NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - electric fan relays only come on for A/C operation
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

electric fan relays only come on for A/C operation

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion
View previous topic :: View next topic  
Author Message
Kyle_in_Tex
Newbie
Newbie


Joined: Jun 20, 2015
Posts: 16
Posts per day: 0.02



PostPosted: Sat Feb 27, 2016 7:24 pm    Post subject:  electric fan relays only come on for A/C operation Reply with quote

What would keep the radiator fan relays from coming on? I haven't let the temp gage go near the red,because it seems like it is getting quite warm when past halfway. The temp gage needle normally stays about 2 marks left of center. It seems maybe the gage could need to be adjusted as it reads a bit cold.
So anyway, if I'm idling in traffic and not getting enough air over the radiator, I've been turning the A/C on which turns on both fans.

One more strange thing with the A/C that has been going on for years. First, the inside environmental fan switch no longer works for the #4 position. I can live with that, but during the summer, (I live in Texas), the A/C will work fine for a few minutes and just really start cooling down the interior and then you hear a faint "click", and then its like the compressor clutch disengages and stops turning the compressor. Here is the strange part, when this is going on, I can hit the brake pedal and hear the exact same "click" like the click is coming from the brake light switch relay under the dash. Weird. Anyway, I can turn off the A/C for a minute, and then turn it on again and it usually will work from then on. But that is a very hot minute...
Any ideas?
Back to top
View user's profile Send private message
Frank
Master Level
Master Level
Platinum Contributor (Amount: 1) Platinum Contributor


Joined: Aug 16, 2005
Posts: 3463
Posts per day: 0.79
Location: Colorado

2001 Chevrolet Impala


PostPosted: Sun Feb 28, 2016 2:24 am    Post subject:   Reply with quote

My only thought is a wiring short in the radiator wires (in which case you should see a service engine soon light), a bad relay (which may or may not cause a light), or a bad fan motor on one side (one fan turns on before the other does) but AC may turn them both on.

Check to see if one of them doesn't turn at all and try swapping the relays to narrow that down. It could also be a bad tune in the PCM if you ever had the car tuned.

If #5 is the highest interior fan setting, you might have a blown blower motor resistor.

As far as the AC cutting out, the first thing I would check are your refrigerant pressures, especially when it gets to the point of cutting out. The clutch will disengage if the pressure sensor on the low side drops below a certain point. Beyond that I would get it scanned to see what is going on.

_________________
2001 Galaxy Silver 9C1 w/ L67 and 4T65E-HD...and a few other mods. Wink
Back to top
View user's profile Send private message
Kyle_in_Tex
Newbie
Newbie


Joined: Jun 20, 2015
Posts: 16
Posts per day: 0.02



PostPosted: Sat Mar 05, 2016 9:33 am    Post subject:   Reply with quote

Frank wrote:
My only thought is a wiring short in the radiator wires (in which case you should see a service engine soon light), a bad relay (which may or may not cause a light), or a bad fan motor on one side (one fan turns on before the other does) but AC may turn them both on.

Check to see if one of them doesn't turn at all and try swapping the relays to narrow that down. It could also be a bad tune in the PCM if you ever had the car tuned.

If #5 is the highest interior fan setting, you might have a blown blower motor resistor.

As far as the AC cutting out, the first thing I would check are your refrigerant pressures, especially when it gets to the point of cutting out. The clutch will disengage if the pressure sensor on the low side drops below a certain point. Beyond that I would get it scanned to see what is going on.


Thanks for the tips, I will check them out. Both radiator fans work fine when I turn on the AC.
Back to top
View user's profile Send private message
Kyle_in_Tex
Newbie
Newbie


Joined: Jun 20, 2015
Posts: 16
Posts per day: 0.02



PostPosted: Sat Apr 16, 2016 9:02 pm    Post subject:   Reply with quote

So the radiator fans are coming on after all. I was just initially overly anal about the temp gage going much past halfway. I was filling it with gas with it idling and no A/C on. I heard the fans kick in and was glad for it.

Lately, I've had it start up with a high idle. It has happened 3 times in the last week. So far, I can turn it off and re-start it and it goes back to normal idling. I've been looking online and many say it is the TPS. I need to charge my laptop and take it out and hook up the OBD cable and see if there's a code. No idiot lights or check engine lights yet.
Back to top
View user's profile Send private message
Frank
Master Level
Master Level
Platinum Contributor (Amount: 1) Platinum Contributor


Joined: Aug 16, 2005
Posts: 3463
Posts per day: 0.79
Location: Colorado

2001 Chevrolet Impala


PostPosted: Sun Apr 17, 2016 11:07 pm    Post subject:   Reply with quote

I would check the IAC first and clean it...just don't pull or push the pintle or you will probably mess it up.

_________________
2001 Galaxy Silver 9C1 w/ L67 and 4T65E-HD...and a few other mods. Wink
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: August 18, 2017, 7:29:13 am
Page Generation: 0.11 Seconds ( SQL 25:104 in 0.01 Seconds )