NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - p0446 code again
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

p0446 code again

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 Engine, Exhaust and Transmission
View previous topic :: View next topic  
Author Message
98ss
Uber
Uber


Joined: Jun 06, 2009
Posts: 812
Posts per day: 0.28
Location: Ann Arbor

2002 Chevrolet Impala
2011 Chevrolet Silverado


PostPosted: Fri Nov 06, 2015 9:32 pm    Post subject:  p0446 code again Reply with quote

Got a P0446 code. Cleaned out the purge vent near the tank...It worked for a few weeks. Then I didn't hear the clicking after driving for a few miles. Thought the valve died. Replaced it and still don't hear it clicking.

I think the problem may be the fuel tank pressure sensor. Anybody know what the resistance should be in the sensor?
Back to top
View user's profile Send private message
2007SSImpala
Dedicated
Dedicated


Joined: Jul 11, 2010
Posts: 344
Posts per day: 0.14
Location: Jacksonville, NC

2007 Chevrolet Impala
2012 Chevrolet Cruze


PostPosted: Sun Nov 22, 2015 6:48 pm    Post subject:   Reply with quote

See if you can get your hands on a cheap scan tool and see what the fuel tank pressure sensor data is. Remove the gas cap and see if the pressure changes, if not, blockage or faulty sensor. Youre not setting any control circuit DTC's for the sensor, so I suspect wiring is okay at this point.

_________________
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
98ss
Uber
Uber


Joined: Jun 06, 2009
Posts: 812
Posts per day: 0.28
Location: Ann Arbor

2002 Chevrolet Impala
2011 Chevrolet Silverado


PostPosted: Mon Nov 23, 2015 7:53 pm    Post subject:   Reply with quote

I actually ordered a fuel tank pressure sensor. I ended up blowing out the vent line and checking the rest of the lines for the canister. I'll post back up when I replace the tank sensor.
Back to top
View user's profile Send private message
98ss
Uber
Uber


Joined: Jun 06, 2009
Posts: 812
Posts per day: 0.28
Location: Ann Arbor

2002 Chevrolet Impala
2011 Chevrolet Silverado


PostPosted: Fri Nov 27, 2015 7:50 pm    Post subject:   Reply with quote

Tank sensor installed. Drove it around, and didn't hear the purge solenoid click, but maybe the code has to be cleared first. Did that tonight. Will drive tomorrow. I guess I check to see if the new purge solenoid is actually good.
Back to top
View user's profile Send private message
98ss
Uber
Uber


Joined: Jun 06, 2009
Posts: 812
Posts per day: 0.28
Location: Ann Arbor

2002 Chevrolet Impala
2011 Chevrolet Silverado


PostPosted: Thu Dec 03, 2015 9:24 pm    Post subject:   Reply with quote

Update. Been a few days and 400 miles later. No light back on.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 Engine, Exhaust and Transmission All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: March 28, 2017, 8:25:57 pm
Page Generation: 0.08 Seconds ( SQL 25:110 in 0.00 Seconds )