NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - Got a problem with my car
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Got a problem with my car

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion
View previous topic :: View next topic  
Author Message
Conner
Forum Regular
Forum Regular


Joined: Jul 17, 2010
Posts: 294
Posts per day: 0.11
Location: Baton Rouge/Hammond, Louisiana

2002 Chevrolet Impala
2004 Chevrolet Impala


PostPosted: Mon May 18, 2015 10:18 am    Post subject:  Got a problem with my car Reply with quote

i have an 04 Indy with 140k. I recently found out that my cat was bad. The car would bog down and sputter when going uphill. I would have to shift down to 2 in order to make this hill. I cnt accelerate hard because it sputters and my RPMS jump up and down. Then my check engine light blinks. If I accelerate lightly in 3rd and then bump up to Drive, the car runs fine. I got my cat cut off and it helped a little bit. Any ideas or opinions?
Back to top
View user's profile Send private message
Frank4202
Senior Level
Senior Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Jul 03, 2008
Posts: 2573
Posts per day: 0.77
Location: Windsor, Ontario, Canada

2004 Chevrolet Impala
1997 Chevrolet Corvette


PostPosted: Mon May 18, 2015 1:25 pm    Post subject:   Reply with quote

Chances are you had a bad misfire which caused the cat to become clogged. Get a code reader and check the codes. Im guessing you have some bad plugs, wires, or coil.

_________________


Sold 28/10/11
Back to top
View user's profile Send private message
Conner
Forum Regular
Forum Regular


Joined: Jul 17, 2010
Posts: 294
Posts per day: 0.11
Location: Baton Rouge/Hammond, Louisiana

2002 Chevrolet Impala
2004 Chevrolet Impala


PostPosted: Mon May 18, 2015 4:29 pm    Post subject:   Reply with quote

Hey Frank thanks for chiming in. Do you think that it could be the MSD wires that I have? Auto lite 104s? Factory stock coils.
Back to top
View user's profile Send private message
PushrodPower
Uberd0rk!
Uberd0rk!
Platinum Contributor (Amount: 1) Platinum Contributor


Joined: Nov 30, 2008
Posts: 6396
Posts per day: 2.01
Location: I love drawing butts on stuff.

2005 Chevrolet Impala
1996 Saturn S-Series


PostPosted: Mon May 18, 2015 6:31 pm    Post subject:   Reply with quote

Frank4202 wrote:
Chances are you had a bad misfire which caused the cat to become clogged. Get a code reader and check the codes. Im guessing you have some bad plugs, wires, or coil.


I back this claim 100%. I had a bad plug cause a CEL to pop on being related to the cat. Had a universal cat put on about 2 years ago. Make sure you don't have anything else besides AC Delco wires and plugs. Any other brands can cause problems. Especially Bosch. Evil or Very Mad

_________________

"The skippers been drinking, oh yes he has you can tell."-Bob Ross
04ImpalaSS wrote:
How much miles are on those seats? How much pounds of ass were applied to the seat during every trip? Lol

wedebrook wrote:
This thread is about *this* far from being about me, all oiled up, eating chili mac in a walmart bathroom.

nightryder wrote:
My c**k broke.
Back to top
View user's profile Send private message
Frank
Master Level
Master Level
Platinum Contributor (Amount: 1) Platinum Contributor


Joined: Aug 16, 2005
Posts: 3464
Posts per day: 0.79
Location: Colorado

2001 Chevrolet Impala


PostPosted: Tue May 19, 2015 12:54 am    Post subject:   Reply with quote

Clogged air and/or fuel filter(s) can cause a misfire as well from the engine going rich or lean. If you haven't replaced those recently, it would be good to do them at the same time. Smile

_________________
2001 Galaxy Silver 9C1 w/ L67 and 4T65E-HD...and a few other mods. Wink
Back to top
View user's profile Send private message
Pitch Black SS
NAIOA Owner / Founder
NAIOA Administrator
NAIOA Administrator


Joined: Mar 08, 2004
Posts: 12754
Posts per day: 2.59
Location: Tullahoma, TN

2004 Chevrolet Impala
1982 Chevrolet Malibu
2007 Chrysler 300C
1986 Chevrolet Monte Carlo


PostPosted: Tue May 19, 2015 11:02 am    Post subject:   Reply with quote

MSD wires are a known "no no" on these cars. They offer little more than stock performance and a whole lot more headaches

_________________
Back to top
View user's profile Send private message Visit poster's website AIM Address
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: August 23, 2017, 2:31:11 pm
Page Generation: 0.11 Seconds ( SQL 27:117 in 0.01 Seconds )