NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - Service Vehicle Soon message?
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Service Vehicle Soon message?

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion
View previous topic :: View next topic  
Author Message
Jayroca
Dedicated
Dedicated


Joined: Jan 28, 2011
Posts: 388
Posts per day: 0.15
Location: Maryland

2007 Chevrolet Impala
2004 Chevrolet Impala


PostPosted: Fri Mar 13, 2015 9:25 am    Post subject:  Service Vehicle Soon message? Reply with quote

Havent been on this forum in a while but i have a few questions if you guys can answer... I recently purchased a 2004 Impala SS indy edition a little while ago for a daily driver and ive noticed that the low beams werent working only high beams... I thought is was the fuses so i checked all fuses they were ok.. I even replaced the headlight switch still no go then i get a service vehicle soon message recently.. Any ideas? Could it be the headlight/turn signal switch held to the sterring wheel? Thanks!

_________________
07 Imp lt converted to a SS Appearance package
04 Indy SS Mods.. XPZ Cam - 130# Springs - Stg 3 Heads - Headers - Gen V - 3.4 to 2.8 Pulley - 60# Injectors
Back to top
View user's profile Send private message
Pitch Black SS
NAIOA Owner / Founder
NAIOA Administrator
NAIOA Administrator


Joined: Mar 08, 2004
Posts: 12756
Posts per day: 2.54
Location: Tullahoma, TN

2004 Chevrolet Impala
1982 Chevrolet Malibu
2007 Chrysler 300C
1986 Chevrolet Monte Carlo


PostPosted: Fri Mar 13, 2015 11:45 am    Post subject:  Re: Service Vehicle Soon message? Reply with quote

Jayroca wrote:
Could it be the headlight/turn signal switch held to the sterring wheel? Thanks!


Very common failure point on these cars. Its called a Multi Function Switch (MFS). It should click when switching from highs to lows.

There are also relays for the headlights in the underhood fuse box. Those are cheap to try also.

As for the SVS light, have to scan the car to see if there are any codes set. Most parts places will do this for free. Get the code and let us know what it is

_________________
Back to top
View user's profile Send private message Visit poster's website AIM Address
BaseLS
Forum Regular
Forum Regular


Joined: Nov 26, 2014
Posts: 239
Posts per day: 0.21
Location: CA

2002 Chevrolet Impala
2002 Chevrolet Blazer
2004 Chevrolet Impala
2002 Pontiac Grand Prix


PostPosted: Fri Mar 13, 2015 7:23 pm    Post subject:   Reply with quote

Supporting PBSS here, My low beams went out and only highs functioned like you mentioned happened to you. I couldn't hear clicking when flipping the Multifunction switch lever so I went straight for that replacement. Verified repair, contacts in the switch body were burnt/broken so no current traveled to low beams. Once I replaced the switch, I regained nighttime visibility Mr. Green

_________________
The LS clone and the SS
Back to top
View user's profile Send private message
Jayroca
Dedicated
Dedicated


Joined: Jan 28, 2011
Posts: 388
Posts per day: 0.15
Location: Maryland

2007 Chevrolet Impala
2004 Chevrolet Impala


PostPosted: Sat Mar 14, 2015 8:23 pm    Post subject:   Reply with quote

Thanks Pitch Black and BaseLs preciate the response i replace all fuses and relays so im just gonna replace the headlight switch scan the codes with my aeroforce and i have no dtcs... So it must be the headlight switch that needs to be replaced

_________________
07 Imp lt converted to a SS Appearance package
04 Indy SS Mods.. XPZ Cam - 130# Springs - Stg 3 Heads - Headers - Gen V - 3.4 to 2.8 Pulley - 60# Injectors
Back to top
View user's profile Send private message
Jayroca
Dedicated
Dedicated


Joined: Jan 28, 2011
Posts: 388
Posts per day: 0.15
Location: Maryland

2007 Chevrolet Impala
2004 Chevrolet Impala


PostPosted: Tue Mar 17, 2015 8:36 am    Post subject:   Reply with quote

Ok so yeah its good to go replaced the multifunctional switch and now its back to normal thats guys low beams and high beams work again!!!

_________________
07 Imp lt converted to a SS Appearance package
04 Indy SS Mods.. XPZ Cam - 130# Springs - Stg 3 Heads - Headers - Gen V - 3.4 to 2.8 Pulley - 60# Injectors
Back to top
View user's profile Send private message
Jayroca
Dedicated
Dedicated


Joined: Jan 28, 2011
Posts: 388
Posts per day: 0.15
Location: Maryland

2007 Chevrolet Impala
2004 Chevrolet Impala


PostPosted: Mon Apr 20, 2015 7:24 pm    Post subject:   Reply with quote

Update on this.. Service vehicle soon message is still on no fog lights low beams cones on hear and there... Not really constistant what would cause the foglights not to work? Its not the bulbs are fine.. When i press the fog light switch it doesnt even light uo. Or come on... Also the turn signals at funny i sometimes have to click the high beams a couple times for the turn signals to operate... Could it be another multifunctional switch gone bad?

_________________
07 Imp lt converted to a SS Appearance package
04 Indy SS Mods.. XPZ Cam - 130# Springs - Stg 3 Heads - Headers - Gen V - 3.4 to 2.8 Pulley - 60# Injectors
Back to top
View user's profile Send private message
Impala_03
Resident
Resident


Joined: Feb 07, 2013
Posts: 603
Posts per day: 0.34


2003 Chevrolet Impala


PostPosted: Tue Apr 21, 2015 1:53 pm    Post subject:   Reply with quote

Jayroca wrote:
Update on this.. Service vehicle soon message is still on no fog lights low beams cones on hear and there... Not really constistant what would cause the foglights not to work? Its not the bulbs are fine.. When i press the fog light switch it doesnt even light uo. Or come on... Also the turn signals at funny i sometimes have to click the high beams a couple times for the turn signals to operate... Could it be another multifunctional switch gone bad?
check the ground wire above the headlight for corrosion a loose connection can make your lights go hay wire.
Back to top
View user's profile Send private message
IffyG
NAIOA Moderator
NAIOA Moderator
Silver Contributor (Amount: 1) Silver Contributor


Joined: May 19, 2007
Posts: 13731
Posts per day: 3.55
Location: Nashville, TN

2002 Chevrolet Monte Carlo
1998 Oldsmobile Intrigue
2009 Chevrolet Malibu


PostPosted: Wed Apr 22, 2015 10:13 am    Post subject:   Reply with quote

Do the lights come on if you you toggle them with the headlight switch? If so, the light sensor that triggers the auto on might be messed up.

_________________
helldorado wrote:
GLWTGFY. Big Thumbs Up

Dan wrote:
Protip: If you don't know what you're doing, don't do it.


d
Back to top
View user's profile Send private message
Jayroca
Dedicated
Dedicated


Joined: Jan 28, 2011
Posts: 388
Posts per day: 0.15
Location: Maryland

2007 Chevrolet Impala
2004 Chevrolet Impala


PostPosted: Thu Apr 23, 2015 7:14 pm    Post subject:   Reply with quote

Ok i will check the ground.. And iffy i see if its a bad switch thanks for the speedy replies

_________________
07 Imp lt converted to a SS Appearance package
04 Indy SS Mods.. XPZ Cam - 130# Springs - Stg 3 Heads - Headers - Gen V - 3.4 to 2.8 Pulley - 60# Injectors
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: December 15, 2017, 3:50:51 pm
Page Generation: 0.10 Seconds ( SQL 33:127 in 0.01 Seconds )