NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - strange grinding noise, only heard at idle, 2007 3.5 flex
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

strange grinding noise, only heard at idle, 2007 3.5 flex

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car!
View previous topic :: View next topic  
Author Message
cosmicbandito
Newbie
Newbie


Joined: Mar 05, 2015
Posts: 3
Posts per day: 0


2007 Chevrolet Impala


PostPosted: Thu Mar 05, 2015 11:18 am    Post subject:  strange grinding noise, only heard at idle, 2007 3.5 flex Reply with quote

Hey guys,
Hoping you can help me diagnose a strange noise I just started hearing in my 2007 Impala. Details follow:

car has approx 115000 on it.
About 2 days ago, I started hearing a strange grinding noise, but only at idle
Only happens when the car is warm (needle about 1/4 up on the water temp gauge)
As soon as I give it any gas, noise goes away.
Happens in park, neutral, and drive
When I listen to it with the hood up, it sounds like it's coming from the driver's side of the block on the lower side.
Sound kind of reminds me of the ABS grinding noise, but obviously it's not the ABS.
All fluids are full and look good, car runs and drives fine, although I think the throttle body need cleaning again. (got the "engine power reduced" message a couple days ago, went away after parking and restarting later, hasn't come back)

Noise is fairly loud, can be heard in the cabin of the car at road speeds

Am planning to tear apart throttle body and clean this weekend, but want some advice as to what else I should be looking at. Water pump? Power steering pump?

Any input appreciated.

Thanks!
Back to top
View user's profile Send private message
cosmicbandito
Newbie
Newbie


Joined: Mar 05, 2015
Posts: 3
Posts per day: 0


2007 Chevrolet Impala


PostPosted: Fri Mar 06, 2015 11:55 am    Post subject:  Re: strange grinding noise, only heard at idle, 2007 3.5 fle Reply with quote

follow up:
This morning, when I get in and go to start the car, I now hear that same noise when I turn the key to "run" but not all the way to start. That's when the fuel system pressurizes right? Or does the power steering pressurize when the switch is turned to "run" as well?
Back to top
View user's profile Send private message
Frank
Master Level
Master Level
Platinum Contributor (Amount: 1) Platinum Contributor


Joined: Aug 16, 2005
Posts: 3466
Posts per day: 0.77
Location: Colorado

2001 Chevrolet Impala


PostPosted: Fri Mar 06, 2015 3:12 pm    Post subject:   Reply with quote

Yes, the fuel pump pressurizes for two seconds when you turn the key to on or acc. Unless the 2006+ has electric power steering, the power steering pump won't start running until the engine starts and the serpentine belt starts turning.

_________________
2001 Galaxy Silver 9C1 w/ L67 and 4T65E-HD...and a few other mods. Wink
Back to top
View user's profile Send private message
cosmicbandito
Newbie
Newbie


Joined: Mar 05, 2015
Posts: 3
Posts per day: 0


2007 Chevrolet Impala


PostPosted: Sat Mar 07, 2015 5:07 pm    Post subject:   Reply with quote

Problem found: throttle body gears were stripped. Noise was high speed flutter in the throttle body when it was "hunting" for proper idle position but couldn't find it due to stripped teeth. Ordered new throttle body off Amazon for about $140. Gears don't appear to be replaceable. Wish they'd make these gears a little tougher.

Thanks for the help folks!



Frank wrote:
Yes, the fuel pump pressurizes for two seconds when you turn the key to on or acc. Unless the 2006+ has electric power steering, the power steering pump won't start running until the engine starts and the serpentine belt
starts turning.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car! All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: December 11, 2017, 9:13:31 am
Page Generation: 0.09 Seconds ( SQL 23:104 in 0.00 Seconds )