NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - 13 Jmpala Trans problem ?????
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

13 Jmpala Trans problem ?????

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car!
View previous topic :: View next topic  
Author Message
rocwal
Newbie
Newbie


Joined: May 15, 2014
Posts: 5
Posts per day: 0
Location: Bradley Maine 04411 USA

2013 Chevrolet Impala


PostPosted: Sun Sep 07, 2014 9:18 pm    Post subject:  13 Jmpala Trans problem ????? Reply with quote

My impala is not shifting after stopping and making a left turn and only at times . it seems to rev up then grabs quick only on left turns . only got 42000 + miles on it going to dealers this week . any suggestions ????

Dan B
Back to top
View user's profile Send private message
9C3
Resident
Resident


Joined: Aug 19, 2012
Posts: 590
Posts per day: 0.33
Location: PALM BEACH FLORIDA

2005 Chevrolet Impala


PostPosted: Mon Sep 08, 2014 12:12 am    Post subject:   Reply with quote

Low ATF level. Had a Dodge do that on left turns. Add ATF to proper level & no more problem. GARY

_________________
2005 9C3 IMPALA
Back to top
View user's profile Send private message
rocwal
Newbie
Newbie


Joined: May 15, 2014
Posts: 5
Posts per day: 0
Location: Bradley Maine 04411 USA

2013 Chevrolet Impala


PostPosted: Mon Sep 08, 2014 7:15 am    Post subject:   Reply with quote

I checked fluid and its at stick full when hot
Back to top
View user's profile Send private message
98ss
Uber
Uber


Joined: Jun 06, 2009
Posts: 817
Posts per day: 0.28
Location: Ann Arbor

2002 Chevrolet Impala
2011 Chevrolet Silverado


PostPosted: Wed Sep 10, 2014 9:45 pm    Post subject:   Reply with quote

Silly question, but did you check it with the car running?
Back to top
View user's profile Send private message
PushrodPower
Uberd0rk!
Uberd0rk!
Platinum Contributor (Amount: 1) Platinum Contributor


Joined: Nov 30, 2008
Posts: 6396
Posts per day: 2.03
Location: I love drawing butts on stuff.

2005 Chevrolet Impala
1996 Saturn S-Series


PostPosted: Thu Sep 11, 2014 12:14 am    Post subject:   Reply with quote

98ss wrote:
Silly question, but did you check it with the car running?


Also, does the owners manual state whether the trans should be hot or cold?

_________________

"The skippers been drinking, oh yes he has you can tell."-Bob Ross
04ImpalaSS wrote:
How much miles are on those seats? How much pounds of ass were applied to the seat during every trip? Lol

wedebrook wrote:
This thread is about *this* far from being about me, all oiled up, eating chili mac in a walmart bathroom.

nightryder wrote:
My c**k broke.
Back to top
View user's profile Send private message
IffyG
NAIOA Moderator
NAIOA Moderator
Silver Contributor (Amount: 1) Silver Contributor


Joined: May 19, 2007
Posts: 13731
Posts per day: 3.69
Location: Nashville, TN

2002 Chevrolet Monte Carlo
1998 Oldsmobile Intrigue
2009 Chevrolet Malibu


PostPosted: Thu Sep 11, 2014 11:39 am    Post subject:   Reply with quote

Take it to the dealer and don't mess with it. Last thing you want to do is give them a reason to void a warranty claim...

_________________
helldorado wrote:
GLWTGFY. Big Thumbs Up

Dan wrote:
Protip: If you don't know what you're doing, don't do it.


d
Back to top
View user's profile Send private message
2008BlueImpalaLTZ
Forum Regular
Forum Regular


Joined: Apr 11, 2009
Posts: 213
Posts per day: 0.07
Location: USA


PostPosted: Thu Sep 11, 2014 5:42 pm    Post subject:   Reply with quote

rocwal wrote:
I checked fluid and its at stick full when hot


How did you check the ATF? That car has the 6-speed automatic transmission. Were you able to remove the large fill cap on the driver side of the transmission? Did it have a dip stick on it?
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car! All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: July 21, 2017, 5:34:44 pm
Page Generation: 0.10 Seconds ( SQL 29:114 in 0.01 Seconds )