NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - AC stopped working today..HELP
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

AC stopped working today..HELP

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion
View previous topic :: View next topic  
Author Message
rc10mike
Dedicated
Dedicated


Joined: Jan 17, 2007
Posts: 434
Posts per day: 0.11
Location: Jacksonville FL

2004 Chevrolet Impala


PostPosted: Sat May 24, 2014 12:20 am    Post subject:  AC stopped working today..HELP Reply with quote

I have an 04 SS with 87k.

Back in 09, I had the compressor replaced for about $1500. It failed because the car sat for 6 months while I was deployed.

Now today, on the start of my Memorial Day weekend, 99* here in FL, my AC worked fine for the first few miles, then with no warning, it started blowing hot. After a few minutes of driving, it blew cold again, then after that it went back to hot.

Further on my way home I noticed the compressor/clutch or belt system was making a very slight squeaking noise, which went away as soon as I turned the AC off.

I could definitely hear the compressor engage when AC was turned on.

Other than that, it still blows hot. So what is it? Compressor or compressor clutch?

_________________
2004 Impala SS:
K&N Intake Kit, ZZP Ceramic Powerlog, ZZP PCM, Hogan DP4 Modular DP, Poly Upper Mounts
Pioneer DEX-P99RS HU, Soundstream HRU.2, Soundstream HRU.4, Image Dynamics IDQ12 x2, Hybrid Audio L6SE & Hybrid Audio L1 Pro R2, 200A Alt
Back to top
View user's profile Send private message
Irish_alley
Resident
Resident


Joined: Dec 13, 2007
Posts: 558
Posts per day: 0.15
Location: De

2004 Chevrolet Impala
1986 GMC Sierra
1994 Chevrolet Silverado
1984 GMC Sierra
1979 Chevrolet Silverado
1991 Chevrolet Silverado


PostPosted: Sat May 24, 2014 12:25 am    Post subject:   Reply with quote

check your pressure.

_________________
Iím SO Much Cooler Online
"Racecar driving is like sex, all men think they are good at it. ď-Jay Leno

Sorry if i'm an a**hole, but i tend to speak whats on my mind and the truth as i see it.. May not be right but it seamed right.
Back to top
View user's profile Send private message AIM Address Yahoo Messenger
Impala_03
Resident
Resident


Joined: Feb 07, 2013
Posts: 603
Posts per day: 0.34


2003 Chevrolet Impala


PostPosted: Sat May 24, 2014 5:33 pm    Post subject:  Re: AC stopped working today..HELP Reply with quote

rc10mike wrote:
I have an 04 SS with 87k.

Back in 09, I had the compressor replaced for about $1500. It failed because the car sat for 6 months while I was deployed.


holy s**t you got scammed Sad


locally it's $464 to get a BRAND ACDELCO new compressor and abs cable installed


that includes labor ,new freon 134a & lube.

the compressor is $160 brand new for 00 to 03 model




$264.39 for 04/05 model


Last edited by Impala_03 on Sat May 24, 2014 5:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
PushrodPower
Uberd0rk!
Uberd0rk!
Platinum Contributor (Amount: 1) Platinum Contributor


Joined: Nov 30, 2008
Posts: 6396
Posts per day: 1.94
Location: I love drawing butts on stuff.

2005 Chevrolet Impala
1996 Saturn S-Series


PostPosted: Sat May 24, 2014 5:41 pm    Post subject:  Re: AC stopped working today..HELP Reply with quote

Impala_03 wrote:
rc10mike wrote:
I have an 04 SS with 87k.

Back in 09, I had the compressor replaced for about $1500. It failed because the car sat for 6 months while I was deployed.


holy s**t you got scammed Sad


locally it's $460 to get a BRAND ACDELCO new compressor and abs cable installed


that includes new freon & lube


It only cost $400 for a brand new compressor on my Impala. $1500 and the damn thing went out already? Shocked Shocked

_________________

"The skippers been drinking, oh yes he has you can tell."-Bob Ross
04ImpalaSS wrote:
How much miles are on those seats? How much pounds of ass were applied to the seat during every trip? Lol

wedebrook wrote:
This thread is about *this* far from being about me, all oiled up, eating chili mac in a walmart bathroom.

nightryder wrote:
My c**k broke.
Back to top
View user's profile Send private message
Impala_03
Resident
Resident


Joined: Feb 07, 2013
Posts: 603
Posts per day: 0.34


2003 Chevrolet Impala


PostPosted: Sat May 24, 2014 5:46 pm    Post subject:  Re: AC stopped working today..HELP Reply with quote

PushrodPower wrote:
Impala_03 wrote:
rc10mike wrote:
I have an 04 SS with 87k.

Back in 09, I had the compressor replaced for about $1500. It failed because the car sat for 6 months while I was deployed.


holy s**t you got scammed Sad


locally it's $460 to get a BRAND ACDELCO new compressor and abs cable installed


that includes new freon & lube


It only cost $400 for a brand new compressor on my Impala. $1500 and the damn thing went out already? Shocked Shocked



my includes installation of ABS cable as well other wise it would be close to 400$


SS should be around 600-700$ since extra work is involved with it.(I'd assume some things need to be removed to get to the compressor )


Last edited by Impala_03 on Sat May 24, 2014 5:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
PushrodPower
Uberd0rk!
Uberd0rk!
Platinum Contributor (Amount: 1) Platinum Contributor


Joined: Nov 30, 2008
Posts: 6396
Posts per day: 1.94
Location: I love drawing butts on stuff.

2005 Chevrolet Impala
1996 Saturn S-Series


PostPosted: Sat May 24, 2014 5:49 pm    Post subject:  Re: AC stopped working today..HELP Reply with quote

Impala_03 wrote:
PushrodPower wrote:
Impala_03 wrote:
rc10mike wrote:
I have an 04 SS with 87k.

Back in 09, I had the compressor replaced for about $1500. It failed because the car sat for 6 months while I was deployed.


holy s**t you got scammed Sad


locally it's $460 to get a BRAND ACDELCO new compressor and abs cable installed


that includes new freon & lube


It only cost $400 for a brand new compressor on my Impala. $1500 and the damn thing went out already? Shocked Shocked



my includes installation of ABS cable as well other wise it would be close to 400$


I was just referring too rc10mikes post. I've never heard of it costing that much unless it came with a new engine or trans. Laughing

_________________

"The skippers been drinking, oh yes he has you can tell."-Bob Ross
04ImpalaSS wrote:
How much miles are on those seats? How much pounds of ass were applied to the seat during every trip? Lol

wedebrook wrote:
This thread is about *this* far from being about me, all oiled up, eating chili mac in a walmart bathroom.

nightryder wrote:
My c**k broke.
Back to top
View user's profile Send private message
Impala_03
Resident
Resident


Joined: Feb 07, 2013
Posts: 603
Posts per day: 0.34


2003 Chevrolet Impala


PostPosted: Sat May 24, 2014 5:51 pm    Post subject:  Re: AC stopped working today..HELP Reply with quote

PushrodPower wrote:
Impala_03 wrote:
PushrodPower wrote:
Impala_03 wrote:
rc10mike wrote:
I have an 04 SS with 87k.

Back in 09, I had the compressor replaced for about $1500. It failed because the car sat for 6 months while I was deployed.


holy s**t you got scammed Sad


locally it's $460 to get a BRAND ACDELCO new compressor and abs cable installed


that includes new freon & lube


It only cost $400 for a brand new compressor on my Impala. $1500 and the damn thing went out already? Shocked Shocked



my includes installation of ABS cable as well other wise it would be close to 400$


I was just referring too rc10mikes post. I've never heard of it costing that much unless it came with a new engine or trans. Laughing



SS should be around 600-700$ since extra work is involved with it.(I'd assume some things need to be removed to get to the compressor )
Back to top
View user's profile Send private message
rc10mike
Dedicated
Dedicated


Joined: Jan 17, 2007
Posts: 434
Posts per day: 0.11
Location: Jacksonville FL

2004 Chevrolet Impala


PostPosted: Sun May 25, 2014 1:58 pm    Post subject:   Reply with quote

Well, found out what the issue was.

Turns out, the front plate on the compressor clutch has a splined input for the spline on the compressor shaft, both of which were stripped out. I found the head of the bolt as well as the thread part that holds the plate on right below the compressor sitting on the frame. Seems like faulty maintenance to me, there wasnt any loctite on that 1 bolt.

_________________
2004 Impala SS:
K&N Intake Kit, ZZP Ceramic Powerlog, ZZP PCM, Hogan DP4 Modular DP, Poly Upper Mounts
Pioneer DEX-P99RS HU, Soundstream HRU.2, Soundstream HRU.4, Image Dynamics IDQ12 x2, Hybrid Audio L6SE & Hybrid Audio L1 Pro R2, 200A Alt
Back to top
View user's profile Send private message
PushrodPower
Uberd0rk!
Uberd0rk!
Platinum Contributor (Amount: 1) Platinum Contributor


Joined: Nov 30, 2008
Posts: 6396
Posts per day: 1.94
Location: I love drawing butts on stuff.

2005 Chevrolet Impala
1996 Saturn S-Series


PostPosted: Sun May 25, 2014 4:19 pm    Post subject:   Reply with quote

rc10mike wrote:
Well, found out what the issue was.

Turns out, the front plate on the compressor clutch has a splined input for the spline on the compressor shaft, both of which were stripped out. I found the head of the bolt as well as the thread part that holds the plate on right below the compressor sitting on the frame. Seems like faulty maintenance to me, there wasnt any loctite on that 1 bolt.


I'm glad you found the problem. Now you know where too start. I'm sorry I gave you a bit of hard time.

_________________

"The skippers been drinking, oh yes he has you can tell."-Bob Ross
04ImpalaSS wrote:
How much miles are on those seats? How much pounds of ass were applied to the seat during every trip? Lol

wedebrook wrote:
This thread is about *this* far from being about me, all oiled up, eating chili mac in a walmart bathroom.

nightryder wrote:
My c**k broke.
Back to top
View user's profile Send private message
rc10mike
Dedicated
Dedicated


Joined: Jan 17, 2007
Posts: 434
Posts per day: 0.11
Location: Jacksonville FL

2004 Chevrolet Impala


PostPosted: Sun May 25, 2014 11:10 pm    Post subject:   Reply with quote

I had a bunch of other stuff replaced last time too hence the cost.

I replaced the M6 bolt that holds the front clutch plate on. I wasnt expecting it to work due to the spline being completely stripped....but I have A/C again.

Who knows...maybe the new M6 bolt will hold up.

_________________
2004 Impala SS:
K&N Intake Kit, ZZP Ceramic Powerlog, ZZP PCM, Hogan DP4 Modular DP, Poly Upper Mounts
Pioneer DEX-P99RS HU, Soundstream HRU.2, Soundstream HRU.4, Image Dynamics IDQ12 x2, Hybrid Audio L6SE & Hybrid Audio L1 Pro R2, 200A Alt
Back to top
View user's profile Send private message
rc10mike
Dedicated
Dedicated


Joined: Jan 17, 2007
Posts: 434
Posts per day: 0.11
Location: Jacksonville FL

2004 Chevrolet Impala


PostPosted: Fri Jun 06, 2014 8:22 am    Post subject:   Reply with quote

Figured I would give a update here.

The new bolt I installed also broke a few days later, no surprise there, since the splines were stripped.

I called the dealer and they claimed I only paid $888 for the entire repair back in 09. I told them I have the receipt showing $1450.

Their system showed that a new compressor was never installed, hence the price difference.

They claimed their computer system went through some updates since then and the information wasnt transferred correctly.

I said its kind of funny the system lost the single most expensive part of the whole repair, and I have a $1500 repair that only lasted 30k miles.

I believe they never actually replaced the compressor the first time I took it in, but they charged me for it accordingly...

I argued that they have no real proof the compressor was changed since their system wasnt showing it.

After that, they then said the compressor has a lifetime warranty and they fixed everything for free...

Weird, fishy, strange...

_________________
2004 Impala SS:
K&N Intake Kit, ZZP Ceramic Powerlog, ZZP PCM, Hogan DP4 Modular DP, Poly Upper Mounts
Pioneer DEX-P99RS HU, Soundstream HRU.2, Soundstream HRU.4, Image Dynamics IDQ12 x2, Hybrid Audio L6SE & Hybrid Audio L1 Pro R2, 200A Alt
Back to top
View user's profile Send private message
Frank
Master Level
Master Level
Platinum Contributor (Amount: 1) Platinum Contributor


Joined: Aug 16, 2005
Posts: 3466
Posts per day: 0.77
Location: Colorado

2001 Chevrolet Impala


PostPosted: Fri Jun 06, 2014 5:22 pm    Post subject:   Reply with quote

My guess is they either found notes on the original invoice saying they changed the compressor or it was a different invoice...they could have also pulled it apart and saw that it was replaced at some point.

Strange, but at least they took care of you.

_________________
2001 Galaxy Silver 9C1 w/ L67 and 4T65E-HD...and a few other mods. Wink
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: December 12, 2017, 12:08:25 pm
Page Generation: 0.13 Seconds ( SQL 39:131 in 0.01 Seconds )