NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - Odd electrical issues
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Odd electrical issues

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion
View previous topic :: View next topic  
Author Message
QuickNick
Forum Regular
Forum Regular


Joined: May 27, 2013
Posts: 196
Posts per day: 0.12


2004 Chevrolet Impala


PostPosted: Sun Apr 06, 2014 6:56 pm    Post subject:  Odd electrical issues Reply with quote

Not sure what I'm chasing so I'll just give the issues & see what happens. I havent driven the car since November of last year (parked it for the long as heck winter). I did a lot of things to it over the winter, mainly suspension & brake related but I did a couple normal maintenance things on the motor -throttle body clean, valve cover gaskets, coolant hose replacements, ect.

Now, I noticed I DONT have to hit the brake before shifting out of park. Shouldnt I? Also, the cruise control does not work. It did before. When I turn it on via the "stalk" I get no "cruise" light on the dash. I've banged on the steering wheel buttons with no difference. The stalk does feel a little "wonky" when switching from low to high beams.

Its been six months since I've driven the car, but this wasnt an issue before. Not really concerned about the "brake to shift" issue but the cruise issue is annoying, I'm thinking they must be related. I checked all the fuses on both sides of the dash & all were good.

Totally lost. What should I be looking at? Is the turn signal switch (stalk) maybe it?
Thanks!
Back to top
View user's profile Send private message
Pitch Black SS
NAIOA Owner / Founder
NAIOA Administrator
NAIOA Administrator


Joined: Mar 08, 2004
Posts: 12756
Posts per day: 2.55
Location: Tullahoma, TN

2004 Chevrolet Impala
1982 Chevrolet Malibu
2007 Chrysler 300C
1986 Chevrolet Monte Carlo


PostPosted: Mon Apr 07, 2014 2:02 pm    Post subject:   Reply with quote

the cruise is probably the MFS (Multi-Function Switch aka turn signal stalk) They are known to fail

The brake / shift is probably the shift interlock switch. I believe its behind the brake pedal. Not a concern to most when it breaks and you can shift. Most of the time if breaks and it gets stuck in park.

_________________
Back to top
View user's profile Send private message Visit poster's website AIM Address
9C3
Resident
Resident


Joined: Aug 19, 2012
Posts: 591
Posts per day: 0.31
Location: PALM BEACH FLORIDA

2005 Chevrolet Impala


PostPosted: Mon Apr 07, 2014 3:39 pm    Post subject:   Reply with quote

Pitch Black SS wrote:
the cruise is probably the MFS (Multi-Function Switch aka turn signal stalk) They are known to fail
I sold plenty of these at the back parts counter. GARY

_________________
2005 9C3 IMPALA
Back to top
View user's profile Send private message
Pitch Black SS
NAIOA Owner / Founder
NAIOA Administrator
NAIOA Administrator


Joined: Mar 08, 2004
Posts: 12756
Posts per day: 2.55
Location: Tullahoma, TN

2004 Chevrolet Impala
1982 Chevrolet Malibu
2007 Chrysler 300C
1986 Chevrolet Monte Carlo


PostPosted: Mon Apr 07, 2014 5:00 pm    Post subject:   Reply with quote

9C3 wrote:
Pitch Black SS wrote:
the cruise is probably the MFS (Multi-Function Switch aka turn signal stalk) They are known to fail
I sold plenty of these at the back parts counter. GARY


Its very common, had both my 02LS and my 04SS fail, fortunately they were both under warranty

_________________
Back to top
View user's profile Send private message Visit poster's website AIM Address
QuickNick
Forum Regular
Forum Regular


Joined: May 27, 2013
Posts: 196
Posts per day: 0.12


2004 Chevrolet Impala


PostPosted: Tue Apr 08, 2014 1:52 pm    Post subject:   Reply with quote

Thanks!
That does make sense. I noticed when I switch to high beams sometimes it "clicks" and sometimes it doesn't (lights still change but no physical "click" feel on the stalk). Man, thats not fun to change Laughing

I'll take a look at the brake interlock switch. I always hated the "press brake to shift" deal & actually like it better broken. I might have gotten a little crazy bleeding the brakes. Looks like a few gremlins (not the AMC kind) got to the car over the winter!
Back to top
View user's profile Send private message
IffyG
NAIOA Moderator
NAIOA Moderator
Silver Contributor (Amount: 1) Silver Contributor


Joined: May 19, 2007
Posts: 13731
Posts per day: 3.57
Location: Nashville, TN

2002 Chevrolet Monte Carlo
1998 Oldsmobile Intrigue
2009 Chevrolet Malibu


PostPosted: Tue Apr 08, 2014 4:04 pm    Post subject:   Reply with quote

QuickNick wrote:
Thanks!
That does make sense. I noticed when I switch to high beams sometimes it "clicks" and sometimes it doesn't (lights still change but no physical "click" feel on the stalk). Man, thats not fun to change Laughing


That's a dead giveaway the switch is failing. Mine was like that for years until all of the sudden it left me with no headlights at all.

_________________
helldorado wrote:
GLWTGFY. Big Thumbs Up

Dan wrote:
Protip: If you don't know what you're doing, don't do it.


d
Back to top
View user's profile Send private message
Irish_alley
Resident
Resident


Joined: Dec 13, 2007
Posts: 558
Posts per day: 0.15
Location: De

2004 Chevrolet Impala
1986 GMC Sierra
1994 Chevrolet Silverado
1984 GMC Sierra
1979 Chevrolet Silverado
1991 Chevrolet Silverado


PostPosted: Wed Apr 16, 2014 6:46 am    Post subject:   Reply with quote

my switch if you dont pull on it all the way it will do the "no click" but in order to disengage them you have to pull on it again to get the click. i still have cruise.

but since the car thinks you are pressing on the brakes to disengage the park lock do to the switch malfunction. dont you think the same malfunction it telling the cruise control to disengage cause you are "pressing" on the brakes. you two problems might be cause of one problem and they are related

_________________
Iím SO Much Cooler Online
"Racecar driving is like sex, all men think they are good at it. ď-Jay Leno

Sorry if i'm an a**hole, but i tend to speak whats on my mind and the truth as i see it.. May not be right but it seamed right.
Back to top
View user's profile Send private message AIM Address Yahoo Messenger
QuickNick
Forum Regular
Forum Regular


Joined: May 27, 2013
Posts: 196
Posts per day: 0.12


2004 Chevrolet Impala


PostPosted: Mon May 12, 2014 7:28 pm    Post subject:   Reply with quote

Update-
Wow I dont drive the car enough! I was goofing around & found the stoplight switch on the pedal wasnt working. No brakelights, just a 3rd brake light only. I messed with the original switch & it was really worn, so for $10 I got a new one and presto! Cruise works, "hit brakes to shift from park" works, all good now Very Happy The last 1,000 miles have been with no brake lights-ouch!

I'll throw in a new turn signal switch soon, but the gremlins are going away! Thanks Cool
Back to top
View user's profile Send private message
Irish_alley
Resident
Resident


Joined: Dec 13, 2007
Posts: 558
Posts per day: 0.15
Location: De

2004 Chevrolet Impala
1986 GMC Sierra
1994 Chevrolet Silverado
1984 GMC Sierra
1979 Chevrolet Silverado
1991 Chevrolet Silverado


PostPosted: Wed May 14, 2014 12:24 am    Post subject:   Reply with quote

lmao i hope i was on my phone (cause its hard even for me to follow) when i wrote that post but glad you got those problems out of the way

_________________
Iím SO Much Cooler Online
"Racecar driving is like sex, all men think they are good at it. ď-Jay Leno

Sorry if i'm an a**hole, but i tend to speak whats on my mind and the truth as i see it.. May not be right but it seamed right.
Back to top
View user's profile Send private message AIM Address Yahoo Messenger
QuickNick
Forum Regular
Forum Regular


Joined: May 27, 2013
Posts: 196
Posts per day: 0.12


2004 Chevrolet Impala


PostPosted: Thu May 15, 2014 7:22 pm    Post subject:   Reply with quote

Thanks Irish! Laughing
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: November 23, 2017, 1:46:58 am
Page Generation: 0.12 Seconds ( SQL 35:134 in 0.01 Seconds )