NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - accelerator stuck?
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

accelerator stuck?

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 Engine, Exhaust and Transmission
View previous topic :: View next topic  
Author Message
t3chn06789
Resident
Resident


Joined: Aug 10, 2009
Posts: 684
Posts per day: 0.23
Location: Cali.

2003 Chevrolet Impala


PostPosted: Sun Sep 15, 2013 9:22 pm    Post subject:  accelerator stuck? Reply with quote

Its been a few days that my car is idling high im on a red light and it sounds like im power braking
Confused

Its random sometimes it will run fine sometimes it will seem that the accelerator is stuck.

I cleaned out the Idle senor
and bought a new tps sensor and its still doing the same thing.



I saw a vaccum hose coming from the pcv valve looks pretty worn and its getting sucked so hard it closes
and also im getting a P0401 code..


any help/tips on what to replace? Shocked

Uploaded with ImageShack.com
Uploaded with ImageShack.com

_________________
Back to top
View user's profile Send private message
lostwrench
Forum Regular
Forum Regular


Joined: Jan 12, 2007
Posts: 271
Posts per day: 0.07
Location: Ct.

2004 Chevrolet Impala
2009 Chevrolet Impala


PostPosted: Sun Sep 15, 2013 10:35 pm    Post subject:   Reply with quote

Replace the failing hose. Air leaks will affect the RPM.
Back to top
View user's profile Send private message
t3chn06789
Resident
Resident


Joined: Aug 10, 2009
Posts: 684
Posts per day: 0.23
Location: Cali.

2003 Chevrolet Impala


PostPosted: Mon Sep 16, 2013 11:45 am    Post subject:   Reply with quote

changed the cracked hose and it still doing the same thing... Confused

_________________
Back to top
View user's profile Send private message
Impala_03
Resident
Resident


Joined: Feb 07, 2013
Posts: 603
Posts per day: 0.35


2003 Chevrolet Impala


PostPosted: Mon Sep 16, 2013 1:01 pm    Post subject:   Reply with quote

t3chn06789 wrote:
changed the cracked hose and it still doing the same thing... Confused


The DPFE (differential pressure feedback EGR) sensor is faulty and needs to be replaced
There is a blockage in the EGR (tube), most likely carbon buildup
The EGR valve is faulty The EGR valve may not be opening due to a lack of vaccuum

Read more at: http://www.obd-codes.com/p0401
Back to top
View user's profile Send private message
t3chn06789
Resident
Resident


Joined: Aug 10, 2009
Posts: 684
Posts per day: 0.23
Location: Cali.

2003 Chevrolet Impala


PostPosted: Tue Sep 24, 2013 4:28 pm    Post subject:   Reply with quote

intake hose had a rip Rolling Eyes

_________________
Back to top
View user's profile Send private message
t3chn06789
Resident
Resident


Joined: Aug 10, 2009
Posts: 684
Posts per day: 0.23
Location: Cali.

2003 Chevrolet Impala


PostPosted: Tue Oct 01, 2013 6:43 pm    Post subject:   Reply with quote

Nope..
Its doing it again...
Checked the vacuum hoses
Cleaned the trottle body
Cleaned egr
New tps sensor
Cleaned idle control sensor


Any ideas? -_-'

_________________
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 Engine, Exhaust and Transmission All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: October 19, 2017, 10:31:58 pm
Page Generation: 0.08 Seconds ( SQL 27:108 in 0.00 Seconds )