NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - 07 impala blower motor
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

07 impala blower motor

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car!
View previous topic :: View next topic  
Author Message
dtestworkin
Newbie
Newbie


Joined: Jun 13, 2008
Posts: 33
Posts per day: 0.01


2004 Chevrolet Impala


PostPosted: Tue Jul 23, 2013 9:31 am    Post subject:  07 impala blower motor Reply with quote

has anyone had a problem with their blower motor not working and it not being the resistor or the motor? the fan will not work on my car so I switched the blower motor and resistor and still nothing. I switched the climate head and still nothing. Is there something that is common that goes bad with these? thanks
Back to top
View user's profile Send private message
05imp
Senior Level
Senior Level


Joined: Jan 01, 2006
Posts: 2302
Posts per day: 0.54
Location: Cleveland, OH

2005 Chevrolet Impala
2000 Ford Ranger
2007 Ford Explorer
2008 Chevrolet Silverado


PostPosted: Tue Jul 23, 2013 4:07 pm    Post subject:   Reply with quote

Did you check the main blower motor fuse under the hood?
Back to top
View user's profile Send private message
dtestworkin
Newbie
Newbie


Joined: Jun 13, 2008
Posts: 33
Posts per day: 0.01


2004 Chevrolet Impala


PostPosted: Tue Jul 23, 2013 4:11 pm    Post subject:   Reply with quote

Nothing under the hood says anything about either blower or hvac. I also tried to find it in the owners manual but with no luck.
Back to top
View user's profile Send private message
2007SSImpala
Dedicated
Dedicated


Joined: Jul 11, 2010
Posts: 344
Posts per day: 0.13
Location: Jacksonville, NC

2007 Chevrolet Impala
2012 Chevrolet Cruze


PostPosted: Tue Jul 23, 2013 9:09 pm    Post subject:   Reply with quote



I'm assuming your underhood fuse panel is like this one.

Check the AIRBAG/DISPLAY Fuse for an open. This controls the HVAC Control Module. But it also controls other things like the IPC and airbag indicators. So you may find this fuse is ok.

There is a fuse called BATT 4, its a 30A fuse. This is the blower motor control processor fuse. Check that one for an open. Let us know...
High resistence in the previous blower motor mave have caused this fuse to open.

_________________
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car! All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: September 21, 2017, 10:41:50 am
Page Generation: 0.09 Seconds ( SQL 23:107 in 0.01 Seconds )