NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - car wont stay on sometimes.
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

car wont stay on sometimes.
Goto page 1, 2  Next
 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion
View previous topic :: View next topic  
Author Message
norcal_impala
Newbie
Newbie


Joined: Oct 31, 2012
Posts: 46
Posts per day: 0.02


2004 Chevrolet Impala
2005 Chevrolet Impala
2014 Chevrolet Impala


PostPosted: Fri Feb 01, 2013 11:34 am    Post subject: Beark ! car wont stay on sometimes. Reply with quote

so I go to turn on my car in the mornings or anytime and if I turn on my key to the run position in 2 seconds it won't start.before it would.now I have to put the key in the ignition,listen to the fuel pump,pray it starts n then turn the key over.sometimes it works and sometimes the car won't start like if I'm not getting no fuel.cold or hot engine,problem still happens sometimes.I bought my car in 09,haven't done a fuel filter and plugs &wires.also noticed my battery is leaking acid.also there's no check engine light. any help is appreciated.. thank you.
Back to top
View user's profile Send private message
Lingenfelter
Uberd0rk!
Uberd0rk!
Gold Contributor (Amount: 1) Gold Contributor


Joined: Oct 21, 2006
Posts: 9331
Posts per day: 2.31
Location: Ontario, Canada

2003 Chevrolet Impala
1999 Yugo Tempo


PostPosted: Fri Feb 01, 2013 12:26 pm    Post subject:   Reply with quote

More information would be helpful. What is the year and engine combination of your car? How many miles or kilometres are on it?

A leaking battery should be replaced - batteries usually only last about 6 years, but I don't know how old your car is.

I believe the service interval for fuel filters on the 00-05 models is 35,000 miles (or maybe 35,000 kilometres, It's been a while since I checked). This is a commonly overlooked service item for a lot of people.

I think plugs and wires are a maintenance item roughly every 100,000 miles - but again, I could be wrong - I haven't changed mine in a couple of years.

Check your owners manual for the service intervals on these items and post your mileage, model year and engine. I suspect the battery is a good place to start, though.

_________________
uıɐƃɐ ʎɐqǝ ɯoɹɟ pɹɐoqʎǝʞ ɐ ƃuıʎnq ɹǝʌǝu ɯɐ ı

GMPP Duals, GMPP Handling Kit, NAIOA FWI V2, Silverstar Hi/Lo/Fogs, Viper 5900 Remote Start/Security.
Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
topgun
Resident
Resident


Joined: May 19, 2011
Posts: 639
Posts per day: 0.27
Location: Upstate N Y

2005 Chevrolet Impala


PostPosted: Fri Feb 01, 2013 8:08 pm    Post subject:  start Reply with quote

First - Change fuel filter. Second - check fuel pressure. Cool

_________________
Untamed . . . and don't try to change me
Back to top
View user's profile Send private message
norcal_impala
Newbie
Newbie


Joined: Oct 31, 2012
Posts: 46
Posts per day: 0.02


2004 Chevrolet Impala
2005 Chevrolet Impala
2014 Chevrolet Impala


PostPosted: Sat Feb 02, 2013 1:27 pm    Post subject:   Reply with quote

my car is a 04 impala ls 3800 V6.milage is 145000.I bought the car in 09 and the only thing ive done to my car since then is oil changes and a o2 sensor.also I been meaning to change the fuel filter its just that I bought it in Florida and it has a lil rust.so I'm afraid of stripping threads or worse.
Back to top
View user's profile Send private message
Lingenfelter
Uberd0rk!
Uberd0rk!
Gold Contributor (Amount: 1) Gold Contributor


Joined: Oct 21, 2006
Posts: 9331
Posts per day: 2.31
Location: Ontario, Canada

2003 Chevrolet Impala
1999 Yugo Tempo


PostPosted: Sat Feb 02, 2013 2:14 pm    Post subject:   Reply with quote

fuel filter, OEM plugs and wires, and a new battery should be a good start, if they don't eliminate the problem altogether.

_________________
uıɐƃɐ ʎɐqǝ ɯoɹɟ pɹɐoqʎǝʞ ɐ ƃuıʎnq ɹǝʌǝu ɯɐ ı

GMPP Duals, GMPP Handling Kit, NAIOA FWI V2, Silverstar Hi/Lo/Fogs, Viper 5900 Remote Start/Security.
Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
topgun
Resident
Resident


Joined: May 19, 2011
Posts: 639
Posts per day: 0.27
Location: Upstate N Y

2005 Chevrolet Impala


PostPosted: Sat Feb 02, 2013 3:21 pm    Post subject:  fuel filter Reply with quote

A lil rust you say, just adds to the fun. WD 40, thread buster, PB blaster (best stuff) soak fuel filter treads with this. Let sit 5 minutes or so. Use flare nut wrench on line side. If still to rusted to turn line fitting try unscrewing the filter from the line nut. Cool

_________________
Untamed . . . and don't try to change me
Back to top
View user's profile Send private message
norcal_impala
Newbie
Newbie


Joined: Oct 31, 2012
Posts: 46
Posts per day: 0.02


2004 Chevrolet Impala
2005 Chevrolet Impala
2014 Chevrolet Impala


PostPosted: Sat Feb 02, 2013 9:46 pm    Post subject:   Reply with quote

Thanx guys ill try it .ill keep in touch to update
Back to top
View user's profile Send private message
chibiblacksheep
Member Level
Member Level


Joined: Dec 14, 2009
Posts: 1369
Posts per day: 0.47
Location: Philadelphia, PA

2000 Chevrolet Monte Carlo
2007 Chevrolet Impala
1968 Chevrolet Camaro
2013 Chevrolet Camaro


PostPosted: Tue Feb 05, 2013 12:47 pm    Post subject:   Reply with quote

Unplug the MAF and try to start it.

_________________
Back to top
View user's profile Send private message Send e-mail AIM Address
norcal_impala
Newbie
Newbie


Joined: Oct 31, 2012
Posts: 46
Posts per day: 0.02


2004 Chevrolet Impala
2005 Chevrolet Impala
2014 Chevrolet Impala


PostPosted: Sun Feb 10, 2013 1:09 am    Post subject:   Reply with quote

key on engine off car won't start.I've notice the fuel gauge temperature gauge and rpm gauge don't move,but usually they move,but not only that,the gauge marks empty temp gauge marks child when I have half tank of gas n the car has been running for 3 hours.So confused.And after I try n starting the vehicle the motor starts shaking like if it's misfiring like 4 cylinders.very bad.n were it usually tells me what gear I'm at in the dash those disappear n only the tripometer shows.im starting to think is a pcm problem.
Back to top
View user's profile Send private message
topgun
Resident
Resident


Joined: May 19, 2011
Posts: 639
Posts per day: 0.27
Location: Upstate N Y

2005 Chevrolet Impala


PostPosted: Sun Feb 10, 2013 9:55 am    Post subject:  start Reply with quote

OK, I can't decipher this one . . . Cool

_________________
Untamed . . . and don't try to change me
Back to top
View user's profile Send private message
00impala123
Senior Level
Senior Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Feb 01, 2010
Posts: 2653
Posts per day: 0.93
Location: Chicago, IL

2000 Chevrolet Impala


PostPosted: Sun Feb 10, 2013 12:27 pm    Post subject:   Reply with quote

Sounds like an electrical problem for sure.

_________________
Back to top
View user's profile Send private message
norcal_impala
Newbie
Newbie


Joined: Oct 31, 2012
Posts: 46
Posts per day: 0.02


2004 Chevrolet Impala
2005 Chevrolet Impala
2014 Chevrolet Impala


PostPosted: Sun Feb 10, 2013 12:47 pm    Post subject:   Reply with quote

yup it does.the only aftermarket stuff I have on my car is a radio which to my research and understanding it's discontinued lol.So I wonder if it's messing around with the cars computer?and this started to happen after the radio was installed so today I'm going to install the stock radio back on.
Back to top
View user's profile Send private message
topgun
Resident
Resident


Joined: May 19, 2011
Posts: 639
Posts per day: 0.27
Location: Upstate N Y

2005 Chevrolet Impala


PostPosted: Sun Feb 10, 2013 4:50 pm    Post subject:  start Reply with quote

Rolling Eyes

_________________
Untamed . . . and don't try to change me
Back to top
View user's profile Send private message
drew7997
Cadet
Cadet


Joined: Apr 10, 2009
Posts: 54
Posts per day: 0.02
Location: Akron, OH

2005 Chevrolet Impala
2003 Chevrolet Malibu


PostPosted: Mon Feb 11, 2013 8:42 am    Post subject:   Reply with quote

Norcal,
Have you had the battery checked? Pull the battery and take it to a auto parts store (advance auto, autozone, oreilys) they can provide you a verbal or printed answer.
Batteries dont leak fluid for no reason. Start there before replacing radio.

Drew
Back to top
View user's profile Send private message MSN Messenger
norcal_impala
Newbie
Newbie


Joined: Oct 31, 2012
Posts: 46
Posts per day: 0.02


2004 Chevrolet Impala
2005 Chevrolet Impala
2014 Chevrolet Impala


PostPosted: Thu Feb 14, 2013 11:00 am    Post subject:   Reply with quote

So I've checked my fuel psi and I'm good.My battery is good.I hooked on a scanner and I had 9 bcm history codes but nothing current.for some reason one of the codes was onstar,but my car doesn't come with it.And I had a U1000 class 2 communication error from bcm to pcm.And the rest of the codes were signal errors from the driver side unlock lock switch.that switch broke so I've been uusing a screwdriver to scroll up n down window.maybe I've been throwing off the bcm since the driverside switch is controkling all the Windows and locks.And maybe my car doesn't lock or unlock doors 100% so my security system disables my fuel n spark.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion All times are GMT - 4 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: November 18, 2017, 10:47:19 pm
Page Generation: 0.13 Seconds ( SQL 45:146 in 0.02 Seconds )