NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - Freeze plugs.
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Freeze plugs.

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 Engine, Exhaust and Transmission
View previous topic :: View next topic  
Author Message
t3chn06789
Resident
Resident


Joined: Aug 10, 2009
Posts: 684
Posts per day: 0.23
Location: Cali.

2003 Chevrolet Impala


PostPosted: Tue Jan 22, 2013 7:41 pm    Post subject: Question Freeze plugs. Reply with quote

Has anyone replaced the freeze plugs on a 3.4 engine?Are they really hard to ? Question

_________________
Back to top
View user's profile Send private message
2007SSImpala
Dedicated
Dedicated


Joined: Jul 11, 2010
Posts: 344
Posts per day: 0.13
Location: Jacksonville, NC

2007 Chevrolet Impala
2012 Chevrolet Cruze


PostPosted: Tue Jan 22, 2013 10:14 pm    Post subject:   Reply with quote

Not bad, time consuming....but not bad. Which one is leaking?

_________________
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
t3chn06789
Resident
Resident


Joined: Aug 10, 2009
Posts: 684
Posts per day: 0.23
Location: Cali.

2003 Chevrolet Impala


PostPosted: Tue Jan 22, 2013 11:03 pm    Post subject:   Reply with quote

they told me its a freeze plug theres a leak on the passenger side but i cant see anything its not the radiator hose or water pump

_________________
Back to top
View user's profile Send private message
2007SSImpala
Dedicated
Dedicated


Joined: Jul 11, 2010
Posts: 344
Posts per day: 0.13
Location: Jacksonville, NC

2007 Chevrolet Impala
2012 Chevrolet Cruze


PostPosted: Wed Jan 23, 2013 12:19 am    Post subject:   Reply with quote

I can't remember if the V6 has the same ECT setup as the V8. But I know there is a whole for a Engine Coolant Temperature sensor on the passenger side cylinder head that will leak sometimes on V8's. it's at the backside of the head. In your case looking at the front of the car, back cylinder head furthest to the drivers side. If this is it, it's a simple as removing the plug and adding some sealant to the threads and reinstall man. Common issue on the V8's.

_________________
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
t3chn06789
Resident
Resident


Joined: Aug 10, 2009
Posts: 684
Posts per day: 0.23
Location: Cali.

2003 Chevrolet Impala


PostPosted: Thu Jan 24, 2013 12:37 am    Post subject:   Reply with quote

But I have a v6 3.4

_________________
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 Engine, Exhaust and Transmission All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: November 19, 2017, 8:05:49 am
Page Generation: 0.09 Seconds ( SQL 25:107 in 0.01 Seconds )