NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - no display...other symptoms
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

no display...other symptoms

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion
View previous topic :: View next topic  
Author Message
ksjkato
Newbie
Newbie


Joined: Mar 04, 2010
Posts: 38
Posts per day: 0.01


2001 Chevrolet Impala


PostPosted: Thu Dec 13, 2012 6:18 pm    Post subject:  no display...other symptoms Reply with quote

Cold weather, but everything was working fine.
Now the displays on radio not lit. Defroster button seems not to work, alternates with the fresh air button light?
No dash lights..
No odometer lights, although they do flash on when car is started.
Everything else seems to work fine.
Which fuse or relay is blown?
Back to top
View user's profile Send private message Send e-mail
IffyG
NAIOA Moderator
NAIOA Moderator
Silver Contributor (Amount: 1) Silver Contributor


Joined: May 19, 2007
Posts: 13731
Posts per day: 3.58
Location: Nashville, TN

2002 Chevrolet Monte Carlo
1998 Oldsmobile Intrigue
2009 Chevrolet Malibu


PostPosted: Thu Dec 13, 2012 7:38 pm    Post subject:   Reply with quote

Have you checked the headlight switch? It's possible that got bumped to a dim setting. It could also be caused by a bad headlight switch itself as well...

_________________
helldorado wrote:
GLWTGFY. Big Thumbs Up

Dan wrote:
Protip: If you don't know what you're doing, don't do it.


d
Back to top
View user's profile Send private message
ksjkato
Newbie
Newbie


Joined: Mar 04, 2010
Posts: 38
Posts per day: 0.01


2001 Chevrolet Impala


PostPosted: Thu Dec 13, 2012 8:56 pm    Post subject:  good possible Reply with quote

what you say may be correct...here are the recent developments.

i have checked all accessible fuses in the two compartments, all working.

The odometer and the radio have now improved to a somewhat visible state.

when i jiggled and turned the headlight switch, there was momentary full light state, then off. It would seem on ignition the lights work, then they dim.

Is it the switch dimmer?...replace the whole headlight pull switch assembly?

thanks,
Back to top
View user's profile Send private message Send e-mail
IffyG
NAIOA Moderator
NAIOA Moderator
Silver Contributor (Amount: 1) Silver Contributor


Joined: May 19, 2007
Posts: 13731
Posts per day: 3.58
Location: Nashville, TN

2002 Chevrolet Monte Carlo
1998 Oldsmobile Intrigue
2009 Chevrolet Malibu


PostPosted: Thu Dec 13, 2012 9:50 pm    Post subject:   Reply with quote

Yeah, I think your headlight switch is shot. Replacing it should fix your problem.

_________________
helldorado wrote:
GLWTGFY. Big Thumbs Up

Dan wrote:
Protip: If you don't know what you're doing, don't do it.


d
Back to top
View user's profile Send private message
Pitch Black SS
NAIOA Owner / Founder
NAIOA Administrator
NAIOA Administrator


Joined: Mar 08, 2004
Posts: 12756
Posts per day: 2.55
Location: Tullahoma, TN

2004 Chevrolet Impala
1982 Chevrolet Malibu
2007 Chrysler 300C
1986 Chevrolet Monte Carlo


PostPosted: Fri Dec 14, 2012 11:34 am    Post subject:  Re: good possible Reply with quote

ksjkato wrote:
what you say may be correct...here are the recent developments.

i have checked all accessible fuses in the two compartments, all working.

The odometer and the radio have now improved to a somewhat visible state.

when i jiggled and turned the headlight switch, there was momentary full light state, then off. It would seem on ignition the lights work, then they dim.

Is it the switch dimmer?...replace the whole headlight pull switch assembly?

thanks,


I think its all 1 piece, been a while since Ive been in an Impala to tell you for sure.

_________________
Back to top
View user's profile Send private message Visit poster's website AIM Address
ksjkato
Newbie
Newbie


Joined: Mar 04, 2010
Posts: 38
Posts per day: 0.01


2001 Chevrolet Impala


PostPosted: Fri Dec 14, 2012 11:46 am    Post subject:  switch Reply with quote

getting switch replaced...thanks,

kj
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: November 18, 2017, 11:04:39 pm
Page Generation: 0.09 Seconds ( SQL 27:116 in 0.01 Seconds )