NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - I think my fuel pump died again.
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

I think my fuel pump died again.

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car!
View previous topic :: View next topic  
Author Message
2001Ls
Resident
Resident


Joined: Jun 26, 2009
Posts: 715
Posts per day: 0.24
Location: New Jersey New Milford

2001 Chevrolet Impala


PostPosted: Sun Sep 23, 2012 11:11 am    Post subject:  I think my fuel pump died again. Reply with quote

Hey y'all, any advice appreciated.

About 2 years ago i replaced my fuel pump with a "Spectre" brand. Issues I was having was hot restart problems and my fuel sender float was giving wrong readings. After I replaced it both those things were fixed and everything was well in the fuel system department.
Anyways about 3 weeks ago I started having problems. Car sometimes doesn't start on first crank, it will start then immediatly stall out. I try cycling the key to "on" to build fuell pressure but that doesn't even work. Also when I go WOT I am pretty much dead power wise which I suspect is due to low fuel pressure. My fuel filter has been replaced within the last year so I don't believe that's it.
I don't have a fuel pressure test tool so I can't really confirm that the pressure is low, does anybody know an alternate way to check the fuel pressure? I have a ELM ODB tool but that isn't exactly accurate as far as fuel pressure. I realy don't want to pop the $45 bucks for the guage or the price of a diagnositc at a shop. Thanks for any advice anybody has.

_________________


2001 Impala LS 81k as of Nov,2011
3.8 V6 3800 Series 2
Back to top
View user's profile Send private message
IffyG
NAIOA Moderator
NAIOA Moderator
Silver Contributor (Amount: 1) Silver Contributor


Joined: May 19, 2007
Posts: 13731
Posts per day: 3.64
Location: Nashville, TN

2002 Chevrolet Monte Carlo
1998 Oldsmobile Intrigue
2009 Chevrolet Malibu


PostPosted: Sun Sep 23, 2012 11:16 am    Post subject:   Reply with quote

Go borrow the a tool from Autozone. It was something like a fully refundable 90 dollar charge when I did it when the Monte Carlo was acting up.

_________________
helldorado wrote:
GLWTGFY. Big Thumbs Up

Dan wrote:
Protip: If you don't know what you're doing, don't do it.


d
Back to top
View user's profile Send private message
2001Ls
Resident
Resident


Joined: Jun 26, 2009
Posts: 715
Posts per day: 0.24
Location: New Jersey New Milford

2001 Chevrolet Impala


PostPosted: Sun Sep 23, 2012 11:37 am    Post subject:   Reply with quote

Ok thanks I'll have to check that out.

_________________


2001 Impala LS 81k as of Nov,2011
3.8 V6 3800 Series 2
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car! All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: September 20, 2017, 12:27:51 am
Page Generation: 0.08 Seconds ( SQL 21:104 in 0.00 Seconds )