NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - Misfire - Fixed
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Misfire - Fixed

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 Engine, Exhaust and Transmission
View previous topic :: View next topic  
Author Message
outonthetiles
Member Level
Member Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Jul 12, 2006
Posts: 1113
Posts per day: 0.27
Location: Ilion, NY

2000 Chevrolet Impala
1990 Volvo 240
2000 Buick Regal


PostPosted: Tue Aug 14, 2012 12:43 pm    Post subject:  Misfire - Fixed Reply with quote

As I mentioned in my build thread, my '02 LSS had developed a random misfire.

At first, I'd just get a quick sputter every once in a while, but the problem has gotten worse and worse and now its running on 4 cylinders almost half the time. It throws a P0300 and a flashing CEL. My aeroforce is telling me I am misfiring on cylinders 2 and 4. When this happens, my LTFT's go up to 16.4 and it smells like unburnt gas. When the car is not misfiring it it drives completely normal and has full power. I drove it up to my parent's house 150 or so miles away and it ran like crap the entire way there, intermittently running on 4 cylinders. The car ran fine the entire way back. Sometimes the car runs fine, sometimes it cuts in and out, and sometimes it runs only on 4. It seems completely random. It happens when the car is cold, hot, when its raining, and when its dry. I think its ignition related because I smell unburnt fuel when it happens and you can smell the cat getting really hot.

So what should I test here? I've ruled out coil packs, as 2 and 4 are on seperate coils. Spark plug wires look relatively new (maybe Bill can step in here and let me know last time they were replaced).

I'm almost thinking a bad PCM but I don't know how to diagnose that. One reason I believe that may be the case is the intermittent nature of the problem. Another reason is that recently, my average MPG in the DIC resets to 27.8 every time I restart the car.

I don't want to just start throwing money at this car. Does anyone have any ideas on how to troubleshoot this?

_________________

2000 Impala LS: Getrag 284 Swapped


Last edited by outonthetiles on Wed Aug 15, 2012 11:00 am; edited 1 time in total
Back to top
View user's profile Send private message
billy101
Member Level
Member Level


Joined: Sep 12, 2010
Posts: 1704
Posts per day: 0.66
Location: Willow Spring, NC

2001 Chevrolet Impala
2010 Chevrolet Malibu


PostPosted: Tue Aug 14, 2012 12:54 pm    Post subject:   Reply with quote

Try the ignition control module. I have a known good working one with all 3 coil packs I don't need.

_________________
2002 Impala LS 3.8 -121,749 miles 11/13/2011
2001 Impala LS 3.8 - 118,510 miles. 9/2/2011. RIP - 11/12/2011
2010 Malibu LTZ 3.6 - 16,014miles. 8/20/2011.
Back to top
View user's profile Send private message
VictoryRed09
Forum Regular
Forum Regular


Joined: Jul 06, 2010
Posts: 263
Posts per day: 0.1


2009 Chevrolet Impala


PostPosted: Tue Aug 14, 2012 12:55 pm    Post subject:   Reply with quote

cylinders 2 and 4 are on the back bank, if I am remember right cylinder order correctly.

Check the wires as they route in and around things. Especially as they go down the back side. They may have been pinched and wedged on some thing that is allowing them to arc or ground out before they get to the spark plug.

Dark night test may show a visible arc.
Back to top
View user's profile Send private message Send e-mail
outonthetiles
Member Level
Member Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Jul 12, 2006
Posts: 1113
Posts per day: 0.27
Location: Ilion, NY

2000 Chevrolet Impala
1990 Volvo 240
2000 Buick Regal


PostPosted: Tue Aug 14, 2012 1:23 pm    Post subject:   Reply with quote

Yep, 2 and 4 are the rear 2 on the passenger side. I checked the spark plug wires and they visibly look good and are routed correctly.

I'll have to look into the ICM. It mounts under the coil packs, correct?

_________________

2000 Impala LS: Getrag 284 Swapped
Back to top
View user's profile Send private message
topgun
Resident
Resident


Joined: May 19, 2011
Posts: 639
Posts per day: 0.28
Location: Upstate N Y

2005 Chevrolet Impala


PostPosted: Tue Aug 14, 2012 7:44 pm    Post subject:  misfire Reply with quote

Coil packs mount onto the ICM, yes you are correct. Cool

_________________
Untamed . . . and don't try to change me
Back to top
View user's profile Send private message
Redshiba
Dedicated
Dedicated
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Sep 11, 2007
Posts: 357
Posts per day: 0.1
Location: Utah

2002 Chevrolet Impala
2009 Chevrolet Silverado


PostPosted: Tue Aug 14, 2012 10:58 pm    Post subject:   Reply with quote

My old Chev Lumina did this and it ended up being a bad Injector, Actually two them.
Replaced the bad injectors and it was good as new.

_________________
Back to top
View user's profile Send private message
PushrodPower
Uberd0rk!
Uberd0rk!
Platinum Contributor (Amount: 1) Platinum Contributor


Joined: Nov 30, 2008
Posts: 6396
Posts per day: 1.99
Location: I love drawing butts on stuff.

2005 Chevrolet Impala
1996 Saturn S-Series


PostPosted: Tue Aug 14, 2012 11:14 pm    Post subject:   Reply with quote

I may have missed it in your post, but did you check the sparkplugs on the offending cylinders?

_________________

"The skippers been drinking, oh yes he has you can tell."-Bob Ross
04ImpalaSS wrote:
How much miles are on those seats? How much pounds of ass were applied to the seat during every trip? Lol

wedebrook wrote:
This thread is about *this* far from being about me, all oiled up, eating chili mac in a walmart bathroom.

nightryder wrote:
My c**k broke.
Back to top
View user's profile Send private message
outonthetiles
Member Level
Member Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Jul 12, 2006
Posts: 1113
Posts per day: 0.27
Location: Ilion, NY

2000 Chevrolet Impala
1990 Volvo 240
2000 Buick Regal


PostPosted: Tue Aug 14, 2012 11:34 pm    Post subject:   Reply with quote

I don't think its the injectors because I can smell fuel when it happens. I don't think its spark plugs because when it is not misfiring, it runs absolutely fine. If its not the ICM, I'll pull them on those cylinders and see how they look. I'm going to swap in the ICM from my sister's car tomorrow and see if that cures it. I'll go from there. I'm really hoping its not a head gasket, although I don't think it is.

_________________

2000 Impala LS: Getrag 284 Swapped
Back to top
View user's profile Send private message
ChevyBill
Newbie
Newbie


Joined: Mar 23, 2012
Posts: 17
Posts per day: 0.01
Location: Upstate NY

2002 Chevrolet Impala
2005 Chevrolet Equinox
2012 Chevrolet Cruze
2017 Chevrolet Cruze


PostPosted: Wed Aug 15, 2012 9:39 am    Post subject:   Reply with quote

Good thing I checked in this morning, just about to leave on vacation for 5 days and no internet access.

Replace the wires. When that car was in the transmission shop at 204k, the owner told me they could see arcing from the wires and to replace them. I never did, as the car seemed to run fine. Regardless, those NAPA wires have well over 100k on them. I think the oem set was replaced at approx.140k, but not sure, so that would be 120k or more on current set of wires. Plugs are just as old, btw.

Good luck.
Back to top
View user's profile Send private message
outonthetiles
Member Level
Member Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Jul 12, 2006
Posts: 1113
Posts per day: 0.27
Location: Ilion, NY

2000 Chevrolet Impala
1990 Volvo 240
2000 Buick Regal


PostPosted: Wed Aug 15, 2012 10:59 am    Post subject:   Reply with quote

I'll go and replace the wires. I noticed they were blue so I figured NAPA. I've had those arc right out of the box, they're junk. Thanks for your input, Bill!

But anyways.... FIXED!! Thanks billy101 for mentioning the ICM. I switched the one over from my sister's car and it drives fine now. Now for a trip to the junkyard to find a cheap quick replacement.

_________________

2000 Impala LS: Getrag 284 Swapped
Back to top
View user's profile Send private message
billy101
Member Level
Member Level


Joined: Sep 12, 2010
Posts: 1704
Posts per day: 0.66
Location: Willow Spring, NC

2001 Chevrolet Impala
2010 Chevrolet Malibu


PostPosted: Wed Aug 15, 2012 11:06 am    Post subject:   Reply with quote

outonthetiles wrote:
I'll go and replace the wires. I noticed they were blue so I figured NAPA. I've had those arc right out of the box, they're junk. Thanks for your input, Bill!

But anyways.... FIXED!! Thanks billy101 for mentioning the ICM. I switched the one over from my sister's car and it drives fine now. Now for a trip to the junkyard to find a cheap quick replacement.


No problem! I'll sell you mine for $20 + shipping and include the coil packs if the junkyard wants to charge you something obscene. I have no need for them..they're sitting in the garage waiting for me to either toss them in the garbage or sell them.

_________________
2002 Impala LS 3.8 -121,749 miles 11/13/2011
2001 Impala LS 3.8 - 118,510 miles. 9/2/2011. RIP - 11/12/2011
2010 Malibu LTZ 3.6 - 16,014miles. 8/20/2011.
Back to top
View user's profile Send private message
outonthetiles
Member Level
Member Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Jul 12, 2006
Posts: 1113
Posts per day: 0.27
Location: Ilion, NY

2000 Chevrolet Impala
1990 Volvo 240
2000 Buick Regal


PostPosted: Wed Aug 15, 2012 11:14 am    Post subject:   Reply with quote

I'll let you know. I'm gonna stop by the yard today and see what they want for them. They're usually very reasonable, and I'd like to have something today as I broke 4/6 of the coil pack bolts and can't drive the car at all now until I get it fixed.

_________________

2000 Impala LS: Getrag 284 Swapped
Back to top
View user's profile Send private message
billy101
Member Level
Member Level


Joined: Sep 12, 2010
Posts: 1704
Posts per day: 0.66
Location: Willow Spring, NC

2001 Chevrolet Impala
2010 Chevrolet Malibu


PostPosted: Wed Aug 15, 2012 12:40 pm    Post subject:   Reply with quote

outonthetiles wrote:
I'll let you know. I'm gonna stop by the yard today and see what they want for them. They're usually very reasonable, and I'd like to have something today as I broke 4/6 of the coil pack bolts and can't drive the car at all now until I get it fixed.


Sounds good...good luck at the yard!

_________________
2002 Impala LS 3.8 -121,749 miles 11/13/2011
2001 Impala LS 3.8 - 118,510 miles. 9/2/2011. RIP - 11/12/2011
2010 Malibu LTZ 3.6 - 16,014miles. 8/20/2011.
Back to top
View user's profile Send private message
outonthetiles
Member Level
Member Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Jul 12, 2006
Posts: 1113
Posts per day: 0.27
Location: Ilion, NY

2000 Chevrolet Impala
1990 Volvo 240
2000 Buick Regal


PostPosted: Wed Aug 15, 2012 8:49 pm    Post subject:   Reply with quote

Got the whole setup, 3 coil packs, ICM, and the bracket from an 01 Regal for $36. Not sure what shipping would've cost from you but I needed it today. Hopefully it all works.

Edit: It works, I even got the plug wires on the right coils first try in the dark!

Another Edit: Would you look at that, "internet speculation" worked!

_________________

2000 Impala LS: Getrag 284 Swapped
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 Engine, Exhaust and Transmission All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: September 23, 2017, 11:31:34 am
Page Generation: 0.11 Seconds ( SQL 43:151 in 0.01 Seconds )