NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - Low Engine Oil Light comes on at startup
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Low Engine Oil Light comes on at startup

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 Engine, Exhaust and Transmission
View previous topic :: View next topic  
Author Message
ptcm1
Newbie
Newbie


Joined: Oct 28, 2009
Posts: 6
Posts per day: 0
Location: Buffalo, NY

2005 Chevrolet Impala


PostPosted: Sun Jul 22, 2012 12:25 am    Post subject:  Low Engine Oil Light comes on at startup Reply with quote

So I just replaced my engine oil level sensor a few weeks ago; installation was a breeze and I used a good gasket maker to seal the sensor against the pan. Since then, every time I start it up (cold and warm starts) the LOW ENG OIL LEVEL message pops up and stays on for a minute. I check the oil dipstick every other day and its completely full, there are no oil stains on my driveway and there is no oil underneath the car so I am pretty sure its either a sensor or the wiring harness that leads to the sensor. Any ideas on how to get rid of this message? Is there any "reset" to this? Engine is a 3.8L
Back to top
View user's profile Send private message
outonthetiles
Member Level
Member Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Jul 12, 2006
Posts: 1113
Posts per day: 0.27
Location: Ilion, NY

2000 Chevrolet Impala
1990 Volvo 240
2000 Buick Regal


PostPosted: Sun Jul 22, 2012 7:25 am    Post subject:   Reply with quote

Are you positive its low engine oil or could it be low oil pressure?

_________________

2000 Impala LS: Getrag 284 Swapped
Back to top
View user's profile Send private message
ptcm1
Newbie
Newbie


Joined: Oct 28, 2009
Posts: 6
Posts per day: 0
Location: Buffalo, NY

2005 Chevrolet Impala


PostPosted: Sun Jul 22, 2012 3:31 pm    Post subject:   Reply with quote

I am positive that its not the oil pressure sense the message started to come on right after I replaced the sensor
Back to top
View user's profile Send private message
outonthetiles
Member Level
Member Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Jul 12, 2006
Posts: 1113
Posts per day: 0.27
Location: Ilion, NY

2000 Chevrolet Impala
1990 Volvo 240
2000 Buick Regal


PostPosted: Sun Jul 22, 2012 3:36 pm    Post subject:   Reply with quote

Sounds like a defective sensor then..

_________________

2000 Impala LS: Getrag 284 Swapped
Back to top
View user's profile Send private message
bigdog60
Resident
Resident
Gold Contributor (Amount: 1) Gold Contributor


Joined: Jan 27, 2009
Posts: 799
Posts per day: 0.25


2005 Chevrolet Impala


PostPosted: Sun Jul 22, 2012 9:41 pm    Post subject:   Reply with quote

Have to ask..Why did you replace it?

_________________
Married men live longer than single men do, but married men are a lot more willing to die...
Back to top
View user's profile Send private message
ptcm1
Newbie
Newbie


Joined: Oct 28, 2009
Posts: 6
Posts per day: 0
Location: Buffalo, NY

2005 Chevrolet Impala


PostPosted: Tue Jul 24, 2012 4:19 pm    Post subject:   Reply with quote

I replaced it because there was a crack in it and oil was slowly leaking out. I just contacted Rock Auto and they agreed to send my a replacement. Thanks for the replies.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 Engine, Exhaust and Transmission All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: December 17, 2017, 7:08:40 pm
Page Generation: 0.09 Seconds ( SQL 27:114 in 0.01 Seconds )