NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - Low oil pressure light out of nowhere?
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Low oil pressure light out of nowhere?

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 Engine, Exhaust and Transmission
View previous topic :: View next topic  
Author Message
pimpstrocity
Forum Regular
Forum Regular


Joined: Jan 21, 2009
Posts: 258
Posts per day: 0.08
Location: La, somewhere in the 985

2004 Chevrolet Impala


PostPosted: Thu May 31, 2012 6:20 pm    Post subject:  Low oil pressure light out of nowhere? Reply with quote

So I just put a new water pump on my car. Everything went smooth and after filling the radiator I start it up to see how everything is. Clear out the blue the message center comes up saying low oil pressure. Now it has never done this before and I immediately shut off the motor and checked the oil levels and they were in normal operating range.

Any ideas what could be going on or what a likely cause for this could be?

**UPDATE**

Put a mechanical gauge up to where the oil sensor goes and got about 25 psi around idle so I have pressure. I installed a new sensor figuring the sensor must have went bad but its still coming up with the light about the pressure.

Where do i go from here?

_________________

2004 impala LS supercharged: Top swap L67 /w 3.8, rebuilt heads, SI performance valves, wizaired CAI, ZZP 3'' dp, SLP 1.8 ratio aluminum roller rockers, SLP ceramic coated headers, GMPP Exhaust, 180* t-stat, tuned /w hp tuners


Last edited by pimpstrocity on Fri Jun 01, 2012 12:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
SuperImpala00
Forum Regular
Forum Regular


Joined: Dec 20, 2010
Posts: 195
Posts per day: 0.08
Location: Oregon

2000 Chevrolet Impala


PostPosted: Thu May 31, 2012 9:49 pm    Post subject:   Reply with quote

Considering all the major harness connections on that side I would double check them all. Otherwise get ahold of a tech2 and get the oil pressure reading directly from the computer.
Back to top
View user's profile Send private message
pimpstrocity
Forum Regular
Forum Regular


Joined: Jan 21, 2009
Posts: 258
Posts per day: 0.08
Location: La, somewhere in the 985

2004 Chevrolet Impala


PostPosted: Fri Jun 01, 2012 12:36 pm    Post subject:   Reply with quote

update

_________________

2004 impala LS supercharged: Top swap L67 /w 3.8, rebuilt heads, SI performance valves, wizaired CAI, ZZP 3'' dp, SLP 1.8 ratio aluminum roller rockers, SLP ceramic coated headers, GMPP Exhaust, 180* t-stat, tuned /w hp tuners
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 Engine, Exhaust and Transmission All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: September 22, 2017, 3:25:16 pm
Page Generation: 0.08 Seconds ( SQL 21:101 in 0.00 Seconds )