NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - Ignition Switch question
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Ignition Switch question

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car!
View previous topic :: View next topic  
Author Message
Gems
Uber
Uber


Joined: Feb 18, 2006
Posts: 928
Posts per day: 0.22
Location: Long Island, New York

2001 Chevrolet Impala


PostPosted: Mon Apr 09, 2012 9:11 pm    Post subject: Question Ignition Switch question Reply with quote

I noticed recently that when I turn the key to start it doesn't fully spring return to the ON position after the engine starts... The car starts and runs fine but the key might be somewhere between START and ON if I don't rotate it myself to the ON position...

About 1 year ago I replaced the ignition switch which is attached to the back of the key cylinder... I wonder if the spring return from START to ON is in the ignition switch or the key cylinder?

_________________
Go Mark Martin!!
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
Arvetus
Senior Level
Senior Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: May 14, 2004
Posts: 2752
Posts per day: 0.56
Location: Lufkin, TX

2001 Chevrolet Impala


PostPosted: Tue Apr 10, 2012 12:00 pm    Post subject:   Reply with quote

The spring is in the ignition switch itself.

_________________
- 2001 Impala Base - Navy Blue Metallic
- 3800 Series II


RIP 10/23/2010, 191,197 miles - traded on a 2003 Tahoe Z71
Back to top
View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger
Gems
Uber
Uber


Joined: Feb 18, 2006
Posts: 928
Posts per day: 0.22
Location: Long Island, New York

2001 Chevrolet Impala


PostPosted: Tue Apr 10, 2012 12:59 pm    Post subject:   Reply with quote

Arvetus wrote:
The spring is in the ignition switch itself.


Yes, I just figured that out... The ignition switch is one I bought from Autozone about 1 year ago under their Duralast brand... Supposedly a limited lifetime warranty, whatever that means... It is actually manufactured by Wells Mfg... http://www.wellsve.com/ ...They make alot of aftermarket ignition parts (coil packs, ignition modules, etc.)... So as a "shot in the dark" I sent an email to their customer service this morning... About 3 hours later I get a phone call from them... The guy who called me is one of their technical reps. and also does customer service... To make a long story short, he told me that Autozone should replace the switch, no charge, but sometimes they give customers a hard time with electrical parts... So he also gave me an RMA number and will send me a free of charge replacement switch... I thought was was pretty good customer service!

_________________
Go Mark Martin!!
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
Arvetus
Senior Level
Senior Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: May 14, 2004
Posts: 2752
Posts per day: 0.56
Location: Lufkin, TX

2001 Chevrolet Impala


PostPosted: Tue Apr 10, 2012 3:36 pm    Post subject:   Reply with quote

Good deal! Glad you got it sorted out with CS. Sometimes, that can be half the battle....

_________________
- 2001 Impala Base - Navy Blue Metallic
- 3800 Series II


RIP 10/23/2010, 191,197 miles - traded on a 2003 Tahoe Z71
Back to top
View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger
Gems
Uber
Uber


Joined: Feb 18, 2006
Posts: 928
Posts per day: 0.22
Location: Long Island, New York

2001 Chevrolet Impala


PostPosted: Tue Apr 10, 2012 5:47 pm    Post subject:   Reply with quote

Arvetus wrote:
Good deal! Glad you got it sorted out with CS. Sometimes, that can be half the battle....


Hey, you're the guy who clued me into the amp bypass a little while ago for my non-working radio??... That worked perfectly and the radio never sounded better... Thanks!!

_________________
Go Mark Martin!!
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
Arvetus
Senior Level
Senior Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: May 14, 2004
Posts: 2752
Posts per day: 0.56
Location: Lufkin, TX

2001 Chevrolet Impala


PostPosted: Thu Apr 12, 2012 11:14 am    Post subject:   Reply with quote

Cool!
Glad I could help... I remember it took me a while to figure out the pinout diagram, so glad I could help ya out!

_________________
- 2001 Impala Base - Navy Blue Metallic
- 3800 Series II


RIP 10/23/2010, 191,197 miles - traded on a 2003 Tahoe Z71
Back to top
View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car! All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: September 21, 2017, 12:40:32 pm
Page Generation: 0.23 Seconds ( SQL 27:110 in 0.06 Seconds )