NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - Battery/Security Light ! Please help !!!
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Battery/Security Light ! Please help !!!

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car!
View previous topic :: View next topic  
Author Message
Tony
Forum Regular
Forum Regular


Joined: Aug 14, 2006
Posts: 180
Posts per day: 0.04
Location: Lebanon, PA

2003 Chevrolet Impala


PostPosted: Fri Mar 23, 2012 6:48 pm    Post subject:  Battery/Security Light ! Please help !!! Reply with quote

OK, today after work I go to start my car and nothing. I tried a second time and held the key and after a few seconds it turned over. Now the Security light is on AND the battery light ! I have 12.5 volts with the the car not running, 14.1 with the car running and still have a battery light and security light. Dropped it off at the garage to look at in the morning. I noticed that while driving it, whenever the battery light would come on, the radio display would dim. As soon as the battery light went off, the display would brighten again ! The message center goes from Security, to Battery, the Check Engine Soon or something like that. Any ideas????? Battery is less than a year old. Thanks alot in advance !!!! Tony

_________________
2003 Impala LS w/3.8L
Alt. Voltage Booster - Alt. Rewire - Motor Mounts Rotated - Cryo-Stop Rotors - Resonator Delete
Compustar 2-way remote starter/keyless entry
Back to top
View user's profile Send private message AIM Address
2007SSImpala
Dedicated
Dedicated


Joined: Jul 11, 2010
Posts: 344
Posts per day: 0.13
Location: Jacksonville, NC

2007 Chevrolet Impala
2012 Chevrolet Cruze


PostPosted: Fri Mar 23, 2012 9:49 pm    Post subject:   Reply with quote

Do you know what trouble codes are being set?

_________________
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
Tony
Forum Regular
Forum Regular


Joined: Aug 14, 2006
Posts: 180
Posts per day: 0.04
Location: Lebanon, PA

2003 Chevrolet Impala


PostPosted: Fri Mar 23, 2012 11:51 pm    Post subject:   Reply with quote

No codes

_________________
2003 Impala LS w/3.8L
Alt. Voltage Booster - Alt. Rewire - Motor Mounts Rotated - Cryo-Stop Rotors - Resonator Delete
Compustar 2-way remote starter/keyless entry
Back to top
View user's profile Send private message AIM Address
Tony
Forum Regular
Forum Regular


Joined: Aug 14, 2006
Posts: 180
Posts per day: 0.04
Location: Lebanon, PA

2003 Chevrolet Impala


PostPosted: Sat Mar 24, 2012 11:51 am    Post subject:   Reply with quote

My garage found the battery/charging system working OK. Only codes found were some ABS codes due a bad front left harness that they fixed. They suspected a bad cell in the battery. So....I take the car to where I bought the battery last Sept and they did all they're checks....AGAIN, no problem found at all ! I have no more Security or Battery light and everything seems to be working. I'm suspecting the ignition switch again but not sure. Stopped by the dealer to pick their brains and was basically told that if there's no lights/codes and everythings working, not much they can do at this point ! Could a security problem when I tried starting the car have caused the battery light to light ????

_________________
2003 Impala LS w/3.8L
Alt. Voltage Booster - Alt. Rewire - Motor Mounts Rotated - Cryo-Stop Rotors - Resonator Delete
Compustar 2-way remote starter/keyless entry
Back to top
View user's profile Send private message AIM Address
Bill58
Resident
Resident
Silver Contributor (Amount: 1) Silver Contributor


Joined: Oct 31, 2008
Posts: 650
Posts per day: 0.2
Location: Maryland

2006 Chevrolet Impala
2005 Chevrolet Impala


PostPosted: Sat Mar 24, 2012 9:27 pm    Post subject:   Reply with quote

You have Alt. Voltage Booster - Alt. Rewire -Compustar 2-way remote starter/keyless entry, any could effect your electrical system. Check batt cables and bolts. Check your ground connections for corrosion.
Back to top
View user's profile Send private message
Tony
Forum Regular
Forum Regular


Joined: Aug 14, 2006
Posts: 180
Posts per day: 0.04
Location: Lebanon, PA

2003 Chevrolet Impala


PostPosted: Sun Mar 25, 2012 8:15 am    Post subject:   Reply with quote

Thanks - I can trace the wires myself, but just in case, where in particular should I be looking?

_________________
2003 Impala LS w/3.8L
Alt. Voltage Booster - Alt. Rewire - Motor Mounts Rotated - Cryo-Stop Rotors - Resonator Delete
Compustar 2-way remote starter/keyless entry
Back to top
View user's profile Send private message AIM Address
zvm77
Dedicated
Dedicated


Joined: May 18, 2007
Posts: 392
Posts per day: 0.1


2001 Chevrolet Impala


PostPosted: Sun Mar 25, 2012 5:28 pm    Post subject:   Reply with quote

most likely your ignition switch or bcm.
Back to top
View user's profile Send private message
Tony
Forum Regular
Forum Regular


Joined: Aug 14, 2006
Posts: 180
Posts per day: 0.04
Location: Lebanon, PA

2003 Chevrolet Impala


PostPosted: Tue Apr 03, 2012 4:08 pm    Post subject:   Reply with quote

Thanks everyone for the replies, I broke down and took the car to a Chevy dealer today. After 2 hours of troubleshooting/diagnosing, the tech came up with a bad BCM. He actually wasn't able to communicate with it and took me back and showed me what he was doing and what the laptop was saying. . Thought it could also be the passlock module, but ruled that out. $455 later, car is fixed and the tech said he can now communicate with the new BCM. I "think" I got lucky and actually got a tech who knew what he was doing and wasn't just replacing parts. Time will tell, but at least I got a 12month/12,000 mile warranty on the new BCM !

_________________
2003 Impala LS w/3.8L
Alt. Voltage Booster - Alt. Rewire - Motor Mounts Rotated - Cryo-Stop Rotors - Resonator Delete
Compustar 2-way remote starter/keyless entry
Back to top
View user's profile Send private message AIM Address
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car! All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: September 19, 2017, 5:15:56 pm
Page Generation: 0.10 Seconds ( SQL 31:114 in 0.01 Seconds )