NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - TPS sensor problem??
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

TPS sensor problem??

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car!
View previous topic :: View next topic  
Author Message
PushrodPower
Uberd0rk!
Uberd0rk!
Platinum Contributor (Amount: 1) Platinum Contributor


Joined: Nov 30, 2008
Posts: 6396
Posts per day: 1.99
Location: I love drawing butts on stuff.

2005 Chevrolet Impala
1996 Saturn S-Series


PostPosted: Mon Mar 05, 2012 10:13 pm    Post subject:  TPS sensor problem?? Reply with quote

I recently came across a new problem that from reading from many articles and forums around net may be my issue. Whenever my car warms up it idles rough and when I cruise on the highway drive ability is horrible. For instance when I gas on it sometimes it won't respond and will do nothing. Other times it'll take probably a full 2 seconds too downshift, it just lags and hangs up real bad. I cleaned the MAF sensor and even got another one and the issue still persists.

I would also like too note that I purchased a K&N round filter for my bumper intake and shortly after this problem reared it's ugly head. I just recently found out from searching around here that the oil from these filters can kill MAF sensors, but can it travel to the TPS and ruin those too?

Any help is very appreciated.

_________________

"The skippers been drinking, oh yes he has you can tell."-Bob Ross
04ImpalaSS wrote:
How much miles are on those seats? How much pounds of ass were applied to the seat during every trip? Lol

wedebrook wrote:
This thread is about *this* far from being about me, all oiled up, eating chili mac in a walmart bathroom.

nightryder wrote:
My c**k broke.
Back to top
View user's profile Send private message
Frank
Master Level
Master Level
Platinum Contributor (Amount: 1) Platinum Contributor


Joined: Aug 16, 2005
Posts: 3465
Posts per day: 0.78
Location: Colorado

2001 Chevrolet Impala


PostPosted: Tue Mar 06, 2012 4:17 am    Post subject:   Reply with quote

The TPS isn't in the air flow at all (nor is it even exposed to the air flow), so there's really no way for it to get contaminated by the filter. It hooks onto the end of the pivot on the throttle plate (which runs the the outside of the throttle body).

If the 3.8L TPS is the same as the 3.4L (I'll let you research), I think I have a spare I can send you for $5...

_________________
2001 Galaxy Silver 9C1 w/ L67 and 4T65E-HD...and a few other mods. Wink
Back to top
View user's profile Send private message
PushrodPower
Uberd0rk!
Uberd0rk!
Platinum Contributor (Amount: 1) Platinum Contributor


Joined: Nov 30, 2008
Posts: 6396
Posts per day: 1.99
Location: I love drawing butts on stuff.

2005 Chevrolet Impala
1996 Saturn S-Series


PostPosted: Tue Mar 06, 2012 9:56 am    Post subject:   Reply with quote

Thank you for the reply Frank. Very Happy Your correct it is just on a pivot and no air flow hits it. Wasn't even thinking about this.

I don't believe the 3.8 sensor is compatible. Unless it looks like this



And has different part numbers according too Amazon. Crying or Very sad

EDIT: Ok so I found two new TPS for $30.00 one is AC Delco and one is Delphi. Which one would be better? I know both are OEM suppliers but I want to be 1000% sure.

_________________

"The skippers been drinking, oh yes he has you can tell."-Bob Ross
04ImpalaSS wrote:
How much miles are on those seats? How much pounds of ass were applied to the seat during every trip? Lol

wedebrook wrote:
This thread is about *this* far from being about me, all oiled up, eating chili mac in a walmart bathroom.

nightryder wrote:
My c**k broke.
Back to top
View user's profile Send private message
bigdog60
Resident
Resident
Gold Contributor (Amount: 1) Gold Contributor


Joined: Jan 27, 2009
Posts: 793
Posts per day: 0.25


2005 Chevrolet Impala


PostPosted: Tue Mar 06, 2012 10:27 pm    Post subject:   Reply with quote

I believe they are both the same.
Back to top
View user's profile Send private message
PushrodPower
Uberd0rk!
Uberd0rk!
Platinum Contributor (Amount: 1) Platinum Contributor


Joined: Nov 30, 2008
Posts: 6396
Posts per day: 1.99
Location: I love drawing butts on stuff.

2005 Chevrolet Impala
1996 Saturn S-Series


PostPosted: Fri Mar 09, 2012 7:28 pm    Post subject:   Reply with quote

I just replaced the TPS with a new AC Delco/CTS one and problem still persists. Check engine light came on afterward had the code read and came up as a misfire. I just replaced the plugs and wires not 5,000 miles ago. Confused Confused Confused I guess I'll change the plugs and wires out again.

_________________

"The skippers been drinking, oh yes he has you can tell."-Bob Ross
04ImpalaSS wrote:
How much miles are on those seats? How much pounds of ass were applied to the seat during every trip? Lol

wedebrook wrote:
This thread is about *this* far from being about me, all oiled up, eating chili mac in a walmart bathroom.

nightryder wrote:
My c**k broke.
Back to top
View user's profile Send private message
PushrodPower
Uberd0rk!
Uberd0rk!
Platinum Contributor (Amount: 1) Platinum Contributor


Joined: Nov 30, 2008
Posts: 6396
Posts per day: 1.99
Location: I love drawing butts on stuff.

2005 Chevrolet Impala
1996 Saturn S-Series


PostPosted: Tue Mar 13, 2012 8:56 pm    Post subject:   Reply with quote

Ok a little update: I changed out the Durajunk plug wires for AC Delco ones it still ran rough. Evil or Very Mad So out off curiosity I pulled the plug to the cylinder it was misfiring on (number 3) and found it too be a Bosch plug. Apparently when I changed them out last year I forgot to do number 3. DOH! So I took a trip to Autozone and but an AC Delco Iridium, threw it in, problem solved. Runs smooth as silk. Hang Head 2 Hang Head 2 Hang Head 2 Kind of weird the Bosch plug only lasted 40K.

_________________

"The skippers been drinking, oh yes he has you can tell."-Bob Ross
04ImpalaSS wrote:
How much miles are on those seats? How much pounds of ass were applied to the seat during every trip? Lol

wedebrook wrote:
This thread is about *this* far from being about me, all oiled up, eating chili mac in a walmart bathroom.

nightryder wrote:
My c**k broke.
Back to top
View user's profile Send private message
chibiblacksheep
Member Level
Member Level


Joined: Dec 14, 2009
Posts: 1369
Posts per day: 0.48
Location: Philadelphia, PA

2000 Chevrolet Monte Carlo
2007 Chevrolet Impala
1968 Chevrolet Camaro
2013 Chevrolet Camaro


PostPosted: Tue Mar 13, 2012 10:11 pm    Post subject:   Reply with quote

That's why we steer people away from Bosch and tell them anything with ignition should be stock acdelco Wink

_________________
Back to top
View user's profile Send private message Send e-mail AIM Address
PushrodPower
Uberd0rk!
Uberd0rk!
Platinum Contributor (Amount: 1) Platinum Contributor


Joined: Nov 30, 2008
Posts: 6396
Posts per day: 1.99
Location: I love drawing butts on stuff.

2005 Chevrolet Impala
1996 Saturn S-Series


PostPosted: Tue Mar 13, 2012 10:50 pm    Post subject:   Reply with quote

chibiblacksheep wrote:
That's why we steer people away from Bosch and tell them anything with ignition should be stock acdelco Wink


I'm a firm believer now. Laughing

_________________

"The skippers been drinking, oh yes he has you can tell."-Bob Ross
04ImpalaSS wrote:
How much miles are on those seats? How much pounds of ass were applied to the seat during every trip? Lol

wedebrook wrote:
This thread is about *this* far from being about me, all oiled up, eating chili mac in a walmart bathroom.

nightryder wrote:
My c**k broke.
Back to top
View user's profile Send private message
ad0726
Member Level
Member Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Nov 20, 2007
Posts: 1316
Posts per day: 0.37


2001 Chevrolet Impala
2005 Chevrolet Malibu
1983 Datsun Patrol
2003 Chevrolet Impala


PostPosted: Wed Mar 14, 2012 2:15 am    Post subject:   Reply with quote

PushrodPower wrote:
Kind of weird the Bosch plug lasted 40K.


Fixed
Back to top
View user's profile Send private message
chibiblacksheep
Member Level
Member Level


Joined: Dec 14, 2009
Posts: 1369
Posts per day: 0.48
Location: Philadelphia, PA

2000 Chevrolet Monte Carlo
2007 Chevrolet Impala
1968 Chevrolet Camaro
2013 Chevrolet Camaro


PostPosted: Wed Mar 14, 2012 8:49 am    Post subject:   Reply with quote

I would love more information on how you missed a spark plug...

Didn't you have one extra when you were done? Laughing

_________________
Back to top
View user's profile Send private message Send e-mail AIM Address
PushrodPower
Uberd0rk!
Uberd0rk!
Platinum Contributor (Amount: 1) Platinum Contributor


Joined: Nov 30, 2008
Posts: 6396
Posts per day: 1.99
Location: I love drawing butts on stuff.

2005 Chevrolet Impala
1996 Saturn S-Series


PostPosted: Wed Mar 14, 2012 9:20 am    Post subject:   Reply with quote

chibiblacksheep wrote:
I would love more information on how you missed a spark plug...

Didn't you have one extra when you were done? Laughing


Yeah yeah yeah. Razz I had a bunch of other plugs from the Saturn sitting on my work bench. I guess it got lost in the shuffle. I'm just glad my car is running well now. That was a huge depressing weight hanging over my head as I always try too keep the Impala running top notch.

_________________

"The skippers been drinking, oh yes he has you can tell."-Bob Ross
04ImpalaSS wrote:
How much miles are on those seats? How much pounds of ass were applied to the seat during every trip? Lol

wedebrook wrote:
This thread is about *this* far from being about me, all oiled up, eating chili mac in a walmart bathroom.

nightryder wrote:
My c**k broke.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car! All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: September 21, 2017, 12:32:22 pm
Page Generation: 0.11 Seconds ( SQL 37:141 in 0.01 Seconds )