NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - might be slipping
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

might be slipping

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 Engine, Exhaust and Transmission
View previous topic :: View next topic  
Author Message
Jnibbs24
Uber
Uber


Joined: May 26, 2009
Posts: 869
Posts per day: 0.29
Location: Seattle

2003 Chevrolet Impala


PostPosted: Thu Mar 01, 2012 3:15 pm    Post subject:  might be slipping Reply with quote

Noticed it today, 3.8 with 153k, I dropped the pant and changed fluid/filter @ 137k, fluid was great looking and nearly no sediments.. I noticed today when I go from a dead stop to 3/4 WOT right around 30mph it feels like a small slip. When driving normal through town I can't notice any bad shifting. It just seems when I'm up on it,it has the slightest hiccup from 1-2 @ 30mph. Anything I can do/ check to maybe save my butt. I don't know when the plugs and wires have been changed... Not since I owned the car @122k. I'm planning on ordering some this week from Amazon. Part #s anyone have?


Just checked the tranny fluid, its good color,level, and doesn't smell burnt..

_________________
Back to top
View user's profile Send private message
98ss
Uber
Uber


Joined: Jun 06, 2009
Posts: 817
Posts per day: 0.27
Location: Ann Arbor

2002 Chevrolet Impala
2011 Chevrolet Silverado


PostPosted: Thu Mar 01, 2012 10:36 pm    Post subject:   Reply with quote

If you want it to last...quit doing hole shots.
Back to top
View user's profile Send private message
Jnibbs24
Uber
Uber


Joined: May 26, 2009
Posts: 869
Posts per day: 0.29
Location: Seattle

2003 Chevrolet Impala


PostPosted: Fri Mar 02, 2012 6:00 am    Post subject:   Reply with quote

Thank you capt. Obvious..

_________________
Back to top
View user's profile Send private message
00impala123
Senior Level
Senior Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Feb 01, 2010
Posts: 2653
Posts per day: 0.95
Location: Chicago, IL

2000 Chevrolet Impala


PostPosted: Fri Mar 02, 2012 2:18 pm    Post subject:   Reply with quote

Could be the start of the cat going bad

_________________
Back to top
View user's profile Send private message
Jnibbs24
Uber
Uber


Joined: May 26, 2009
Posts: 869
Posts per day: 0.29
Location: Seattle

2003 Chevrolet Impala


PostPosted: Fri Mar 02, 2012 3:28 pm    Post subject:   Reply with quote

Was thinking that but, I bought a new one around 127k and it only hesitates for a split second between 1-2nd. So I don't think it'd be that..

_________________
Back to top
View user's profile Send private message
98ss
Uber
Uber


Joined: Jun 06, 2009
Posts: 817
Posts per day: 0.27
Location: Ann Arbor

2002 Chevrolet Impala
2011 Chevrolet Silverado


PostPosted: Sat Mar 03, 2012 12:04 pm    Post subject:   Reply with quote

If you have a delay from 1-2, it could just be some varish in the 1-2 accumulator causing the o-ring to stick. What sux is that it you have to drop the pan to get to it, and you were just in there. You can always try putting a couple bottles of lubeguard red in there and see what happens. Yes, miricle in a can, but I think it is an etcher, so that would take care of the varish, and it works. The other way to fix like I said is to pull the accumulators apart and scuff up via a scotch brite pad the bores of the 1-2 and 2-3 accumulator.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 Engine, Exhaust and Transmission All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: September 20, 2017, 9:41:34 am
Page Generation: 0.11 Seconds ( SQL 27:110 in 0.01 Seconds )