NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - Leaking Coolant!
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Leaking Coolant!

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion
View previous topic :: View next topic  
Author Message
TeenBeach
Forum Regular
Forum Regular
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Mar 11, 2011
Posts: 296
Posts per day: 0.12
Location: Greenfield, Wisconsin

2003 Chevrolet Impala
2002 Kia Rio


PostPosted: Wed Feb 15, 2012 5:43 pm    Post subject: Snif ! Leaking Coolant! Reply with quote

So just when I thought that my car problem would be over for a while, I am now leaking coolant at a fast rate. I noticed that two days ago, my engine temp was getting pretty high, way over the half mark. I wasn't thinking anything about it the first time I noticed it, but then it got pretty high the next day. I never let it get into the overheating zone though. My low coolant light was not on, but I went to buy some dex-cool and 1/3 of it in there. My temp went back to normal but then again the next day, it started to get high again. I was in my driveway and I was looking around to see if I had any leaks and sure enough I had a puddle of coolant on the concrete, after just 2 minutes of being there! I just added more coolant, started it up and it was leaking pretty fast again. Not like a waterfall, but big drops. Sad

This is very frustrating to me if you can't tell. I know for sure its not my coolant elbows or water pump... because its on the driver side, which I think it is coming off the radiator. Its hard to tell exactly where it is coming from percisely. I snapped some pics for you guys. Sorry, if for some reason there is a right up or solution somewhere. I am in a big hurry, as I do work alot.

The impy will be sitting out in the driveway this weekend since I am going on vacation and taking a train. So its not a major problem at the moment, but it is my DD.


this is where I see a wet line of coolant, not sure where its coming from though??? Its on the radiator.


Its all over the place down here, It would look as if the drain is leaking but I am pretty sure its not. I've never removed it personally.



and its all leaking off of here, onto the ground.

I really hope my radiator isn't cracked, I don't remember hitting anything really hard. Also, when I opened up my radiator cap... there was alot of milkshake in it Crying or Very sad Pretty sure thats becasue I switched over to royal purple without ever changing the LIM gasket.... ugh!

Hopefully you guys can help me out. Thanks for your replys in advance as always!

Peace.
Back to top
View user's profile Send private message Send e-mail Visit poster's website Yahoo Messenger
billy101
Member Level
Member Level


Joined: Sep 12, 2010
Posts: 1704
Posts per day: 0.66
Location: Willow Spring, NC

2001 Chevrolet Impala
2010 Chevrolet Malibu


PostPosted: Wed Feb 15, 2012 6:37 pm    Post subject:   Reply with quote

The radiator in my 02 was cracked in the same area. Not even cracked, had a hole. Never hit anything, just happened.
If you have the milkshake going on and have never done your UIM/LIM gaskets, now's the time! If they were never done I would replace the radiator with OEM (read my transmission thread on why I will never buy anything but OEM from now on), and then flush the entire coolant system, including the motor, and then do the UIM/LIM gaskets. It's not fun, but maintenance seems to be due. The UIM/LIM gaskets is a weekend job your average DIYer can do, there are plenty of write ups online, it's hard to mess up.

_________________
2002 Impala LS 3.8 -121,749 miles 11/13/2011
2001 Impala LS 3.8 - 118,510 miles. 9/2/2011. RIP - 11/12/2011
2010 Malibu LTZ 3.6 - 16,014miles. 8/20/2011.
Back to top
View user's profile Send private message
Frank
Master Level
Master Level
Platinum Contributor (Amount: 1) Platinum Contributor


Joined: Aug 16, 2005
Posts: 3465
Posts per day: 0.78
Location: Colorado

2001 Chevrolet Impala


PostPosted: Thu Feb 16, 2012 1:50 am    Post subject:   Reply with quote

The drain is on the drivers side of the radiator. I cracked two(!!) radiators from a crappy cap that I bought from Auto Zone, and then tossed the cap without ever thinking of calling the company and asking them for paying for my radiator.

Only Stant caps for me from now on. Smile

_________________
2001 Galaxy Silver 9C1 w/ L67 and 4T65E-HD...and a few other mods. Wink
Back to top
View user's profile Send private message
barnettimpala
Member Level
Member Level


Joined: Dec 26, 2010
Posts: 1328
Posts per day: 0.53
Location: Hawaii

2002 Chevrolet Impala
2001 Pontiac Grand Prix
2003 Pontiac Grand Prix


PostPosted: Thu Feb 16, 2012 4:16 am    Post subject:   Reply with quote

I have noticed 3 times when I park that it was leaking on the ground when I pulled up in the exact same spot, right where the drain plug is and running down on the lower valence. Has only done it those times and I couldn't figure it out. Also, I have the same crappy brown in my radiator/coolant. Hope you get a solution!

_________________

2002 Impala- SSC, AGX, 18" charger R/t rims w/8mm spacers, Magnaflow cat, U-bend delete, flowmaster 80 series crossflow, z28 tips, HAI, debadged, 35% tint, smoked headlights, full sound system
Back to top
View user's profile Send private message
Domo
Forum Regular
Forum Regular


Joined: Oct 14, 2008
Posts: 293
Posts per day: 0.09
Location: Maryland

2001 Chevrolet Impala
2002 Chevrolet TrailBlazer
2005 Chrysler 300C


PostPosted: Thu Feb 16, 2012 5:55 pm    Post subject:   Reply with quote

Yup.. Cracked Radiator.. Same thing was on mine last summer.

Not hard at all to change yourself. did mine in about 2 1/2 hours I believe.
Back to top
View user's profile Send private message
Danno
Newbie
Newbie


Joined: Feb 06, 2012
Posts: 22
Posts per day: 0.01
Location: Kansas City, MO

2004 Chevrolet Impala


PostPosted: Thu Feb 16, 2012 7:34 pm    Post subject:   Reply with quote

Never had it with any of my Imps, but my Grand Cherokee had that happen. Same random coolant leak. Drained the whole thing pretty quick. I didn't hit anything either, like someone said it just happens. The whole side actually just came apart. Apparently over time the adhesive got soft and just separated. Pretty quick fix to replace, but when every auto parts store you call stocks a radiator from a 1999 Grand Cherokee Limited you know you have a pretty crappy part on your hands.
Back to top
View user's profile Send private message
98ss
Uber
Uber


Joined: Jun 06, 2009
Posts: 817
Posts per day: 0.27
Location: Ann Arbor

2002 Chevrolet Impala
2011 Chevrolet Silverado


PostPosted: Fri Feb 17, 2012 11:14 pm    Post subject:   Reply with quote

Your pet c**k could have broken, or come loose. That is on the driver side, not saying that it couldn't be a radiator, but I would check that 1st.
Back to top
View user's profile Send private message
DennisW
Forum Regular
Forum Regular


Joined: Nov 30, 2010
Posts: 205
Posts per day: 0.08


2004 Chevrolet Impala


PostPosted: Sun Feb 19, 2012 3:21 am    Post subject: Snif ! Re: Leaking Coolant! Reply with quote

TeenBeach wrote:
So just when I thought that my car problem would be over for a while, I am now leaking coolant at a fast rate. I noticed that two days ago, my engine temp was getting pretty high, way over the half mark. I wasn't thinking anything about it the first time I noticed it, but then it got pretty high the next day. I never let it get into the overheating zone though. My low coolant light was not on, but I went to buy some dex-cool and 1/3 of it in there. My temp went back to normal but then again the next day, it started to get high again. I was in my driveway and I was looking around to see if I had any leaks and sure enough I had a puddle of coolant on the concrete, after just 2 minutes of being there! I just added more coolant, started it up and it was leaking pretty fast again. Not like a waterfall, but big drops. Sad

This is very frustrating to me if you can't tell. I know for sure its not my coolant elbows or water pump... because its on the driver side, which I think it is coming off the radiator. Its hard to tell exactly where it is coming from percisely. I snapped some pics for you guys. Sorry, if for some reason there is a right up or solution somewhere. I am in a big hurry, as I do work alot.

The impy will be sitting out in the driveway this weekend since I am going on vacation and taking a train. So its not a major problem at the moment, but it is my DD.


this is where I see a wet line of coolant, not sure where its coming from though??? Its on the radiator.


Its all over the place down here, It would look as if the drain is leaking but I am pretty sure its not. I've never removed it personally.



and its all leaking off of here, onto the ground.

I really hope my radiator isn't cracked, I don't remember hitting anything really hard. Also, when I opened up my radiator cap... there was alot of milkshake in it Crying or Very sad Pretty sure thats becasue I switched over to royal purple without ever changing the LIM gasket.... ugh!

Hopefully you guys can help me out. Thanks for your replys in advance as always!

Peace.


As others have said, looks to be the radiator. New cars with aluminum core radiators use plastic end tanks that are crimped to the core with I believe a gasket between them. I've seen a couple of them simply start to leak between the core and the tank, perhaps because the gasket deteriorated or the crimp came a bit loose over time.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: October 16, 2017, 9:13:06 pm
Page Generation: 0.10 Seconds ( SQL 31:120 in 0.01 Seconds )