NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - Another coolant leak thread
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Another coolant leak thread

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car!
View previous topic :: View next topic  
Author Message
SuperImpala00
Forum Regular
Forum Regular


Joined: Dec 20, 2010
Posts: 195
Posts per day: 0.08
Location: Oregon

2000 Chevrolet Impala


PostPosted: Thu Feb 09, 2012 10:43 pm    Post subject:  Another coolant leak thread Reply with quote

hey guys, need some advice, got a coolant leak and pretty much ruled out the LIM when i saw coolant dripping from the driver's side compartment. Looks like its dripping through the holes at the bottom of where the radiator sits. Hose on that side looks fine, any ideas?
Back to top
View user's profile Send private message
VTSS
Forum Regular
Forum Regular


Joined: Feb 05, 2012
Posts: 219
Posts per day: 0.1
Location: VT

2004 Chevrolet Impala
1994 Mitsubishi 3000GT


PostPosted: Wed Mar 07, 2012 1:31 pm    Post subject:   Reply with quote

The hole at the bottom of the radiator is to drain the fluid. There is a plastic screw on the back side of the radiator that drains the fluid out the bottom when removed. Try tightening it, may need to replace if the seal is broken on the end of the screw.

Back to top
View user's profile Send private message
SuperImpala00
Forum Regular
Forum Regular


Joined: Dec 20, 2010
Posts: 195
Posts per day: 0.08
Location: Oregon

2000 Chevrolet Impala


PostPosted: Wed Mar 07, 2012 3:24 pm    Post subject:   Reply with quote

whoa a reply!!! lol thanks man, I'll have to check that next time I got it up on the lift, appreciate it
Back to top
View user's profile Send private message
VTSS
Forum Regular
Forum Regular


Joined: Feb 05, 2012
Posts: 219
Posts per day: 0.1
Location: VT

2004 Chevrolet Impala
1994 Mitsubishi 3000GT


PostPosted: Thu Mar 08, 2012 12:20 am    Post subject:   Reply with quote

No problem. If its not the drain plug it might be the radiator itself. How many miles are on your car?
Back to top
View user's profile Send private message
Lingenfelter
Uberd0rk!
Uberd0rk!
Gold Contributor (Amount: 1) Gold Contributor


Joined: Oct 21, 2006
Posts: 9331
Posts per day: 2.3
Location: Ontario, Canada

2003 Chevrolet Impala
1999 Yugo Tempo


PostPosted: Thu Mar 08, 2012 12:47 pm    Post subject:   Reply with quote

I didn't see this post come up or I would have suggested a pinhole leak in the rad.

The drain plug seal being damaged or worn is a good possibility as well. The drain plug was hard to spot when I drained mine, but it's not impossible to get at.

_________________
uıɐƃɐ ʎɐqǝ ɯoɹɟ pɹɐoqʎǝʞ ɐ ƃuıʎnq ɹǝʌǝu ɯɐ ı

GMPP Duals, GMPP Handling Kit, NAIOA FWI V2, Silverstar Hi/Lo/Fogs, Viper 5900 Remote Start/Security.
Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
SuperImpala00
Forum Regular
Forum Regular


Joined: Dec 20, 2010
Posts: 195
Posts per day: 0.08
Location: Oregon

2000 Chevrolet Impala


PostPosted: Thu Mar 08, 2012 3:56 pm    Post subject:   Reply with quote

I've got about 265,000 miles on the beast VTSS, Lingenfelter I can only hope its not a pin hole but I've heard they're pretty common on these plastic radiators
Back to top
View user's profile Send private message
sh8dybizness
Master Level
Master Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Feb 18, 2009
Posts: 3616
Posts per day: 1.13
Location: Southern California

2003 Chevrolet Impala


PostPosted: Thu Mar 08, 2012 10:03 pm    Post subject:   Reply with quote

Yup my rad sprung what started as a pin hole leak and turned into a piss stream! A radiator change solved my problem.

_________________

helldorado wrote:
I should be surprised at the lack of knowledge in this thread, but its NAIOA, so I'm not.


whitelightnin04MC wrote:
If you drive stupid, you die stupid.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car! All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: November 24, 2017, 6:49:41 am
Page Generation: 0.12 Seconds ( SQL 29:114 in 0.01 Seconds )