NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - Problems with the 03
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Problems with the 03

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car!
View previous topic :: View next topic  
Author Message
ad0726
Member Level
Member Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Nov 20, 2007
Posts: 1316
Posts per day: 0.36


2001 Chevrolet Impala
2005 Chevrolet Malibu
1983 Datsun Patrol
2003 Chevrolet Impala


PostPosted: Mon Jan 30, 2012 1:52 am    Post subject:  Problems with the 03 Reply with quote

The 03 is acting weird, the car is running fine and suddenly, when I stop at a red light the thing dies, sometimes at any speed the car dies even if I step on the gas, what could it be now?? TPS? IAC valve?

Thanks
Back to top
View user's profile Send private message
2007SSImpala
Dedicated
Dedicated


Joined: Jul 11, 2010
Posts: 344
Posts per day: 0.13
Location: Jacksonville, NC

2007 Chevrolet Impala
2012 Chevrolet Cruze


PostPosted: Mon Jan 30, 2012 6:24 am    Post subject:   Reply with quote

Possible crank sensor. Is your check engine light on?

_________________
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
guinnessfan
Dedicated
Dedicated
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Jan 13, 2008
Posts: 330
Posts per day: 0.09
Location: Three Mile Island, PA

2001 Chevrolet Impala
2004 Buick Rendezvous


PostPosted: Mon Jan 30, 2012 11:00 am    Post subject:   Reply with quote

Yep, check the crank position sensor.
Back to top
View user's profile Send private message
ad0726
Member Level
Member Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Nov 20, 2007
Posts: 1316
Posts per day: 0.36


2001 Chevrolet Impala
2005 Chevrolet Malibu
1983 Datsun Patrol
2003 Chevrolet Impala


PostPosted: Mon Jan 30, 2012 3:26 pm    Post subject:   Reply with quote

The CEL light is off, where is the CPS?
Back to top
View user's profile Send private message
IffyG
NAIOA Moderator
NAIOA Moderator
Silver Contributor (Amount: 1) Silver Contributor


Joined: May 19, 2007
Posts: 13731
Posts per day: 3.58
Location: Nashville, TN

2002 Chevrolet Monte Carlo
1998 Oldsmobile Intrigue
2009 Chevrolet Malibu


PostPosted: Mon Jan 30, 2012 3:41 pm    Post subject:   Reply with quote

Do you have an OBD2 scanner? My car had a pending code for the crankshaft position sensor, but never popped a CEL when my car was cutting out intermittently.

_________________
helldorado wrote:
GLWTGFY. Big Thumbs Up

Dan wrote:
Protip: If you don't know what you're doing, don't do it.


d
Back to top
View user's profile Send private message
ad0726
Member Level
Member Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Nov 20, 2007
Posts: 1316
Posts per day: 0.36


2001 Chevrolet Impala
2005 Chevrolet Malibu
1983 Datsun Patrol
2003 Chevrolet Impala


PostPosted: Mon Jan 30, 2012 6:25 pm    Post subject:   Reply with quote

IffyG wrote:
Do you have an OBD2 scanner? My car had a pending code for the crankshaft position sensor, but never popped a CEL when my car was cutting out intermittently.


No I don't have a scanner, I'm gonna get one.
Anyway, the problem was found (apparently), I swapped the IAC valve and TPS from the 01, and the problem was consistent, then I swapped the MAF problem solved... Confused
I tested the 03 MAF on the 01, the symptoms were the same. Now I need to get a MAF sensor Mad
Back to top
View user's profile Send private message
IffyG
NAIOA Moderator
NAIOA Moderator
Silver Contributor (Amount: 1) Silver Contributor


Joined: May 19, 2007
Posts: 13731
Posts per day: 3.58
Location: Nashville, TN

2002 Chevrolet Monte Carlo
1998 Oldsmobile Intrigue
2009 Chevrolet Malibu


PostPosted: Mon Jan 30, 2012 6:44 pm    Post subject:   Reply with quote

See if you can find a low mileage used one. I got one from Morad and then again from another user on here. The aftermarket ones are shoddy and I'd rather spend 50-75 bucks on a used OEM part than the 200 the parts house wants for whatever craptacular brand they stock.

_________________
helldorado wrote:
GLWTGFY. Big Thumbs Up

Dan wrote:
Protip: If you don't know what you're doing, don't do it.


d
Back to top
View user's profile Send private message
ad0726
Member Level
Member Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Nov 20, 2007
Posts: 1316
Posts per day: 0.36


2001 Chevrolet Impala
2005 Chevrolet Malibu
1983 Datsun Patrol
2003 Chevrolet Impala


PostPosted: Tue Jan 31, 2012 12:37 am    Post subject:   Reply with quote

Yea, I will definitely get a OEM, most likely a used one.
Back to top
View user's profile Send private message
IffyG
NAIOA Moderator
NAIOA Moderator
Silver Contributor (Amount: 1) Silver Contributor


Joined: May 19, 2007
Posts: 13731
Posts per day: 3.58
Location: Nashville, TN

2002 Chevrolet Monte Carlo
1998 Oldsmobile Intrigue
2009 Chevrolet Malibu


PostPosted: Tue Jan 31, 2012 12:22 pm    Post subject:   Reply with quote

Good man. I got about 40K out of my used MAF before it got wrecked by some transmission fluid dripped on the filter a moron at the shop it was at.

_________________
helldorado wrote:
GLWTGFY. Big Thumbs Up

Dan wrote:
Protip: If you don't know what you're doing, don't do it.


d
Back to top
View user's profile Send private message
billy101
Member Level
Member Level


Joined: Sep 12, 2010
Posts: 1704
Posts per day: 0.65
Location: Willow Spring, NC

2001 Chevrolet Impala
2010 Chevrolet Malibu


PostPosted: Tue Jan 31, 2012 1:28 pm    Post subject:   Reply with quote

ad0726 wrote:
Yea, I will definitely get a OEM, most likely a used one.


I have a known good MAF sensor from my 2001 3800, OEM if you're interested.

_________________
2002 Impala LS 3.8 -121,749 miles 11/13/2011
2001 Impala LS 3.8 - 118,510 miles. 9/2/2011. RIP - 11/12/2011
2010 Malibu LTZ 3.6 - 16,014miles. 8/20/2011.
Back to top
View user's profile Send private message
ad0726
Member Level
Member Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Nov 20, 2007
Posts: 1316
Posts per day: 0.36


2001 Chevrolet Impala
2005 Chevrolet Malibu
1983 Datsun Patrol
2003 Chevrolet Impala


PostPosted: Wed Feb 01, 2012 12:31 am    Post subject:   Reply with quote

billy101 wrote:
ad0726 wrote:
Yea, I will definitely get a OEM, most likely a used one.


I have a known good MAF sensor from my 2001 3800, OEM if you're interested.


If I only knew this early morning, you might consider to keep it, it's an expensive sensor with a high rate of failure.
Back to top
View user's profile Send private message
billy101
Member Level
Member Level


Joined: Sep 12, 2010
Posts: 1704
Posts per day: 0.65
Location: Willow Spring, NC

2001 Chevrolet Impala
2010 Chevrolet Malibu


PostPosted: Wed Feb 01, 2012 12:44 am    Post subject:   Reply with quote

ad0726 wrote:
billy101 wrote:
ad0726 wrote:
Yea, I will definitely get a OEM, most likely a used one.


I have a known good MAF sensor from my 2001 3800, OEM if you're interested.


If I only knew this early morning, you might consider to keep it, it's an expensive sensor with a high rate of failure.


Wouldn't have minded selling it to you, but I am going to keep it, just in case.

_________________
2002 Impala LS 3.8 -121,749 miles 11/13/2011
2001 Impala LS 3.8 - 118,510 miles. 9/2/2011. RIP - 11/12/2011
2010 Malibu LTZ 3.6 - 16,014miles. 8/20/2011.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car! All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: November 20, 2017, 1:55:42 am
Page Generation: 0.15 Seconds ( SQL 39:153 in 0.02 Seconds )