NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - security light stays on!
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

security light stays on!

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion
View previous topic :: View next topic  
Author Message
jakes
Newbie
Newbie


Joined: Jan 28, 2012
Posts: 2
Posts per day: 0



PostPosted: Sat Jan 28, 2012 3:38 am    Post subject: Grrrr ! security light stays on! Reply with quote

my security light on my 01 impala stays on.and after awhile when i turn the car off i cant turn it back. i have to wait about 20 minutes for it to turn back on.i need help what can this possibly be?i have no idea.
Back to top
View user's profile Send private message Send e-mail AIM Address
Danno
Newbie
Newbie


Joined: Feb 06, 2012
Posts: 22
Posts per day: 0.01
Location: Kansas City, MO

2004 Chevrolet Impala


PostPosted: Thu Feb 09, 2012 1:35 am    Post subject:   Reply with quote

I've had the same problem too on my old Imp. Take a quick look at the "common problems" sticky at the top of the forum and it should give you some pointers if you ever run into trouble. Pulled this from in there.

"Problem: Security light is on while driving or the car will not start
Likely cause: Something in the passlock system isnít functioning properly
Solution: Replace the ignition cylinder.
Prevention: nothing"

There's also some short term fixes if it won't start. Turning the key to the "on" position for about 10 minutes and leaving it there before attempting to start the car generally gets good results. Not always ideal, but it will at least get you to the shop instead of a tow bill. Good luck!!
Back to top
View user's profile Send private message
MixedImpala04
Newbie
Newbie


Joined: Jun 16, 2011
Posts: 9
Posts per day: 0
Location: Merced,CA

2004 Chevrolet Impala


PostPosted: Thu Mar 08, 2012 12:08 am    Post subject:   Reply with quote

there is a security pigtail behind the lock cylinder, that is most likely it not the lock cylinder itself. i just changed mine because i was having the same problems. its an easy install and part is on rockauto.com
Back to top
View user's profile Send private message
IffyG
NAIOA Moderator
NAIOA Moderator
Silver Contributor (Amount: 1) Silver Contributor


Joined: May 19, 2007
Posts: 13731
Posts per day: 3.6
Location: Nashville, TN

2002 Chevrolet Monte Carlo
1998 Oldsmobile Intrigue
2009 Chevrolet Malibu


PostPosted: Thu Mar 08, 2012 12:34 am    Post subject:   Reply with quote

You would be the first person I've ever heard of with the pigtail being the problem. The vast majority of security light issues are bad components in the lock cylinder itself.

_________________
helldorado wrote:
GLWTGFY. Big Thumbs Up

Dan wrote:
Protip: If you don't know what you're doing, don't do it.


d
Back to top
View user's profile Send private message
2001Ls
Resident
Resident


Joined: Jun 26, 2009
Posts: 715
Posts per day: 0.24
Location: New Jersey New Milford

2001 Chevrolet Impala


PostPosted: Thu Mar 08, 2012 1:05 pm    Post subject:   Reply with quote

I had that problem and it stopped when my body control module was replaced.

_________________


2001 Impala LS 81k as of Nov,2011
3.8 V6 3800 Series 2
Back to top
View user's profile Send private message
richp04impala
Newbie
Newbie


Joined: Mar 01, 2012
Posts: 41
Posts per day: 0.02
Location: LB, CA


PostPosted: Thu Mar 08, 2012 7:40 pm    Post subject:   Reply with quote

had the same issue my battery was dying once replaced, no more issues and its been over 20k
Back to top
View user's profile Send private message
sh8dybizness
Master Level
Master Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Feb 18, 2009
Posts: 3616
Posts per day: 1.14
Location: Southern California

2003 Chevrolet Impala


PostPosted: Thu Mar 08, 2012 10:06 pm    Post subject:   Reply with quote

IffyG wrote:
You would be the first person I've ever heard of with the pigtail being the problem. The vast majority of security light issues are bad components in the lock cylinder itself.
Im With Stupid

_________________

helldorado wrote:
I should be surprised at the lack of knowledge in this thread, but its NAIOA, so I'm not.


whitelightnin04MC wrote:
If you drive stupid, you die stupid.
Back to top
View user's profile Send private message
Danny_9C1
Resident
Resident


Joined: Jun 30, 2009
Posts: 595
Posts per day: 0.2
Location: Western NY

2004 Chevrolet Impala
1999 Chevrolet Tahoe


PostPosted: Fri Mar 09, 2012 8:44 pm    Post subject:   Reply with quote

I had a simular issue but it was just bad connections inside the gray plug that goes onto my ICM.(Ignition control modual)

_________________

1999 Chevy Z56 Tahoe PPV.2004 Ford Crown Victoria Police Interceptor,
2007 Chevy 9C1 Impala.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: October 22, 2017, 4:12:24 pm
Page Generation: 0.10 Seconds ( SQL 31:114 in 0.01 Seconds )