NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - Thinking fuel filter
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Thinking fuel filter

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car!
View previous topic :: View next topic  
Author Message
BLK2000LS
Cadet
Cadet


Joined: Nov 23, 2008
Posts: 77
Posts per day: 0.02
Location: Jacksonville FL

2000 Chevrolet Impala


PostPosted: Tue Dec 20, 2011 8:48 am    Post subject:  Thinking fuel filter Reply with quote

So I was in my way to work this morning. The car was up to normal operating tempature so I eased on the throttle to get on the interstate then its like the car lost power for a slight second then regained normal power. So then tried the same practice again going wot around 65 MPH and same effect. So any suggestions fellas I'm leaning toward the fuel filter.
Back to top
View user's profile Send private message
chibiblacksheep
Member Level
Member Level


Joined: Dec 14, 2009
Posts: 1369
Posts per day: 0.47
Location: Philadelphia, PA

2000 Chevrolet Monte Carlo
2007 Chevrolet Impala
1968 Chevrolet Camaro
2013 Chevrolet Camaro


PostPosted: Tue Dec 20, 2011 10:00 am    Post subject:   Reply with quote

Could also be a clogging cat.

_________________
Back to top
View user's profile Send private message Send e-mail AIM Address
2001Ls
Resident
Resident


Joined: Jun 26, 2009
Posts: 715
Posts per day: 0.23
Location: New Jersey New Milford

2001 Chevrolet Impala


PostPosted: Tue Dec 20, 2011 10:16 am    Post subject:   Reply with quote

Could be bad gas, failing MAF, clogged cat. Try thinking about the type of gas you filled with last, was it knock off?

_________________


2001 Impala LS 81k as of Nov,2011
3.8 V6 3800 Series 2
Back to top
View user's profile Send private message
BLK2000LS
Cadet
Cadet


Joined: Nov 23, 2008
Posts: 77
Posts per day: 0.02
Location: Jacksonville FL

2000 Chevrolet Impala


PostPosted: Tue Dec 20, 2011 3:37 pm    Post subject:   Reply with quote

It was shell gas two days ago.
Back to top
View user's profile Send private message
davidhoutz
Uber
Uber


Joined: Feb 28, 2008
Posts: 978
Posts per day: 0.28
Location: Clemmons NC

2001 Chevrolet Impala


PostPosted: Tue Dec 20, 2011 5:21 pm    Post subject:   Reply with quote

I would say not the fuel filter. Your fuel pump is going to push the amount of fuel you need. But, if its clogged with something maybe. But then I would think it would do it all the time. I know expert, just throwing my $.02 out there. Fuel filters are like $15 so it couldn't hurt. I change mine every 15,000 or so.
Back to top
View user's profile Send private message
98ss
Uber
Uber


Joined: Jun 06, 2009
Posts: 818
Posts per day: 0.26
Location: Ann Arbor

2002 Chevrolet Impala
2011 Chevrolet Silverado


PostPosted: Tue Dec 20, 2011 8:43 pm    Post subject:   Reply with quote

If the fuel filter is more than 30k old, then it wouldn't hurt to change. If it is the cat, eventually you should get a p0300 random misfire code.
Back to top
View user's profile Send private message
2001Ls
Resident
Resident


Joined: Jun 26, 2009
Posts: 715
Posts per day: 0.23
Location: New Jersey New Milford

2001 Chevrolet Impala


PostPosted: Wed Dec 21, 2011 1:17 am    Post subject:   Reply with quote

I just went through this routine, the fuel filter was not the problem, I had poor gas and the Cat was clogged. Sounds like gas is fine which would lead me to believe that your cat is clogged. Im not a mechanic but I couldn't figure it out. If its any incentive to get the car replaced my car is running like %25 better , stonger, and quicker with the new car. It will improve your preformance if youve had a plugged up cat for a while.

_________________


2001 Impala LS 81k as of Nov,2011
3.8 V6 3800 Series 2
Back to top
View user's profile Send private message
habermehl
Member Level
Member Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Jul 29, 2010
Posts: 1374
Posts per day: 0.51
Location: Ontario

2001 Chevrolet Impala
2007 Chevrolet Impala


PostPosted: Wed Dec 21, 2011 9:13 pm    Post subject:   Reply with quote

Kinda sounds like one of the symptoms I had and it was clogged cat it will get worse

_________________
bbengineer wrote:
And yes, I spend a lot of time deleting useless posts... many of which are yours
BBEngineer


billy101 wrote:
Conner wrote:
how do the dealer's expect us to get the cars there if they don 't run at all?


Tow Truck?
Back to top
View user's profile Send private message Send e-mail
BLK2000LS
Cadet
Cadet


Joined: Nov 23, 2008
Posts: 77
Posts per day: 0.02
Location: Jacksonville FL

2000 Chevrolet Impala


PostPosted: Fri Dec 23, 2011 5:11 pm    Post subject:   Reply with quote

Yeah it has been running fine since that one time..so who knows i think ill just put a purchase a new cat anyway. Along with fuel filter its been a while since i changed it.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car! All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: November 19, 2017, 10:01:47 am
Page Generation: 0.11 Seconds ( SQL 33:119 in 0.01 Seconds )