NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - 2004 impala 3400. p0300 random misfire
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

2004 impala 3400. p0300 random misfire

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car!
View previous topic :: View next topic  
Author Message
morkuma
Master Level
Master Level
Diamond Contributor (Amount: 1) Diamond Contributor


Joined: Sep 18, 2007
Posts: 3360
Posts per day: 0.92
Location: abbotsford, bc, canada

2004 Chevrolet Impala


PostPosted: Mon Dec 05, 2011 12:02 pm    Post subject:  2004 impala 3400. p0300 random misfire Reply with quote

Oh its just me again. Long time since I have been around...

P0300 - random misfire
Only happens on cold startup, interceptor guages only really show the misfires on #2, ranges from 50ish to 200ish at a time, only when dead cold. Lasts about 4 minutes sitting at idle, or 2 min if I just start driving. Minor backfiring as well.
During normal driving I get minor misfires (2-4) on all 6, but few and far between, and usually only when at a stop.
Started in the past few weeks since we have been seeing negative temps in the am, but does it all the time on a cold start, no matter what the temp.

Have replaced front plugs and wires, reconnected my egr and took the block off out (which made it worse once I plugged it in, but back to the initial problem once unplugged (its my old dead egr, was just testing))
Have cleaned the maf, throttlebody, and done visual inspections on everything, used an injector cleaner in hopes it was just something stupid.
Car has to go for first inspection ever in 8 days, and it won't pass with the code.

Any ideas? Don't want to dig too deep, as the plan was to pass inspection then sell it off. Been a good car, but I need something else now. If there is a good chance it is the egr (I have deleted all egr codes so nothing is popping up, don't currently have a laptop to re-add all the codes, or do proper scans with the software, relying on my interceptor gagues.)

_________________
No longer fat.
Back to top
View user's profile Send private message Visit poster's website AIM Address MSN Messenger
PBnj
Dedicated
Dedicated
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Aug 01, 2007
Posts: 476
Posts per day: 0.13


2003 Chevrolet Impala


PostPosted: Mon Dec 05, 2011 12:51 pm    Post subject:   Reply with quote

maybe a clogged fuel injector? :2cents:

if you demod her before selling, I got dibs on the engine cover an filler
Back to top
View user's profile Send private message Send e-mail
morkuma
Master Level
Master Level
Diamond Contributor (Amount: 1) Diamond Contributor


Joined: Sep 18, 2007
Posts: 3360
Posts per day: 0.92
Location: abbotsford, bc, canada

2004 Chevrolet Impala


PostPosted: Mon Dec 05, 2011 1:11 pm    Post subject:   Reply with quote

Threw some injector cleaner in her on saturday and have driven her for 8 hours or so since, no change. I relize it could be the actual injector and not just dirty, but I feel some change would have happened.
I hope it is some cheap fix as I don't want to drop a wackload of cash into. It right before I sell.

_________________
No longer fat.
Back to top
View user's profile Send private message Visit poster's website AIM Address MSN Messenger
ZSPOT
NAIOA Moderator
NAIOA Moderator
Gold Contributor (Amount: 1) Gold Contributor


Joined: Mar 14, 2005
Posts: 5891
Posts per day: 1.29
Location: Wamego, KS

2001 Chevrolet Impala
2004 Ford Mustang
1981 Chevrolet Silverado
2007 Chevrolet Silverado


PostPosted: Mon Dec 05, 2011 1:25 pm    Post subject:   Reply with quote

Is it only P0300?

You can try the 'ol spray bottle technique on your ignition components and check for arching.

_________________
Back to top
View user's profile Send private message Send e-mail Visit poster's website
chibiblacksheep
Member Level
Member Level


Joined: Dec 14, 2009
Posts: 1369
Posts per day: 0.48
Location: Philadelphia, PA

2000 Chevrolet Monte Carlo
2007 Chevrolet Impala
1968 Chevrolet Camaro
2013 Chevrolet Camaro


PostPosted: Mon Dec 05, 2011 2:25 pm    Post subject:   Reply with quote

What plugs did you replace with?

_________________
Back to top
View user's profile Send private message Send e-mail AIM Address
morkuma
Master Level
Master Level
Diamond Contributor (Amount: 1) Diamond Contributor


Joined: Sep 18, 2007
Posts: 3360
Posts per day: 0.92
Location: abbotsford, bc, canada

2004 Chevrolet Impala


PostPosted: Mon Dec 05, 2011 3:17 pm    Post subject:   Reply with quote

ZSPOT wrote:
Is it only P0300?

You can try the 'ol spray bottle technique on your ignition components and check for arching.



Yes, it is only p0300 as far as I see, but the egr codes were all previously deleted when I did the egr delete. (And I have no current way of adding them back in, no laptop anymore)

And I used acdelco plugs

_________________
No longer fat.
Back to top
View user's profile Send private message Visit poster's website AIM Address MSN Messenger
morkuma
Master Level
Master Level
Diamond Contributor (Amount: 1) Diamond Contributor


Joined: Sep 18, 2007
Posts: 3360
Posts per day: 0.92
Location: abbotsford, bc, canada

2004 Chevrolet Impala


PostPosted: Fri Dec 09, 2011 12:09 pm    Post subject:   Reply with quote

Brought it to a shop. Full scan and diagnosis. Nothing found. Pressure tested email everything. Nothing found. Replaced rad cap because he noticed the pressure release was plugged. Misfires dropped to almost nothing.
Shocked Shocked

_________________
No longer fat.
Back to top
View user's profile Send private message Visit poster's website AIM Address MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car! All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: September 19, 2017, 8:57:50 pm
Page Generation: 0.10 Seconds ( SQL 29:121 in 0.01 Seconds )