NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - No power from my 03 Impala HELP
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

No power from my 03 Impala HELP

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion
View previous topic :: View next topic  
Author Message
03impala
Newbie
Newbie


Joined: Mar 23, 2011
Posts: 29
Posts per day: 0.01
Location: Dupage county, il


PostPosted: Fri Dec 02, 2011 3:43 am    Post subject:  No power from my 03 Impala HELP Reply with quote

A little back ground first.

I have an 03 Impala, with the 3.4. I have had the car for 8 months. The car had 133k on it when I bought it, and now it has 140k.

The car has always seemed like it was low on power, but it seems to be getting worse.

I have no CEL on. The car is smooth, idles nice, but takes it time getting up to speed. When you have it up to speed it can be hard to keep it there. The car will kick down to 3rd gear way to easy when you have the cruise set at 70 and you go up a very slight incline. If you try to go up that same slight incline with the cruise off, you have to step on the gas pedal or else you'll drop down to 55mph.

I drive this road everyday. My other car is a 98 Chevy Lumina, 3.1 with 228k .

My Lumina goes down the same road and has no issues going up this slight incline at 70-80mph and never has to down shift to do it.
The Lumina is quicker coming off the line too. ( I drive easy, no WOT for me.)

Why does my car not have enough power, why don't I have any CEL on?
What would you look at first? The car doesn't burn or use any oil between oil changes. Any help would be great.
Back to top
View user's profile Send private message
00impala123
Senior Level
Senior Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Feb 01, 2010
Posts: 2653
Posts per day: 0.92
Location: Chicago, IL

2000 Chevrolet Impala


PostPosted: Fri Dec 02, 2011 4:18 am    Post subject:   Reply with quote

you should have the cat checked. also, where in dupage county are you? If you want to meet up next weekend I can plug in my scanner and see if there are any stored codes not throwing a CEL and help you look at it.

_________________
Back to top
View user's profile Send private message
03impala
Newbie
Newbie


Joined: Mar 23, 2011
Posts: 29
Posts per day: 0.01
Location: Dupage county, il


PostPosted: Fri Dec 02, 2011 5:06 am    Post subject:   Reply with quote

00impala123 wrote:
you should have the cat checked. also, where in dupage county are you? If you want to meet up next weekend I can plug in my scanner and see if there are any stored codes not throwing a CEL and help you look at it.


I'm near rt.59 and 64. I was thinking about the cat being clogged too.
How do you check a cat if they are no codes.

One other thing, my gas mileage is crappy, low 20's at best.
I guess a clogged cat would cause that too.

Thank you
Back to top
View user's profile Send private message
PushrodPower
Uberd0rk!
Uberd0rk!
Platinum Contributor (Amount: 1) Platinum Contributor


Joined: Nov 30, 2008
Posts: 6396
Posts per day: 1.94
Location: I love drawing butts on stuff.

2005 Chevrolet Impala
1996 Saturn S-Series


PostPosted: Fri Dec 02, 2011 2:23 pm    Post subject:   Reply with quote

Low 20's city or highway? You can have a backpressure test done too see if the cat is indeed clogged.

_________________

"The skippers been drinking, oh yes he has you can tell."-Bob Ross
04ImpalaSS wrote:
How much miles are on those seats? How much pounds of ass were applied to the seat during every trip? Lol

wedebrook wrote:
This thread is about *this* far from being about me, all oiled up, eating chili mac in a walmart bathroom.

nightryder wrote:
My c**k broke.
Back to top
View user's profile Send private message
00impala123
Senior Level
Senior Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Feb 01, 2010
Posts: 2653
Posts per day: 0.92
Location: Chicago, IL

2000 Chevrolet Impala


PostPosted: Fri Dec 02, 2011 4:08 pm    Post subject:   Reply with quote

03impala wrote:
00impala123 wrote:
you should have the cat checked. also, where in dupage county are you? If you want to meet up next weekend I can plug in my scanner and see if there are any stored codes not throwing a CEL and help you look at it.


I'm near rt.59 and 64. I was thinking about the cat being clogged too.
How do you check a cat if they are no codes.

One other thing, my gas mileage is crappy, low 20's at best.
I guess a clogged cat would cause that too.

Thank you


You're a little more north than I was hoping haha. I'm in new lenox. but PM me if you want/need to meet up. I would def take it to an exhaust shop and have it backpressure tested. its a good starting point.

_________________
Back to top
View user's profile Send private message
Danny_9C1
Resident
Resident


Joined: Jun 30, 2009
Posts: 595
Posts per day: 0.19
Location: Western NY

2004 Chevrolet Impala
1999 Chevrolet Tahoe


PostPosted: Fri Dec 02, 2011 7:59 pm    Post subject:   Reply with quote

Check your air filter,make sure its good,seafoam your intake,replace fuel filter,new sparkplugs if needed,clean your MAF(Mass air flow senser).

Seafoam treatment video.
http://www.youtube.com/watch?v=jGvlZ2u5As0

Also...Acetone cleaning.
http://www.youtube.com/watch?v.....re=related

Good luck!

_________________

1999 Chevy Z56 Tahoe PPV.2004 Ford Crown Victoria Police Interceptor,
2007 Chevy 9C1 Impala.
Back to top
View user's profile Send private message
topgun
Resident
Resident


Joined: May 19, 2011
Posts: 639
Posts per day: 0.27
Location: Upstate N Y

2005 Chevrolet Impala


PostPosted: Sat Dec 03, 2011 8:27 pm    Post subject:  no power . . . Reply with quote

Remove the O2 sensor just before the cat. Drive car (will be very loud). If drives good = bad cat. Cool

_________________
Untamed . . . and don't try to change me
Back to top
View user's profile Send private message
amoffitt
Member Level
Member Level


Joined: Oct 09, 2007
Posts: 1770
Posts per day: 0.48
Location: Tyler TX

2003 Chevrolet Impala
2003 Infiniti G35
2007 BMW 3 Series
2009 Mercedes-Benz C Class


PostPosted: Sat Dec 03, 2011 8:36 pm    Post subject:   Reply with quote

Danny_9C1 wrote:
Check your air filter,make sure its good,seafoam your intake,replace fuel filter,new sparkplugs if needed,clean your MAF(Mass air flow senser).

Seafoam treatment video.
http://www.youtube.com/watch?v=jGvlZ2u5As0

Also...Acetone cleaning.
http://www.youtube.com/watch?v.....re=related

Good luck!


Has anyone tried the stuff in the fuel and running the car at 2500 RPMs for 30 mins in one of our cars? I have P0420 currently on the car atm but i dont pay attention to it so much because the catalytic converter has been replaced before and it currently has a Magnaflow one on there.

_________________
http://www.youtube.com/watch?v=2PCLugUV33M


Vehicles:
2003 Chevy Impala- Current, 2003 Infiniti G35 Coupe- Sold, 2007 Yamaha R6s- Sold, 2007 BMW 335i- Current, 2008 Yamaha R1- Current
Back to top
View user's profile Send private message AIM Address
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: December 16, 2017, 2:37:15 pm
Page Generation: 0.11 Seconds ( SQL 31:117 in 0.01 Seconds )