NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - Noise from under the hood.
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Noise from under the hood.

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car!
View previous topic :: View next topic  
Author Message
07ImpalaMark
Cadet
Cadet


Joined: Aug 19, 2007
Posts: 81
Posts per day: 0.02
Location: Tennessee

2007 Chevrolet Impala


PostPosted: Tue Oct 04, 2011 2:04 pm    Post subject:  Noise from under the hood. Reply with quote

My 07 with 3.9 has had an intermittent problem with a noise that sounds like the power steering pump. When the engine is at idle it doesn't make the sound but off idle upon acceleration it makes a whining sound. I checked the fluid level and it was right on the add mark so I added some fluid and the sound continued as loud as ever.

Ok, so I go purchase a new AC Delco pump and after a couple days the noise reduced to a very faint sound. I returned the new pump and for the last two weeks the car is doing well except for the same sound at the reduced level. I'm now wondering if damage was done to the pump before I added fluid or if something else is making the noise. It was only to the add mark and that was a cold reading. A friend that was a GM Tech says that pulleys can imitate that sound so I'm in a quandry about re-purchasing a pump or not. Any ideas as to how to accurately diagnose?

I don't mind buying a pump but if it's something else then I'm stuck unnecessary expense. the sound sometimes is worse when I turn at slow speed under a strain but sometimes it's there just when driving in a straight line.

Any suggestions will be much appreciated. Oh, the car now has 82,000 mi.

_________________
2012 Impala LTZ White with Grey Leather.

Lots of junk in my garage and in my head.
Back to top
View user's profile Send private message
IffyG
NAIOA Moderator
NAIOA Moderator
Silver Contributor (Amount: 1) Silver Contributor


Joined: May 19, 2007
Posts: 13731
Posts per day: 3.63
Location: Nashville, TN

2002 Chevrolet Monte Carlo
1998 Oldsmobile Intrigue
2009 Chevrolet Malibu


PostPosted: Tue Oct 04, 2011 3:09 pm    Post subject:   Reply with quote

I can't speak for your exact power steering pump as I have a 3800 engine, but when I blew out my power steering line and pretty much drained the pump, it was never the same.

However, since you mention you are hearing the noise when you are going in a straight line that makes me think you might have a pulley that is dragging. Can you take the belt off and make sure everything spins freely?

_________________
helldorado wrote:
GLWTGFY. Big Thumbs Up

Dan wrote:
Protip: If you don't know what you're doing, don't do it.


d
Back to top
View user's profile Send private message
topgun
Resident
Resident


Joined: May 19, 2011
Posts: 639
Posts per day: 0.28
Location: Upstate N Y

2005 Chevrolet Impala


PostPosted: Tue Oct 04, 2011 5:34 pm    Post subject:  noise from under hood Reply with quote

Could it be an alternator whine? Cool

_________________
Untamed . . . and don't try to change me
Back to top
View user's profile Send private message
07ImpalaMark
Cadet
Cadet


Joined: Aug 19, 2007
Posts: 81
Posts per day: 0.02
Location: Tennessee

2007 Chevrolet Impala


PostPosted: Tue Oct 04, 2011 8:04 pm    Post subject:   Reply with quote

Thanks for the response from both of you.

I have removed the belt and everything turned by hand seems to be ok but the noise won't happen until off-idle from about 1500 rpm's and up.

At first I thought it could be the alternator and it could still be. I find it very hard to narrow down the noise by listening under the hood. Maybe I should try the trick of sticking a broom handle near each pulley and listening for the sound to transfer that way. Problem is we all know how tight the engine fit is and I'm a bit afraid of getting broom handle into the belt and ending up like Van Gogh (LOL)!

I mainly am wondering if this is a common problem that others have had and maybe they would know a common culprit.

Anybody please feel free to chime in with ANY suggestion. I'm on a fixed income and can't afford to buy parts and do a shotgun approach.

The water pump was replaced under the drivetrain warranty at about 70,000 mi. plus they replaced the belt because the leaking water pump soaked the old one. All was well then.

I've also noticed that on a cold start the belt will squeak for a nanosecond just as the engine starts but never makes a sound after that. May or may not be related but I thought I'd throw it in. The squeak started before the water pump was replaced. HELP!

_________________
2012 Impala LTZ White with Grey Leather.

Lots of junk in my garage and in my head.
Back to top
View user's profile Send private message
07ImpalaMark
Cadet
Cadet


Joined: Aug 19, 2007
Posts: 81
Posts per day: 0.02
Location: Tennessee

2007 Chevrolet Impala


PostPosted: Wed Oct 12, 2011 9:49 pm    Post subject:   Reply with quote

Well, over a period of a few days the noise stopped. I believe when the power steering fluid was at the add mark it somehow got air in the system and when I added fluid it just took time for the system to bleed out the air.

I returned the new pump. Maybe the threat of working on it made my car straighten up! LOL!. Very Happy

_________________
2012 Impala LTZ White with Grey Leather.

Lots of junk in my garage and in my head.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car! All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: September 21, 2017, 12:42:19 pm
Page Generation: 0.09 Seconds ( SQL 25:108 in 0.00 Seconds )