NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - Rear Defrost Quit Working
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Rear Defrost Quit Working

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion
View previous topic :: View next topic  
Author Message
mmumtaz3
Newbie
Newbie


Joined: Jul 22, 2011
Posts: 31
Posts per day: 0.01
Location: GTA

2005 Chevrolet Impala


PostPosted: Fri Sep 30, 2011 10:02 am    Post subject:  Rear Defrost Quit Working Reply with quote

Hey my rear defrost quit working, the defrost light turns on but I dont hear a click and I also cant check if my headlights dim because of hids. Ive left it on for atleast 5mins and noticed that the windshield was cold and so were the wires.

Also the passenger side window doesn't go up from the driverside anymore it does go down but I have to lean over and pull up the window using the passenger switch not sure if this related to the defrost problem but I noticed them both at the same time.
Back to top
View user's profile Send private message
topgun
Resident
Resident


Joined: May 19, 2011
Posts: 639
Posts per day: 0.27
Location: Upstate N Y

2005 Chevrolet Impala


PostPosted: Fri Sep 30, 2011 10:28 am    Post subject:  rear defrost quit . . . Reply with quote

Rear defrost - Must be a fuse or fused relay for that somewhere, check that.
pass window - if it goes down, must go up, motor ok. Probably contact in switch or broken wire maybe in harness that enters the door. Cool

_________________
Untamed . . . and don't try to change me
Back to top
View user's profile Send private message
shotokan
Forum Regular
Forum Regular


Joined: May 18, 2009
Posts: 208
Posts per day: 0.07
Location: Langley, B.C.

2006 Chevrolet Impala


PostPosted: Sat Oct 01, 2011 1:14 pm    Post subject: Snif !  Reply with quote

defrost - check thet the wires are still attached to the glass, mine detached on one side ( re-soldered to the glass and works again). Also these cars are known for the connector behind the passenger front kick panel to fry Sad

window - pull the panel and check that the motor is still good and that glass clips and actuator assemblies haven't come apart

Good luck!
Back to top
View user's profile Send private message
spacewalker404
Resident
Resident
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Jan 25, 2007
Posts: 579
Posts per day: 0.15
Location: Not of this world

2004 Chevrolet Impala
2000 Chevrolet S10


PostPosted: Sat Oct 01, 2011 4:57 pm    Post subject:   Reply with quote

My problem ended up being a bad c/b.
The photos were an enormous help to me in the pin location of the c/b. http://www.naioa.com/v2/module.....mp;t=44376

_________________
Back to top
View user's profile Send private message
HotSauce6226
Uberd0rk!
Uberd0rk!
Diamond Contributor (Amount: 1) Diamond Contributor


Joined: Mar 01, 2007
Posts: 5744
Posts per day: 1.48
Location: Louisville, KY

2003 Chevrolet Impala
2004 Chevrolet Impala


PostPosted: Sun Oct 02, 2011 12:15 am    Post subject:   Reply with quote

The contacts are dirty. Take apart and clean and it will work.

_________________
2004 Chevy Impala SS Indy Edition - 3800 Supercharged - Alot of Mods
Contact me for LED interior conversions

Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: October 19, 2017, 10:28:27 pm
Page Generation: 0.09 Seconds ( SQL 25:109 in 0.01 Seconds )