NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - Low fuel pressure.....
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Low fuel pressure.....

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 Engine, Exhaust and Transmission
View previous topic :: View next topic  
Author Message
GOTIT4CHEAP16
Senior Level
Senior Level


Joined: Sep 12, 2008
Posts: 2681
Posts per day: 0.81
Location: Bowie, MD

2000 Chevrolet Impala


PostPosted: Wed Sep 21, 2011 8:25 pm    Post subject:  Low fuel pressure..... Reply with quote

So how do i fix this?

http://www.youtube.com/watch?v=_rICkn5pVEs

Ive replaced fuel filter, cleaned maf. Dont know what else to do. Where should my fuel pressure be?

_________________
L67 Engine Swapped w/ 2005 Impala SS
Mods: 3.0 MPS | Gen V | N* TB | LQ4 MAF | 130# Springs | XP Cam | |Stage 3 Ported Heads| Roller Master Double Timing Set | CAI | PRJ Wires | AL104 | Speed Daddy Headers | EGR Delete | ZZP Stage 2 Intercooler | 42lb Injectors |
13.4 @ 106


http://www.cardomain.com/ride/3183434


Last edited by GOTIT4CHEAP16 on Wed Sep 21, 2011 8:41 pm; edited 1 time in total
Back to top
View user's profile Send private message
billy101
Member Level
Member Level


Joined: Sep 12, 2010
Posts: 1704
Posts per day: 0.66
Location: Willow Spring, NC

2001 Chevrolet Impala
2010 Chevrolet Malibu


PostPosted: Wed Sep 21, 2011 8:32 pm    Post subject:  Re: Low fuel pressure..... Reply with quote

GOTIT4CHEAP16 wrote:
So how do i fix this?

http://www.youtube.com/watch?v=_rICkn5pVEs

Ive replaced fuel filter, cleaned maf. Dont know what else to do. Where should my fuel pressure be?



Video is private

_________________
2002 Impala LS 3.8 -121,749 miles 11/13/2011
2001 Impala LS 3.8 - 118,510 miles. 9/2/2011. RIP - 11/12/2011
2010 Malibu LTZ 3.6 - 16,014miles. 8/20/2011.
Back to top
View user's profile Send private message
GOTIT4CHEAP16
Senior Level
Senior Level


Joined: Sep 12, 2008
Posts: 2681
Posts per day: 0.81
Location: Bowie, MD

2000 Chevrolet Impala


PostPosted: Wed Sep 21, 2011 8:44 pm    Post subject:   Reply with quote

Fixed

_________________
L67 Engine Swapped w/ 2005 Impala SS
Mods: 3.0 MPS | Gen V | N* TB | LQ4 MAF | 130# Springs | XP Cam | |Stage 3 Ported Heads| Roller Master Double Timing Set | CAI | PRJ Wires | AL104 | Speed Daddy Headers | EGR Delete | ZZP Stage 2 Intercooler | 42lb Injectors |
13.4 @ 106


http://www.cardomain.com/ride/3183434
Back to top
View user's profile Send private message
billy101
Member Level
Member Level


Joined: Sep 12, 2010
Posts: 1704
Posts per day: 0.66
Location: Willow Spring, NC

2001 Chevrolet Impala
2010 Chevrolet Malibu


PostPosted: Wed Sep 21, 2011 8:53 pm    Post subject:   Reply with quote

Have you changed your FPR lately? I think fuel pressure specs are between 50 and 56 psi.

_________________
2002 Impala LS 3.8 -121,749 miles 11/13/2011
2001 Impala LS 3.8 - 118,510 miles. 9/2/2011. RIP - 11/12/2011
2010 Malibu LTZ 3.6 - 16,014miles. 8/20/2011.
Back to top
View user's profile Send private message
nightryder
Master Level
Master Level
Silver Contributor (Amount: 1) Silver Contributor


Joined: Oct 18, 2006
Posts: 3256
Posts per day: 0.82
Location: Lockport NY

2001 Chevrolet Impala
2005 Subaru Impreza


PostPosted: Wed Sep 21, 2011 8:56 pm    Post subject:   Reply with quote

Check the vac/boost line connection to the FPR. You should be around 45psi at idle.

_________________
Back to top
View user's profile Send private message AIM Address
GOTIT4CHEAP16
Senior Level
Senior Level


Joined: Sep 12, 2008
Posts: 2681
Posts per day: 0.81
Location: Bowie, MD

2000 Chevrolet Impala


PostPosted: Wed Sep 21, 2011 9:01 pm    Post subject:   Reply with quote

Ive checked all those. I have the zzp fuel rails installed and my i/c core is removed for now.

I have my vacuum ran as....

under supercharger snout ....map sensor.....FPR.....Boost sensor.

_________________
L67 Engine Swapped w/ 2005 Impala SS
Mods: 3.0 MPS | Gen V | N* TB | LQ4 MAF | 130# Springs | XP Cam | |Stage 3 Ported Heads| Roller Master Double Timing Set | CAI | PRJ Wires | AL104 | Speed Daddy Headers | EGR Delete | ZZP Stage 2 Intercooler | 42lb Injectors |
13.4 @ 106


http://www.cardomain.com/ride/3183434
Back to top
View user's profile Send private message
nightryder
Master Level
Master Level
Silver Contributor (Amount: 1) Silver Contributor


Joined: Oct 18, 2006
Posts: 3256
Posts per day: 0.82
Location: Lockport NY

2001 Chevrolet Impala
2005 Subaru Impreza


PostPosted: Thu Sep 22, 2011 12:34 pm    Post subject:   Reply with quote

How much vacuum are you making at idle? I'm assuming you mean you have ZZP modified rails and not their billet rails as you can't use the stock FPR with those rails.

That gauge looks very erratic, almost like the needle is sticking, I would verify that it's not a faulty gauge first (looks like auto-zone crap). If it's not the gauge It looks to me like you have a sporadic vac leak, a fuel leak (could be a bad connection to the gauge), or the pump is kicking on and off for some reason.

_________________
Back to top
View user's profile Send private message AIM Address
billy101
Member Level
Member Level


Joined: Sep 12, 2010
Posts: 1704
Posts per day: 0.66
Location: Willow Spring, NC

2001 Chevrolet Impala
2010 Chevrolet Malibu


PostPosted: Thu Sep 22, 2011 1:01 pm    Post subject:   Reply with quote

nightryder wrote:
How much vacuum are you making at idle? I'm assuming you mean you have ZZP modified rails and not their billet rails as you can't use the stock FPR with those rails.

That gauge looks very erratic, almost like the needle is sticking, I would verify that it's not a faulty gauge first (looks like auto-zone crap). If it's not the gauge It looks to me like you have a sporadic vac leak, a fuel leak (could be a bad connection to the gauge), or the pump is kicking on and off for some reason.


I don't think it's a faulty gauge. If you listen to the video and watch the needle the motor changes in sound when the fuel pressure makes that jump up.

_________________
2002 Impala LS 3.8 -121,749 miles 11/13/2011
2001 Impala LS 3.8 - 118,510 miles. 9/2/2011. RIP - 11/12/2011
2010 Malibu LTZ 3.6 - 16,014miles. 8/20/2011.
Back to top
View user's profile Send private message
GOTIT4CHEAP16
Senior Level
Senior Level


Joined: Sep 12, 2008
Posts: 2681
Posts per day: 0.81
Location: Bowie, MD

2000 Chevrolet Impala


PostPosted: Thu Sep 22, 2011 1:36 pm    Post subject:   Reply with quote

Yea I double checked and the gauge is good. Hooked up my android torque app and at idle I'm getting 20 vacuum but then drops to 16 and back to 20 and repeats its self. Swapped fpr and nothing changed. Also checked all vacuum lines visually multiple times and used carb spray. I'm starting to think I it may be a LIM leak and I tucked up when replacing the gaskets and installing my ported LIM.


Update:

I re did the LIM Gaskets and let everything set the last 2-3 ours and its still doing the same thing smh. Even swapped the maf sensor with a spare.

Once again, im getting no dtc codes.

_________________
L67 Engine Swapped w/ 2005 Impala SS
Mods: 3.0 MPS | Gen V | N* TB | LQ4 MAF | 130# Springs | XP Cam | |Stage 3 Ported Heads| Roller Master Double Timing Set | CAI | PRJ Wires | AL104 | Speed Daddy Headers | EGR Delete | ZZP Stage 2 Intercooler | 42lb Injectors |
13.4 @ 106


http://www.cardomain.com/ride/3183434
Back to top
View user's profile Send private message
nightryder
Master Level
Master Level
Silver Contributor (Amount: 1) Silver Contributor


Joined: Oct 18, 2006
Posts: 3256
Posts per day: 0.82
Location: Lockport NY

2001 Chevrolet Impala
2005 Subaru Impreza


PostPosted: Fri Sep 23, 2011 5:21 pm    Post subject:   Reply with quote

What ported LIM? Why are you not running your IC core? What s/c gasket are you using?

Are you running a BCS?

I still think you have a vacuum leak somewhere.

_________________
Back to top
View user's profile Send private message AIM Address
GOTIT4CHEAP16
Senior Level
Senior Level


Joined: Sep 12, 2008
Posts: 2681
Posts per day: 0.81
Location: Bowie, MD

2000 Chevrolet Impala


PostPosted: Fri Sep 23, 2011 6:24 pm    Post subject:   Reply with quote

Its a zzp ported lim that came with my stage 2 intercooler. Took the i/c core out after i couldnt seal everything when i installed it before even when i used stock gaskets.

Whats a BCS?

_________________
L67 Engine Swapped w/ 2005 Impala SS
Mods: 3.0 MPS | Gen V | N* TB | LQ4 MAF | 130# Springs | XP Cam | |Stage 3 Ported Heads| Roller Master Double Timing Set | CAI | PRJ Wires | AL104 | Speed Daddy Headers | EGR Delete | ZZP Stage 2 Intercooler | 42lb Injectors |
13.4 @ 106


http://www.cardomain.com/ride/3183434
Back to top
View user's profile Send private message
nightryder
Master Level
Master Level
Silver Contributor (Amount: 1) Silver Contributor


Joined: Oct 18, 2006
Posts: 3256
Posts per day: 0.82
Location: Lockport NY

2001 Chevrolet Impala
2005 Subaru Impreza


PostPosted: Fri Sep 23, 2011 6:33 pm    Post subject:   Reply with quote

Boost control solenoid

Is the LIM the standard or revised version?

Use garlock gaskets with grey RTV and let it sit for at least 24 hours before starting it.

_________________
Back to top
View user's profile Send private message AIM Address
GOTIT4CHEAP16
Senior Level
Senior Level


Joined: Sep 12, 2008
Posts: 2681
Posts per day: 0.81
Location: Bowie, MD

2000 Chevrolet Impala


PostPosted: Fri Sep 23, 2011 8:22 pm    Post subject:   Reply with quote

Yes my BCS is plugged in and the intake manifold is a revised version w/ PCV. I wanna keep the core off for a while untill next spring and fix my current issue. Im using a stock gasket right now without the core on

_________________
L67 Engine Swapped w/ 2005 Impala SS
Mods: 3.0 MPS | Gen V | N* TB | LQ4 MAF | 130# Springs | XP Cam | |Stage 3 Ported Heads| Roller Master Double Timing Set | CAI | PRJ Wires | AL104 | Speed Daddy Headers | EGR Delete | ZZP Stage 2 Intercooler | 42lb Injectors |
13.4 @ 106


http://www.cardomain.com/ride/3183434
Back to top
View user's profile Send private message
whitelightnin04MC
Uberd0rk!
Uberd0rk!
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Nov 05, 2006
Posts: 6364
Posts per day: 1.6
Location: I got big balls and dey jangle like a lotta keys.

2004 Chevrolet Monte Carlo
2001 Chevrolet Monte Carlo
2009 Subaru Impreza


PostPosted: Fri Sep 23, 2011 9:54 pm    Post subject:   Reply with quote

nightryder wrote:
Boost control solenoid

Is the LIM the standard or revised version?

Use garlock gaskets with grey RTV and let it sit for at least 24 hours before starting it.


Yeah, garlock or make your own out of silicone baking sheet. We use garlock at work sometimes. It's better than most of the CGP community likes to make you think.

_________________
Proud Helldorado Nut Hugger

Resident Prick, at your service.
SS - Corsa Catback, RT 3" DP, CC T304 PLOG, Wizaired, ZZP Offset Polys, GMPP Koni Kit, Hella Projectrofits, PT, ZZP HVTB, 10.4's
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 Engine, Exhaust and Transmission All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: September 19, 2017, 3:46:17 pm
Page Generation: 0.12 Seconds ( SQL 43:137 in 0.01 Seconds )