NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - Need some serious help for my '04 LS with 3.8 L
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Need some serious help for my '04 LS with 3.8 L

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 Engine, Exhaust and Transmission
View previous topic :: View next topic  
Author Message
starskgrrl
Newbie
Newbie


Joined: Sep 15, 2011
Posts: 3
Posts per day: 0
Location: Calgary, Alberta

2004 Chevrolet Impala


PostPosted: Fri Sep 16, 2011 10:06 pm    Post subject:  Need some serious help for my '04 LS with 3.8 L Reply with quote

First post and it's a doozy. I'm praying someone out there can help, and fast. My '04 Impala LS has developed an idling problem - when started, unless I can keep the rev's over 2 K, it chokes and dies. I also noticed two days ago that I had that horrendous infamous DexCool issue with it leaking all over the top side of the motor, so today thanks to all the information I read here, we replaced the UIM, the LIM, the IAC, the thermostat, ran all the DexCool out of it, and now...it still will not idle on its own without putting my foot darn near through the floorboards to keep it running. What could we have missed today? Any and all suggestions would be most gratefully accepted. HELP! LOL

EDIT: Status update: We removed the MAF with security torx, sprayed it with MAF cleaner, and VOILA!, I have my Imp back on the road running like a big dog once again. Thanks to all of you for your assistance, and thank goodness for this forum - you saved my car!


Last edited by starskgrrl on Sun Sep 18, 2011 3:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
chibiblacksheep
Member Level
Member Level


Joined: Dec 14, 2009
Posts: 1369
Posts per day: 0.47
Location: Philadelphia, PA

2000 Chevrolet Monte Carlo
2007 Chevrolet Impala
1968 Chevrolet Camaro
2013 Chevrolet Camaro


PostPosted: Fri Sep 16, 2011 10:08 pm    Post subject:   Reply with quote

Try the Mass Air Flow next.

_________________
Back to top
View user's profile Send private message Send e-mail AIM Address
starskgrrl
Newbie
Newbie


Joined: Sep 15, 2011
Posts: 3
Posts per day: 0
Location: Calgary, Alberta

2004 Chevrolet Impala


PostPosted: Fri Sep 16, 2011 10:10 pm    Post subject:  MAF or the TPS? Reply with quote

chibiblacksheep wrote:
Try the Mass Air Flow next.


Sorry - I'm a mechanical dolt - friends have spent the entire day today doing all these gasket, etc., replacements. Could you explain what the MAF should be doing and if it's not working properly, what the symptoms are? Thank you so much for answering so quickly!
Back to top
View user's profile Send private message
habermehl
Member Level
Member Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Jul 29, 2010
Posts: 1374
Posts per day: 0.51
Location: Ontario

2001 Chevrolet Impala
2007 Chevrolet Impala


PostPosted: Fri Sep 16, 2011 11:15 pm    Post subject:   Reply with quote

http://en.wikipedia.org/wiki/Mass_flow_sensor

try cleaning it first or running the car with it un plugged (not for a long time) and see if it makes a difference. people clean all the build up on it with MAF cleaner.

_________________
bbengineer wrote:
And yes, I spend a lot of time deleting useless posts... many of which are yours
BBEngineer


billy101 wrote:
Conner wrote:
how do the dealer's expect us to get the cars there if they don 't run at all?


Tow Truck?
Back to top
View user's profile Send private message Send e-mail
starskgrrl
Newbie
Newbie


Joined: Sep 15, 2011
Posts: 3
Posts per day: 0
Location: Calgary, Alberta

2004 Chevrolet Impala


PostPosted: Sat Sep 17, 2011 12:50 am    Post subject:  Thanks! Reply with quote

habermehl wrote:
http://en.wikipedia.org/wiki/Mass_flow_sensor

try cleaning it first or running the car with it un plugged (not for a long time) and see if it makes a difference. people clean all the build up on it with MAF cleaner.


We are certainly going to give that a try first thing tomorrow morning - and I can't thank you both enough for all your help tonight. I'm praying that this solves the issue. If not, I'll certainly be back to learn from your expertise some more. Thank you both again for all your assistance!
Back to top
View user's profile Send private message
Lingenfelter
Uberd0rk!
Uberd0rk!
Gold Contributor (Amount: 1) Gold Contributor


Joined: Oct 21, 2006
Posts: 9331
Posts per day: 2.31
Location: Ontario, Canada

2003 Chevrolet Impala
1999 Yugo Tempo


PostPosted: Sat Sep 17, 2011 10:23 am    Post subject:   Reply with quote

Check or replace your engine air filter

Clean your throttle body inside

Maybe take a look at the EGR valve if all else fails.

I don't know if a plugged catalytic converter will cause these symptoms or not, but a backpressure test will tell you if the cat is any good or not.

_________________
uıɐƃɐ ʎɐqǝ ɯoɹɟ pɹɐoqʎǝʞ ɐ ƃuıʎnq ɹǝʌǝu ɯɐ ı

GMPP Duals, GMPP Handling Kit, NAIOA FWI V2, Silverstar Hi/Lo/Fogs, Viper 5900 Remote Start/Security.
Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
impalafirst
Dedicated
Dedicated


Joined: Apr 14, 2007
Posts: 378
Posts per day: 0.1
Location: Baltimore

2014 Chevrolet Malibu


PostPosted: Sat Sep 17, 2011 6:14 pm    Post subject:   Reply with quote

My bet is on the MAF.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 Engine, Exhaust and Transmission All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: November 17, 2017, 3:17:47 pm
Page Generation: 0.10 Seconds ( SQL 29:116 in 0.01 Seconds )