NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - "Low Coolant Level"
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

"Low Coolant Level"

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 Engine, Exhaust and Transmission
View previous topic :: View next topic  
Author Message
kpraytor
Newbie
Newbie


Joined: Aug 17, 2011
Posts: 13
Posts per day: 0.01


2001 Chevrolet Impala


PostPosted: Tue Sep 13, 2011 7:51 am    Post subject: Question "Low Coolant Level" Reply with quote

Good morning everyone! Long time reader, first time thread starter Very Happy

I flushed out my radiator 2 weeks ago due to all the sludge buildup from the Dexcool. I followed all the procedures listed on the Prestone flush.

I topped off my coolant last week. Now, I went to check to see if I needed anymore coolant; I did not need any (I could see the coolant level in the radiator. Clearly, my coolant level appears full in my radiator but my car keeps telling me "Low Coolant Level"

Is there a sensor that needs to be reset?

Do I need to add more coolant somewhere else?

Will it eventually stop saying that and just go away on its own?

Am I truly low on coolant?

Thanks everyone for the responses!
Back to top
View user's profile Send private message
chibiblacksheep
Member Level
Member Level


Joined: Dec 14, 2009
Posts: 1369
Posts per day: 0.47
Location: Philadelphia, PA

2000 Chevrolet Monte Carlo
2007 Chevrolet Impala
1968 Chevrolet Camaro
2013 Chevrolet Camaro


PostPosted: Tue Sep 13, 2011 7:54 am    Post subject:   Reply with quote

Near the battery, there's a sensor in the radiator. You can just unplug it and not worry about it ever again and just check your level manually. Or you can replace it.

_________________
Back to top
View user's profile Send private message Send e-mail AIM Address
kpraytor
Newbie
Newbie


Joined: Aug 17, 2011
Posts: 13
Posts per day: 0.01


2001 Chevrolet Impala


PostPosted: Tue Sep 13, 2011 8:01 am    Post subject:   Reply with quote

chibiblacksheep wrote:
Near the battery, there's a sensor in the radiator. You can just unplug it and not worry about it ever again and just check your level manually. Or you can replace it.


Is there any way to determine whether the sensor is broken or if I somehow truly have a low coolant level.

I'm just not into spending needless money if something else can be done to determine the true problem.
Back to top
View user's profile Send private message
chibiblacksheep
Member Level
Member Level


Joined: Dec 14, 2009
Posts: 1369
Posts per day: 0.47
Location: Philadelphia, PA

2000 Chevrolet Monte Carlo
2007 Chevrolet Impala
1968 Chevrolet Camaro
2013 Chevrolet Camaro


PostPosted: Tue Sep 13, 2011 9:03 am    Post subject:   Reply with quote

You said yourself you don't have low coolant. The sensor probably is dirty, you could always pop it out and clean it too. Often times the sludge gets on them and ruins them too.

_________________
Back to top
View user's profile Send private message Send e-mail AIM Address
topgun
Resident
Resident


Joined: May 19, 2011
Posts: 639
Posts per day: 0.27
Location: Upstate N Y

2005 Chevrolet Impala


PostPosted: Tue Sep 13, 2011 5:09 pm    Post subject:   Reply with quote

Hey kpraytor, I'm doing a flush soon.
What did you do to flush?
What did you refill with. Thanks. Cool

_________________
Untamed . . . and don't try to change me
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 Engine, Exhaust and Transmission All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: November 19, 2017, 10:04:29 am
Page Generation: 0.09 Seconds ( SQL 25:111 in 0.00 Seconds )