NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - blown horn fuse #4???
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

blown horn fuse #4???

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car!
View previous topic :: View next topic  
Author Message
Forgotten
Resident
Resident


Joined: Jun 08, 2005
Posts: 507
Posts per day: 0.11
Location: Chicago South Subrubs

2006 Dodge Charger


PostPosted: Tue Sep 06, 2011 7:21 pm    Post subject: Question blown horn fuse #4??? Reply with quote

i have changed the fuse for my horn 4 times already and each time i use the horn it keeps blowing. what could be the cause of this? the horns are wired good, no wires are touching each other.

_________________

http://www.photobucket.com/355camaro
78 Camaro Progress Album
Back to top
View user's profile Send private message Send e-mail AIM Address
bbengineer
NAIOA Owner / Webmaster
NAIOA Administrator
NAIOA Administrator


Joined: Jun 01, 2005
Posts: 9496
Posts per day: 2.11
Location: NJ

2004 Chevrolet Impala
1998 Chevrolet Corvette
2007 Chevrolet Tahoe
2008 Subaru Impreza
1970 Chevrolet Chevelle


PostPosted: Tue Sep 06, 2011 7:39 pm    Post subject:   Reply with quote

One of the 2 horns is probably internally shorted. Unplug one at a time and press the horn and see which one causes the fuse to blow

BBEngineer

_________________

Decisions...Decisions...
Back to top
View user's profile Send private message Visit poster's website
bigdog60
Resident
Resident
Gold Contributor (Amount: 1) Gold Contributor


Joined: Jan 27, 2009
Posts: 793
Posts per day: 0.25


2005 Chevrolet Impala


PostPosted: Tue Sep 06, 2011 9:33 pm    Post subject:   Reply with quote

Just to add they are known to short out because of water getting in to them. I took mine off, turned them upside down and shook the water out of them.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car! All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: September 23, 2017, 11:22:03 am
Page Generation: 0.08 Seconds ( SQL 21:106 in 0.00 Seconds )