NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - Water Pump Installed
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Water Pump Installed

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car!
View previous topic :: View next topic  
Author Message
impalafirst
Dedicated
Dedicated


Joined: Apr 14, 2007
Posts: 378
Posts per day: 0.1
Location: Baltimore

2014 Chevrolet Malibu


PostPosted: Sun Sep 04, 2011 3:31 pm    Post subject:  Water Pump Installed Reply with quote

I just finished installing a new water pump this morning because I am at 93,000 miles. GM why did you put one water pump bolt behing the power steering pulley?? Why not put 4 of the 8 behind it and not 1? Took me in total 41/2 hrs. 1hr spent trying to line up power steering bolts to put it back on, another 1 hr making sure all the old gasket was off. Did the thermostat while I was at it because it was stuck shut and it is not even a year old (Stant). Next is the UIM, it has a slight leak near the throttle body. I saw a video some time ago on it. Anyone recall that video?
Back to top
View user's profile Send private message
MISHNAH
Master Level
Master Level


Joined: Mar 08, 2004
Posts: 3158
Posts per day: 0.63
Location: Baton Rouge, LA/Houston, TX GEAUX TIGERS!!!

2002 Chevrolet Impala
2006 Mercedes-Benz E Class
2006 Nissan Murano
2003 BMW 5 Series


PostPosted: Wed Sep 07, 2011 2:11 pm    Post subject:  Re: Water Pump Installed Reply with quote

impalafirst wrote:
I just finished installing a new water pump this morning because I am at 93,000 miles. GM why did you put one water pump bolt behing the power steering pulley?? Why not put 4 of the 8 behind it and not 1? Took me in total 41/2 hrs. 1hr spent trying to line up power steering bolts to put it back on, another 1 hr making sure all the old gasket was off. Did the thermostat while I was at it because it was stuck shut and it is not even a year old (Stant). Next is the UIM, it has a slight leak near the throttle body. I saw a video some time ago on it. Anyone recall that video?


Was something wrong with the pump? I hope you didnt replace it just because of the mileage, they can last the life of the car many times.

I love how all the accessories are super-easy to reach on the 3400, unfortunately its also the crappiest engine in the Impala. Laughing

_________________
2002 Galaxy Silver Sedan - LS cluster - Debadged - Intrigue compass/autodim mirror - DIC - Regal graphite leather seats - LS console with floor shift conversion - Monte Carlo black leather steering wheel - LS springs - KYB GR-2 Struts - GMPP sway bars and rear STB - Fog light frontend harness - LS Bumper with fog lights - Painted trim and side skirts

2006 Nissan Murano - Autodim/compass mirror
2006 Mercedez-Benz E350 - Stock for stock, its faster than an SS, woot!
Back to top
View user's profile Send private message Send e-mail AIM Address Yahoo Messenger
GOTIT4CHEAP16
Senior Level
Senior Level


Joined: Sep 12, 2008
Posts: 2681
Posts per day: 0.8
Location: Bowie, MD

2000 Chevrolet Impala


PostPosted: Wed Sep 07, 2011 3:18 pm    Post subject:   Reply with quote

Next time remmeber that the psp bolts are at 12 and 6 o clockand youll be good.

_________________
L67 Engine Swapped w/ 2005 Impala SS
Mods: 3.0 MPS | Gen V | N* TB | LQ4 MAF | 130# Springs | XP Cam | |Stage 3 Ported Heads| Roller Master Double Timing Set | CAI | PRJ Wires | AL104 | Speed Daddy Headers | EGR Delete | ZZP Stage 2 Intercooler | 42lb Injectors |
13.4 @ 106


http://www.cardomain.com/ride/3183434
Back to top
View user's profile Send private message
impalafirst
Dedicated
Dedicated


Joined: Apr 14, 2007
Posts: 378
Posts per day: 0.1
Location: Baltimore

2014 Chevrolet Malibu


PostPosted: Wed Sep 07, 2011 4:15 pm    Post subject:   Reply with quote

I changed the pump due to mileage and it was in pristine condition. My bad. I still have it in my trunk.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car! All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: November 19, 2017, 9:49:02 pm
Page Generation: 0.12 Seconds ( SQL 23:106 in 0.01 Seconds )