NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - Coolant leaking bad need help
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Coolant leaking bad need help

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car!
View previous topic :: View next topic  
Author Message
kp_432
Forum Regular
Forum Regular


Joined: Apr 15, 2007
Posts: 121
Posts per day: 0.03
Location: $$TEXAS$$

2003 Chevrolet Impala
2004 Chevrolet Impala


PostPosted: Sat Jul 30, 2011 1:30 pm    Post subject:  Coolant leaking bad need help Reply with quote

Been searching on the internet I dont know the name of this plastic elbow that is cracked and will not let the engine hold any coolant AT ALL. Could it be the Evaporator Drain Tube? I need fix a.s.a.p. and will need with best ways with tear down please. 2004 SS 3.8 SC
thanks
kp_432



Uploaded with ImageShack.us
Back to top
View user's profile Send private message
chibiblacksheep
Member Level
Member Level


Joined: Dec 14, 2009
Posts: 1369
Posts per day: 0.47
Location: Philadelphia, PA

2000 Chevrolet Monte Carlo
2007 Chevrolet Impala
1968 Chevrolet Camaro
2013 Chevrolet Camaro


PostPosted: Sat Jul 30, 2011 2:25 pm    Post subject:   Reply with quote

Just a basic coolant elbow? Those break all the time.

Go to the self-help section of a pep-boys or other auto parts store and you'll see them, they come in a pack of 2.

I actually keep a spare in my trunk lol.

_________________
Back to top
View user's profile Send private message Send e-mail AIM Address
chevykid24
Cadet
Cadet
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Apr 09, 2010
Posts: 80
Posts per day: 0.03
Location: Mesa, Az

2004 Chevrolet Impala


PostPosted: Sat Jul 30, 2011 7:59 pm    Post subject:   Reply with quote

It's called the Thermostat Bypass Pipe and you might as well replace both of them. There is an upper and lower pipe right next to each other. Its pretty easy to replace.

Steps to replace them:
1. Disconnect battery
2. Drain the coolant
3. Remove the coolant resivor. You don't have to but its easier
4. Remove the belt
5. Unbolt alternator
6. Unbolt the tensioner pully
7. Replace pipes

Then vice versa. Pretty simple. After you fill the radiator back up with coolant run the car and open the bleeder on top of the thermostat housing till a little bit of coolant comes out. You want to try to get the air out of the coolant. Then you should be set.

_________________
Back to top
View user's profile Send private message Send e-mail
Jayme
Dedicated
Dedicated


Joined: Jan 15, 2007
Posts: 379
Posts per day: 0.1
Location: West Chicago, IL

2000 Chevrolet Impala


PostPosted: Sat Jul 30, 2011 9:46 pm    Post subject:   Reply with quote

Here's a writeup:http://www.naioa.com/v2/module.....mp;t=17376

It's not hard.

_________________


Start them out right...
Back to top
View user's profile Send private message
DennisW
Forum Regular
Forum Regular


Joined: Nov 30, 2010
Posts: 205
Posts per day: 0.08


2004 Chevrolet Impala


PostPosted: Sun Jul 31, 2011 12:08 am    Post subject:   Reply with quote

Jayme wrote:
Here's a writeup:http://www.naioa.com/v2/module.....mp;t=17376

It's not hard.


"....ERROR: 404 - Page Not Found,,,," oops! Shocked
Back to top
View user's profile Send private message
kp_432
Forum Regular
Forum Regular


Joined: Apr 15, 2007
Posts: 121
Posts per day: 0.03
Location: $$TEXAS$$

2003 Chevrolet Impala
2004 Chevrolet Impala


PostPosted: Sun Jul 31, 2011 11:23 am    Post subject:   Reply with quote

Jayme wrote:
Here's a writeup:http://www.naioa.com/v2/module.....mp;t=17376

It's not hard.



Yes these are the instruction I went off of. Really do thank everybody,couldn't find anything about those elbows in my Haynes Manuel and this website came threw yet once again.
Thanks again
kp_432
Back to top
View user's profile Send private message
Jayme
Dedicated
Dedicated


Joined: Jan 15, 2007
Posts: 379
Posts per day: 0.1
Location: West Chicago, IL

2000 Chevrolet Impala


PostPosted: Sat Aug 06, 2011 9:46 pm    Post subject:   Reply with quote

http://www.naioa.com/v2/module.....mp;t=17376

Not sure why the other link didn't work.

_________________


Start them out right...
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> Problems with my car! All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: November 23, 2017, 11:40:49 pm
Page Generation: 0.11 Seconds ( SQL 29:115 in 0.01 Seconds )