NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - Problems With 2001 Impala 3.4
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Problems With 2001 Impala 3.4

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion
View previous topic :: View next topic  
Author Message
cmpdesignz
Newbie
Newbie


Joined: Oct 05, 2009
Posts: 19
Posts per day: 0.01


2001 Chevrolet Impala


PostPosted: Sat Apr 09, 2011 7:41 pm    Post subject:  Problems With 2001 Impala 3.4 Reply with quote

I have no turn signals or horn and the car is over heating. None of the interior fuses or blown and all the small under hood fuses are fine as well.

Where else can I start to trouble shoot and what do I look for?
Back to top
View user's profile Send private message
Rakshatiz
Forum Regular
Forum Regular


Joined: Feb 14, 2011
Posts: 177
Posts per day: 0.07
Location: North Olmsted,OH

2001 Chevrolet Impala
1986 Pontiac Solstice


PostPosted: Sat Apr 09, 2011 9:42 pm    Post subject:   Reply with quote

No turn signals could be related to the hazard light switch. All your turn signals run through that switch. Idk on the over heating, could be head gasket?

_________________
IffyG wrote:
I want to punch myself in the taint for saying this

nightryder wrote:
My oversized radiator has a nice c**k though, nice and smooth operation.

BlackVenom wrote:
You gotta be really careful with this stuff as it's a pretty big deal and serious business. I can't imagine what would happen if i miss applied that stuff.... itd be like feeding a dog chocolate, putting a tinfoil hat on it and throwing it in the microwave for 60s.....
Back to top
View user's profile Send private message
cmpdesignz
Newbie
Newbie


Joined: Oct 05, 2009
Posts: 19
Posts per day: 0.01


2001 Chevrolet Impala


PostPosted: Sat Apr 09, 2011 10:44 pm    Post subject:   Reply with quote

Rakshatiz wrote:
No turn signals could be related to the hazard light switch. All your turn signals run through that switch. Idk on the over heating, could be head gasket?


The hazards work when turned on. All four turn signals flash. The over heating is occurs when at a light or in stop and go traffic. When in motion or at highway speed, the temp returns to normal.

And there is still the horn issue.
Back to top
View user's profile Send private message
buzzstpoint
Dedicated
Dedicated


Joined: Oct 20, 2008
Posts: 306
Posts per day: 0.09
Location: Stevens Point WI

2000 Chevrolet Impala
1995 Chevrolet Silverado
2000 Saturn L-Series


PostPosted: Sat Apr 09, 2011 10:54 pm    Post subject:   Reply with quote

Next to the thermostat housing, there's a bleeder screw. When it's overheating open this bleeder screw and bleed the air out. If the air returns, I would suspect a bad head gasket as well. This what happened on my 3.4L

_________________
A well regulated Militia, being necessary to the security of a free State, the right of the people to keep and bear Arms, shall not be infringed.
Back to top
View user's profile Send private message Visit poster's website
Jayme
Dedicated
Dedicated


Joined: Jan 15, 2007
Posts: 379
Posts per day: 0.1
Location: West Chicago, IL

2000 Chevrolet Impala


PostPosted: Sat Apr 09, 2011 11:20 pm    Post subject:   Reply with quote

The hazard light switch can still be bad even if all the hazards work. The part that makes the turn signals flash is built into the switch and can be bad by itself.
You may also have a multifunction switch bad.

When the car overheats, do both the fans come on?

_________________


Start them out right...
Back to top
View user's profile Send private message
cmpdesignz
Newbie
Newbie


Joined: Oct 05, 2009
Posts: 19
Posts per day: 0.01


2001 Chevrolet Impala


PostPosted: Sat Apr 09, 2011 11:21 pm    Post subject:   Reply with quote

Jayme wrote:
The hazard light switch can still be bad even if all the hazards work. The part that makes the turn signals flash is built into the switch and can be bad by itself.
You may also have a multifunction switch bad.

When the car overheats, do both the fans come on?


Honestly I don't hear any fans, which is leading to think this is all electrical.
Back to top
View user's profile Send private message
buzzstpoint
Dedicated
Dedicated


Joined: Oct 20, 2008
Posts: 306
Posts per day: 0.09
Location: Stevens Point WI

2000 Chevrolet Impala
1995 Chevrolet Silverado
2000 Saturn L-Series


PostPosted: Sat Apr 09, 2011 11:38 pm    Post subject:   Reply with quote

I believe if you turn your AC on the fans should kick on.
If your fans arent turning on, I would check the fan relays.

_________________
A well regulated Militia, being necessary to the security of a free State, the right of the people to keep and bear Arms, shall not be infringed.
Back to top
View user's profile Send private message Visit poster's website
BlackVenom
Member Level
Member Level


Joined: Aug 15, 2009
Posts: 1597
Posts per day: 0.55
Location: Muncie, IN

2003 Chevrolet Impala


PostPosted: Sun Apr 10, 2011 4:47 pm    Post subject:   Reply with quote

Did this all hit at once?

Do your gauges light up and all? Do your wipers work? Check if one of the fans is spinning by having someone turn on your car while you watch. And as per usual check your reservoirs and for leaks under the car.

_________________
Shoobidoobop!
Back to top
View user's profile Send private message
04ImpalaSS
Newbie
Newbie


Joined: Oct 07, 2008
Posts: 47
Posts per day: 0.01


2004 Chevrolet Impala


PostPosted: Wed Apr 13, 2011 8:56 pm    Post subject:   Reply with quote

I was just actually about to come and check for the same thing. Today my car got up to 210 degrees and the fans didnt kick on at 185 like their suppose too. I have an aeroforce scan gauge and I got a P0418 and P1819 code and the gauge wont let me turn the fans on either. It said something about fan controller #2 but when I tried swapping the relays it still didnt work..Do all 3 relays need to work or should they still work if only 1 of them were bad. Now I dont know whats going on and I couldnt drive my car home
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: August 23, 2017, 8:37:17 am
Page Generation: 0.11 Seconds ( SQL 33:118 in 0.01 Seconds )