NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - Short In Sunroof Switch?
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Short In Sunroof Switch?

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion
View previous topic :: View next topic  
Author Message
Bundy
Cadet
Cadet


Joined: Sep 14, 2008
Posts: 56
Posts per day: 0.02
Location: Ontario

2004 Chevrolet Impala


PostPosted: Sun Apr 03, 2011 1:29 pm    Post subject:  Short In Sunroof Switch? Reply with quote

Using my overhead sunroof switch on my 2004 Impala LS it has started to work intermittently. It will partially open and then I can keep flicking the switch back until it opens all the way.

To close it is a real pain. I push the switch forward and it moves the sunroof a tiny amount and stops. I have to keep repeating this process many times before it will finally reach the closed position.

At this point I have it closed and am afraid to open it again for fear of not being able to close it at all.

Has anyone else had this problem? If so, what could it be? Faulty switch? Loose connection? All of the above? Smile

Any thoughts would be appreciated. Summer is approaching again and I'd love to be able to open the top.

Thanks
Back to top
View user's profile Send private message
Specter
Member Level
Member Level


Joined: Aug 30, 2008
Posts: 1586
Posts per day: 0.48
Location: Bealeton, Virginia

2004 Chevrolet Impala


PostPosted: Sun Apr 03, 2011 1:54 pm    Post subject:   Reply with quote

Lubing the track always seems to do the trick for me.

_________________
Quote:
You're not smart. You're not a doctor. You're not even a full-time employee. Where did your life go so wrong?
Back to top
View user's profile Send private message MSN Messenger
Bundy
Cadet
Cadet


Joined: Sep 14, 2008
Posts: 56
Posts per day: 0.02
Location: Ontario

2004 Chevrolet Impala


PostPosted: Sun Apr 03, 2011 2:13 pm    Post subject:   Reply with quote

Hmmm, I don't thank that's it but thanks for the suggestion.

Even when I hold the switch it will stop working which to me sounds like a short of some kind. Not sure how much it would cost to fix or if I could fix it myself.
Back to top
View user's profile Send private message
Specter
Member Level
Member Level


Joined: Aug 30, 2008
Posts: 1586
Posts per day: 0.48
Location: Bealeton, Virginia

2004 Chevrolet Impala


PostPosted: Sun Apr 03, 2011 3:08 pm    Post subject:   Reply with quote

Yeah, that's what happens to me all the time.
Last time I had the sunroof open all the way, it took about 10 minutes to close.

But I lubed it and it worked fine. Haven't had any problems so far.

_________________
Quote:
You're not smart. You're not a doctor. You're not even a full-time employee. Where did your life go so wrong?
Back to top
View user's profile Send private message MSN Messenger
Bundy
Cadet
Cadet


Joined: Sep 14, 2008
Posts: 56
Posts per day: 0.02
Location: Ontario

2004 Chevrolet Impala


PostPosted: Sun Apr 03, 2011 3:26 pm    Post subject:   Reply with quote

Wow...I honestly never thought that could be the cause. I'll have to give it a try. What kind of lube do you suggest?

Thanks for the input.
Back to top
View user's profile Send private message
spacewalker404
Resident
Resident
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Jan 25, 2007
Posts: 579
Posts per day: 0.15
Location: Not of this world

2004 Chevrolet Impala
2000 Chevrolet S10


PostPosted: Sun Apr 03, 2011 3:53 pm    Post subject:   Reply with quote

I had the same problem. http://www.naioa.com/v2/module.....p;p=433983

Take apart the sunroof switch and check for loose/ dirty connections. Then reassemble. I have not had a problem, since I did it, after I tore everything apart and found nothing to be wrong.

_________________
Back to top
View user's profile Send private message
Bundy
Cadet
Cadet


Joined: Sep 14, 2008
Posts: 56
Posts per day: 0.02
Location: Ontario

2004 Chevrolet Impala


PostPosted: Sun Apr 17, 2011 10:48 am    Post subject:   Reply with quote

Just wanted to update and say thanks.

I cleaned out the tracks which were quite gunky with grease and debris. I sprayed the track with lube and now she's moving like new.

Appreciate the assistance.
Back to top
View user's profile Send private message
BlackVenom
Member Level
Member Level


Joined: Aug 15, 2009
Posts: 1597
Posts per day: 0.55
Location: Muncie, IN

2003 Chevrolet Impala


PostPosted: Sun Apr 17, 2011 10:57 pm    Post subject:   Reply with quote

Meh, i relubed twice and still have this problem. needa take the switch apart.

_________________
Shoobidoobop!
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: August 18, 2017, 7:28:12 am
Page Generation: 0.12 Seconds ( SQL 31:113 in 0.01 Seconds )