NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - 05 blower motor.
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

05 blower motor.

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion
View previous topic :: View next topic  
Author Message
charlie45
Newbie
Newbie


Joined: Mar 26, 2011
Posts: 2
Posts per day: 0
Location: salem ohio

2005 Chevrolet Impala


PostPosted: Sat Mar 26, 2011 1:42 pm    Post subject:  05 blower motor. Reply with quote

hello this is my first time here. i have a 2005 impala that the blower motor runs
always key no key. but only on high, cant find a relay just fuses. changed resistor nothing trying dash controll today if this is not it would anyone else have any ideas, thanks charlie
Back to top
View user's profile Send private message
GOTIT4CHEAP16
Senior Level
Senior Level


Joined: Sep 12, 2008
Posts: 2681
Posts per day: 0.81
Location: Bowie, MD

2000 Chevrolet Impala


PostPosted: Sat Mar 26, 2011 2:15 pm    Post subject:   Reply with quote

hUH?? ???

_________________
L67 Engine Swapped w/ 2005 Impala SS
Mods: 3.0 MPS | Gen V | N* TB | LQ4 MAF | 130# Springs | XP Cam | |Stage 3 Ported Heads| Roller Master Double Timing Set | CAI | PRJ Wires | AL104 | Speed Daddy Headers | EGR Delete | ZZP Stage 2 Intercooler | 42lb Injectors |
13.4 @ 106


http://www.cardomain.com/ride/3183434
Back to top
View user's profile Send private message
05imp
Senior Level
Senior Level


Joined: Jan 01, 2006
Posts: 2302
Posts per day: 0.53
Location: Cleveland, OH

2005 Chevrolet Impala
2000 Ford Ranger
2007 Ford Explorer
2008 Chevrolet Silverado


PostPosted: Sun Mar 27, 2011 8:17 am    Post subject:   Reply with quote

If am reading this right you are saying that the blower just keeps running with the key off ect.. correct?
I had this happen myself and it was the blower control module (05 impalas don't have blower motor resisters Wink )

Its this thing and its right by the blower motor


But for the time being you can pull the big fuse for the blower from the fuse box under the hood so you can get around without it running the batt down.

Back to top
View user's profile Send private message
grimsin
Member Level
Member Level


Joined: Oct 27, 2009
Posts: 1179
Posts per day: 0.4
Location: Port Stanley ON

2005 Chevrolet Impala


PostPosted: Sun Mar 27, 2011 9:48 am    Post subject:   Reply with quote

LMAO when i went to go buy my impala 1.8 years ago, drove it, tested and loved it,went back to say its sold!, shut off the car and blower moto stays on high with key out and everything turned off even the dealer was Shocked lol!
never found out what it was. he had to fix it for safety.car hasnt done it since.
Back to top
View user's profile Send private message
charlie45
Newbie
Newbie


Joined: Mar 26, 2011
Posts: 2
Posts per day: 0
Location: salem ohio

2005 Chevrolet Impala


PostPosted: Sun Mar 27, 2011 11:28 am    Post subject:   Reply with quote

thanks for the replies. i changed the control mod but did not change. but i could have had a bad mod.
Back to top
View user's profile Send private message
EricJ
Resident
Resident


Joined: Sep 23, 2009
Posts: 694
Posts per day: 0.24
Location: Geneva, O.

2003 Chevrolet Impala
2007 Ford Taurus


PostPosted: Wed Apr 13, 2011 9:02 pm    Post subject:   Reply with quote

05imp wrote:
If am reading this right you are saying that the blower just keeps running with the key off ect.. correct?
I had this happen myself and it was the blower control module (05 impalas don't have blower motor resisters Wink )

Its this thing and its right by the blower motor


But for the time being you can pull the big fuse for the blower from the fuse box under the hood so you can get around without it running the batt down.

Thanks for telling where and that there is a fuse under the hood for the blower motor. We don't have ANY fan speed at all; I replaced the resistor last fall.

_________________
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: October 22, 2017, 7:23:23 pm
Page Generation: 0.10 Seconds ( SQL 27:111 in 0.01 Seconds )