NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - 2004 Blower Motor Electrical Issues?!?!
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

2004 Blower Motor Electrical Issues?!?!

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion
View previous topic :: View next topic  
Author Message
cableguy
Newbie
Newbie


Joined: Nov 17, 2010
Posts: 4
Posts per day: 0


2004 Chevrolet Impala


PostPosted: Thu Nov 18, 2010 12:23 am    Post subject: Question 2004 Blower Motor Electrical Issues?!?! Reply with quote

Hi All... thanks in advance for your help with this.

I have a 2004 Impala.... overall, love it. Lately though, the battery has been draining (it's basically a new battery) to the point that the car is completely dead. I checked the alternator... all seems to be fine there.... the battery checks out once I use a battery charger to bring it back up to speed.

I then hooked a multimeter up to it in series while it was off to see if there was any parasitic battery drainage... there WAS.... it showed almost 1.2 amps of discharge. I went to pulling fuses, and the amperage went to about 10 milliamps (good) once the 30 amp fuse for the blower motor was pulled.

Does anyone have an idea as to what might be happening here? What on that circuit would be pulling 1ish amps while the car is turned OFF?

Any help would be great.... thanks for your expertise.

Peace,
cableguy Very Happy
Back to top
View user's profile Send private message
bbengineer
NAIOA Owner / Webmaster
NAIOA Administrator
NAIOA Administrator


Joined: Jun 01, 2005
Posts: 9496
Posts per day: 2.13
Location: NJ

2004 Chevrolet Impala
1998 Chevrolet Corvette
2007 Chevrolet Tahoe
2008 Subaru Impreza
1970 Chevrolet Chevelle


PostPosted: Thu Nov 18, 2010 8:44 am    Post subject:   Reply with quote

That 30A fuse feeds the blower motor control processor directly. So either the blower controller or the climate control head unit is bad

When you have the parasitic draw test running, try unplugging the blower control processor (rather than the fuse) and see if the draw goes away

BBEngineer

_________________

Decisions...Decisions...
Back to top
View user's profile Send private message Visit poster's website
cableguy
Newbie
Newbie


Joined: Nov 17, 2010
Posts: 4
Posts per day: 0


2004 Chevrolet Impala


PostPosted: Thu Nov 18, 2010 8:56 am    Post subject:   Reply with quote

BBEngineer,

Thanks for your thoughts. I don't have a wiring diagram... maybe I don't need one in order to do what you mentioned?

Could you describe where I would gain access to either the blower controller or the climate control head unit?

Under the dash? Sorry for my ignorance. Confused

~cableguy
Back to top
View user's profile Send private message
bbengineer
NAIOA Owner / Webmaster
NAIOA Administrator
NAIOA Administrator


Joined: Jun 01, 2005
Posts: 9496
Posts per day: 2.13
Location: NJ

2004 Chevrolet Impala
1998 Chevrolet Corvette
2007 Chevrolet Tahoe
2008 Subaru Impreza
1970 Chevrolet Chevelle


PostPosted: Thu Nov 18, 2010 9:25 am    Post subject:   Reply with quote

The control processor is under the passenger side dash, next to the blower motor

The head unit requires the dash bezel removal.. directions here:
http://impalahq.naioa.com/HowTo/Dash.html

BBEngineer

_________________

Decisions...Decisions...
Back to top
View user's profile Send private message Visit poster's website
Truckman
Resident
Resident


Joined: Aug 08, 2010
Posts: 701
Posts per day: 0.27
Location: Conroe Texas

2008 Chevrolet Impala


PostPosted: Thu Nov 18, 2010 2:40 pm    Post subject:   Reply with quote

All good advice...I'll move along...My work here is done... Arrow ...Ben

_________________
"Before I refuse to take your questions, I have an opening statement." - Ronald Reagan~~~~~''Life's tough, pilgrim, and it's even tougher if you're stupid.'' - John Wayne

"A thing worth having is a thing worth cheating for" - Cuthbert J. Twillie "It must be mounted on a tripod! It must be mounted on a tripod!" - Cmdr. Frederick Mohr, Imperial German Army
Back to top
View user's profile Send private message
cableguy
Newbie
Newbie


Joined: Nov 17, 2010
Posts: 4
Posts per day: 0


2004 Chevrolet Impala


PostPosted: Fri Nov 19, 2010 8:17 am    Post subject:   Reply with quote

Agreed.... wonderful advice so far. One more question before I try to troubleshoot this.

What exactly does the blower control processor look like so I know what to unplug? Is it directly adjacent to the blower motor?

I haven't had a chance to look at it because it's just been to dark after work. This will be a weekend project.

Thanks again, BBEngineer. Have a good weekend. Smile
Back to top
View user's profile Send private message
cableguy
Newbie
Newbie


Joined: Nov 17, 2010
Posts: 4
Posts per day: 0


2004 Chevrolet Impala


PostPosted: Sat Nov 27, 2010 4:18 pm    Post subject:   Reply with quote

OK... so after taking way too long to complete a simple task (LOL)... I was finally able to get the wiring out of the blower control processor.

At least, I believe it was the blower control processor... it had about 5 wires going into it and it was close to the firewall... a small rectangle about 1 inch by 3 inches.

When I unplugged that, the ammeter went to ZERO! Problem found.

Now... to fix the problem, I would imagine that I just want to install a new blower control processor.... any suggestions on the best place to purchase one? 2004 Impala.

Thanks everyone for you help so far!

~cable
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: August 17, 2017, 6:12:06 pm
Page Generation: 0.09 Seconds ( SQL 29:117 in 0.01 Seconds )