NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - Still heating up
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Still heating up
Goto page 1, 2  Next
 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion
View previous topic :: View next topic  
Author Message
A_t
Forum Regular
Forum Regular


Joined: Nov 28, 2008
Posts: 165
Posts per day: 0.05
Location: Dallas

2005 Chevrolet Impala
1987 Ford Mustang


PostPosted: Sat Sep 04, 2010 12:03 pm    Post subject: Bad ! Still heating up Reply with quote

Replaced the LIM about 1k miles ago now I'm sitting in my car hoping it will make it home cause the red low coolant light came on. I'm experiencing all the lim gasket failure symptoms. Hopefully I make it home. Later I will check the rad. for the good stuff. Mmmmm...I haven't had a shake in miles.
Back to top
View user's profile Send private message
IffyG
NAIOA Moderator
NAIOA Moderator
Silver Contributor (Amount: 1) Silver Contributor


Joined: May 19, 2007
Posts: 13731
Posts per day: 3.55
Location: Nashville, TN

2002 Chevrolet Monte Carlo
1998 Oldsmobile Intrigue
2009 Chevrolet Malibu


PostPosted: Sat Sep 04, 2010 12:05 pm    Post subject:   Reply with quote

Any reason for posting this story twice? I can't find a question... so I don't think there is anything else to post... Confused

_________________
helldorado wrote:
GLWTGFY. Big Thumbs Up

Dan wrote:
Protip: If you don't know what you're doing, don't do it.


d
Back to top
View user's profile Send private message
A_t
Forum Regular
Forum Regular


Joined: Nov 28, 2008
Posts: 165
Posts per day: 0.05
Location: Dallas

2005 Chevrolet Impala
1987 Ford Mustang


PostPosted: Sat Sep 04, 2010 12:58 pm    Post subject:   Reply with quote

I have no idea how it posted twice.....stupid iPhone. My question is, if the lim has been replaced, rad has been cleaned out and I have a new t-stat. What else could it be
Back to top
View user's profile Send private message
crazydayz
Uberd0rk!
Uberd0rk!


Joined: Mar 11, 2007
Posts: 6996
Posts per day: 1.78
Location: Somewhere in Florida

2000 Chevrolet Impala
2000 Oldsmobile Intrigue
2004 Chevrolet Impala
1997 Chevrolet S10
2006 Chevrolet TrailBlazer


PostPosted: Sat Sep 04, 2010 1:08 pm    Post subject:   Reply with quote

A_t wrote:
I have no idea how it posted twice.....stupid iPhone. My question is, if the lim has been replaced, rad has been cleaned out and I have a new t-stat. What else could it be

Did you bleed the cooling system properly?

_________________
2004 Indy Impala SS Bagged
check out - http://www.noaffiliation.net
http://www.youtube.com/thecrazydayz
http://www.cardomain.com/ride/3352096
http://www.cardomain.com/ride/2588642
Back to top
View user's profile Send private message Send e-mail AIM Address
A_t
Forum Regular
Forum Regular


Joined: Nov 28, 2008
Posts: 165
Posts per day: 0.05
Location: Dallas

2005 Chevrolet Impala
1987 Ford Mustang


PostPosted: Sat Sep 04, 2010 1:22 pm    Post subject:   Reply with quote

I believe it was. I'm waiting for the car to cool down before I open the radiator
Back to top
View user's profile Send private message
SatImpala
Resident
Resident


Joined: Jun 07, 2008
Posts: 778
Posts per day: 0.22
Location: San Antonio

2003 Chevrolet Impala
2007 Ford Mustang


PostPosted: Sat Sep 04, 2010 1:25 pm    Post subject:   Reply with quote

I had the same issue before AND after my LIM gasket fix. Always ran hot. Troubleshot every possibility and no fix, car just wanted to run hot. Changed LIM & UIM gaskets properly, bled air, checked coolant religiously, flushed system twice, changed heater core, checked all hoses, checked fan operation...nothing fixed it.
I just changed it to a 180* T-stat and dealt with it. Maybe it was a computer issue.
Have you checked to make sure your fans are turning on?

Edit: my bad I thought I read that it was running hot. Yeah sounds like you have a leak somewhere, if you don't see coolant anywhere, it's internal.

_________________
Impala sold!
Back to top
View user's profile Send private message
A_t
Forum Regular
Forum Regular


Joined: Nov 28, 2008
Posts: 165
Posts per day: 0.05
Location: Dallas

2005 Chevrolet Impala
1987 Ford Mustang


PostPosted: Sat Sep 04, 2010 7:21 pm    Post subject:   Reply with quote

Yup, it is muddy in there again Sad
Back to top
View user's profile Send private message
nnoossss
Forum Regular
Forum Regular


Joined: Sep 04, 2010
Posts: 169
Posts per day: 0.06
Location: Roanoke, VA

2002 Pontiac Trans Am


PostPosted: Sat Sep 04, 2010 8:58 pm    Post subject:   Reply with quote

i just had my water pump, gasket and fitting replaced because i was leaking coolant it was a little off both the water pump was leaking and one off the fittings were rotten also making it leak a bit.
Back to top
View user's profile Send private message Send e-mail Visit poster's website AIM Address
A_t
Forum Regular
Forum Regular


Joined: Nov 28, 2008
Posts: 165
Posts per day: 0.05
Location: Dallas

2005 Chevrolet Impala
1987 Ford Mustang


PostPosted: Sun Sep 05, 2010 10:24 am    Post subject:   Reply with quote

Well, I don't see any leaks but the car does smell like coolant. Perhaps it is burning it to fast for some reason. There is mud in the rad but not as much as there was before. It also doesn't look like there's much coolant in there either.
Back to top
View user's profile Send private message
Truckman
Resident
Resident


Joined: Aug 08, 2010
Posts: 701
Posts per day: 0.26
Location: Conroe Texas

2008 Chevrolet Impala


PostPosted: Sun Sep 05, 2010 10:40 am    Post subject:   Reply with quote

I'm guessing the cooling system was thoroughly flushed after the LIM gasket change...What does a pressure test show?... Question ...Ben

_________________
"Before I refuse to take your questions, I have an opening statement." - Ronald Reagan~~~~~''Life's tough, pilgrim, and it's even tougher if you're stupid.'' - John Wayne

"A thing worth having is a thing worth cheating for" - Cuthbert J. Twillie "It must be mounted on a tripod! It must be mounted on a tripod!" - Cmdr. Frederick Mohr, Imperial German Army
Back to top
View user's profile Send private message
A_t
Forum Regular
Forum Regular


Joined: Nov 28, 2008
Posts: 165
Posts per day: 0.05
Location: Dallas

2005 Chevrolet Impala
1987 Ford Mustang


PostPosted: Sun Sep 05, 2010 10:53 am    Post subject:   Reply with quote

Truckman wrote:
I'm guessing the cooling system was thoroughly flushed after the LIM gasket change...What does a pressure test show?... Question ...Ben

I hope the Job was done properly. I paid some guy to do it so I hope he did it right. I just hope it isn't serious. I could take it to get it flushed and bled properly but if something is wrong it's just gonna get muddy again.
Back to top
View user's profile Send private message
Truckman
Resident
Resident


Joined: Aug 08, 2010
Posts: 701
Posts per day: 0.26
Location: Conroe Texas

2008 Chevrolet Impala


PostPosted: Sun Sep 05, 2010 11:19 am    Post subject:   Reply with quote

If you paid to have the work done, is it still under warranty?... Question ...Ben

_________________
"Before I refuse to take your questions, I have an opening statement." - Ronald Reagan~~~~~''Life's tough, pilgrim, and it's even tougher if you're stupid.'' - John Wayne

"A thing worth having is a thing worth cheating for" - Cuthbert J. Twillie "It must be mounted on a tripod! It must be mounted on a tripod!" - Cmdr. Frederick Mohr, Imperial German Army
Back to top
View user's profile Send private message
IffyG
NAIOA Moderator
NAIOA Moderator
Silver Contributor (Amount: 1) Silver Contributor


Joined: May 19, 2007
Posts: 13731
Posts per day: 3.55
Location: Nashville, TN

2002 Chevrolet Monte Carlo
1998 Oldsmobile Intrigue
2009 Chevrolet Malibu


PostPosted: Sun Sep 05, 2010 11:26 am    Post subject:   Reply with quote

I hate to be the cynical one... but was the job even done in the first place?

_________________
helldorado wrote:
GLWTGFY. Big Thumbs Up

Dan wrote:
Protip: If you don't know what you're doing, don't do it.


d
Back to top
View user's profile Send private message
A_t
Forum Regular
Forum Regular


Joined: Nov 28, 2008
Posts: 165
Posts per day: 0.05
Location: Dallas

2005 Chevrolet Impala
1987 Ford Mustang


PostPosted: Sun Sep 05, 2010 11:27 am    Post subject:   Reply with quote

Truckman wrote:
If you paid to have the work done, is it still under warranty?... Question ...Ben

No warranties. I hope the job was done right. A friend of mine did the job......he's a ford tech though.
Back to top
View user's profile Send private message
05imp
Senior Level
Senior Level


Joined: Jan 01, 2006
Posts: 2302
Posts per day: 0.53
Location: Cleveland, OH

2005 Chevrolet Impala
2000 Ford Ranger
2007 Ford Explorer
2008 Chevrolet Silverado


PostPosted: Sun Sep 05, 2010 11:52 am    Post subject:   Reply with quote

Did you check and see how the antifreeze looked after the job was done?
Your friend may have just done the job but didn't bother to flush the gunk out of the cooling system.
I would recommend you at least flush the system and get it right then keep an eye on it and the fluids till you feel you can confirm or dissprove whether you still have the original problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion All times are GMT - 4 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: December 14, 2017, 4:41:57 pm
Page Generation: 0.12 Seconds ( SQL 45:146 in 0.01 Seconds )