NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - 2004 impala ss need help
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

2004 impala ss need help

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion
View previous topic :: View next topic  
Author Message
pimptight
Newbie
Newbie


Joined: Mar 11, 2010
Posts: 20
Posts per day: 0.01


2004 Chevrolet Impala


PostPosted: Tue Aug 10, 2010 10:14 am    Post subject:  2004 impala ss need help Reply with quote

i have a 2004 impala ss and for some reason when i turn left or right almost locking the wheels my traction control light come on saying traction active and the brakes feel funny then the light goes off and it's normal again can somebody please help
Back to top
View user's profile Send private message
Frank4202
Senior Level
Senior Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Jul 03, 2008
Posts: 2573
Posts per day: 0.77
Location: Windsor, Ontario, Canada

2004 Chevrolet Impala
1997 Chevrolet Corvette


PostPosted: Tue Aug 10, 2010 10:38 am    Post subject:   Reply with quote

Wheel hub/bearing assembly.

_________________


Sold 28/10/11
Back to top
View user's profile Send private message
pimptight
Newbie
Newbie


Joined: Mar 11, 2010
Posts: 20
Posts per day: 0.01


2004 Chevrolet Impala


PostPosted: Tue Aug 10, 2010 10:44 am    Post subject:   Reply with quote

can i just un plug it
Back to top
View user's profile Send private message
FooBag
Forum Regular
Forum Regular
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Jun 26, 2004
Posts: 268
Posts per day: 0.06
Location: Des Moines, IA

2004 Chevrolet Impala


PostPosted: Tue Aug 10, 2010 10:59 am    Post subject:   Reply with quote

If you unplug it, your ABS will not work, the traction control will be disabled, and every time you start the car you'll get a double chime and a 'Service Traction Control System" message. The best course of action is to replace the wheel hub. A decent shop should be able to tell you which of the front hubs is causing the problem.

_________________
'04 SS - L26 short block, VS cam, Gen V M90, other stuff. More info here.
Back to top
View user's profile Send private message
pimptight
Newbie
Newbie


Joined: Mar 11, 2010
Posts: 20
Posts per day: 0.01


2004 Chevrolet Impala


PostPosted: Tue Aug 10, 2010 11:06 am    Post subject:   Reply with quote

thanks alot i'm on my way to the shop thanks so much for the help
Back to top
View user's profile Send private message
Frank4202
Senior Level
Senior Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Jul 03, 2008
Posts: 2573
Posts per day: 0.77
Location: Windsor, Ontario, Canada

2004 Chevrolet Impala
1997 Chevrolet Corvette


PostPosted: Tue Aug 10, 2010 1:16 pm    Post subject:   Reply with quote

If your going to instal the new one yourself, get a good quality one. You can find some cheap but you'll have this same problem in a few months due to a cheap part. If your going to have a shop install it, ask what the warranty will be on the new part. I just changed mine last month with a AC Delco unit.

_________________


Sold 28/10/11
Back to top
View user's profile Send private message
pimptight
Newbie
Newbie


Joined: Mar 11, 2010
Posts: 20
Posts per day: 0.01


2004 Chevrolet Impala


PostPosted: Tue Aug 10, 2010 9:37 pm    Post subject:   Reply with quote

that's what i bought ac delco they wiil be putting it on in the morning it was the driver side i might just put the other side on to what u think at least both of them will be new i got 22"s on my car i like the way yours sit do u think i can sit mine that way with 22's go chk me out it's on cardomain.com 2004 impala it's called pudaplg it's in first place chk it out and let me know what u think
Back to top
View user's profile Send private message
Frank4202
Senior Level
Senior Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Jul 03, 2008
Posts: 2573
Posts per day: 0.77
Location: Windsor, Ontario, Canada

2004 Chevrolet Impala
1997 Chevrolet Corvette


PostPosted: Tue Aug 10, 2010 9:43 pm    Post subject:   Reply with quote

Chances are if one side went, the other side probably isn't far behind. However, if your not having any problems with the other side, I wouldn't worry about it until it becomes an issue but thats just me.

_________________


Sold 28/10/11
Back to top
View user's profile Send private message
Deezul_AwT
Dedicated
Dedicated
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Jul 14, 2007
Posts: 359
Posts per day: 0.1
Location: Cumming, GA

2004 Chevrolet Impala


PostPosted: Fri Aug 20, 2010 10:08 pm    Post subject:   Reply with quote

This sounds like it might be an issue I'm having. Since I've had my Imp, there's a slight rub/grind sound when I turn the wheel but only during startup. And within the past month, the Traction Active light will come on at start for about a second. Bad Hub? And how easy is it to replace?

_________________
2016 Ford Fusion Titanium Energi. Still trying to figure out what I can do with it...

2006 Mercury Mariner Hybrid. K&N Air filter. Can't do much else on a hybrid.

Totaled 9/19/2016 - 2004 Impala SS, Performance Car - ZZP ECM 1.0, 3.4" Pulley, K&N Cold Air Intake, TOG Headers, Random Technology Hi-Flow Cat, SLP Power-Flo Cat-Back Exhaust, Autolite 104s, PRJ Performance Ignition wires, GMPP Handling Kit
Back to top
View user's profile Send private message MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: August 23, 2017, 2:28:51 pm
Page Generation: 0.12 Seconds ( SQL 33:121 in 0.01 Seconds )