NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - black thing under the front of the car is crooked
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

black thing under the front of the car is crooked

 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion
View previous topic :: View next topic  
Author Message
soxfan2546
Forum Regular
Forum Regular
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Aug 29, 2009
Posts: 218
Posts per day: 0.07
Location: Highland, IN

2005 Chevrolet Impala


PostPosted: Mon Jan 18, 2010 2:02 pm    Post subject:  black thing under the front of the car is crooked Reply with quote

I know I've seen this somewhere else but I couldn't find it and I don't know what to search for...

the black guard thing under the front of my car is crooked. I looked at it today and theres a crack near one of the spots where it is attached. What would be the easiest way to fix it? or would I need to buy a new one off ebay or something? I really like how it looks so I don't really want to take it completely off...

_________________
Back to top
View user's profile Send private message
IffyG
NAIOA Moderator
NAIOA Moderator
Silver Contributor (Amount: 1) Silver Contributor


Joined: May 19, 2007
Posts: 13731
Posts per day: 3.61
Location: Nashville, TN

2002 Chevrolet Monte Carlo
1998 Oldsmobile Intrigue
2009 Chevrolet Malibu


PostPosted: Mon Jan 18, 2010 2:04 pm    Post subject:   Reply with quote

I think you are talking about the air dam. They run about 30 dollars at the dealer. FYI: you don't want to remove it, you run the risk of overheating if you do.

_________________
helldorado wrote:
GLWTGFY. Big Thumbs Up

Dan wrote:
Protip: If you don't know what you're doing, don't do it.


d
Back to top
View user's profile Send private message
wanderson75
Guru
Guru
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Oct 12, 2008
Posts: 4362
Posts per day: 1.32
Location: Southgate, Michigan

2005 Chevrolet Impala


PostPosted: Mon Jan 18, 2010 2:13 pm    Post subject:   Reply with quote

I've had mine off since January of last year after I blasted a piece of guard rail laying on 75. My temps through the summer never went over the halfway mark.

_________________
Shameless Plug: http://gamerliving.net
Back to top
View user's profile Send private message Visit poster's website
IffyG
NAIOA Moderator
NAIOA Moderator
Silver Contributor (Amount: 1) Silver Contributor


Joined: May 19, 2007
Posts: 13731
Posts per day: 3.61
Location: Nashville, TN

2002 Chevrolet Monte Carlo
1998 Oldsmobile Intrigue
2009 Chevrolet Malibu


PostPosted: Mon Jan 18, 2010 2:35 pm    Post subject:   Reply with quote

I guess I'm paranoid after nearly overheating when it was almost 110 a few years ago.

_________________
helldorado wrote:
GLWTGFY. Big Thumbs Up

Dan wrote:
Protip: If you don't know what you're doing, don't do it.


d
Back to top
View user's profile Send private message
soxfan2546
Forum Regular
Forum Regular
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Aug 29, 2009
Posts: 218
Posts per day: 0.07
Location: Highland, IN

2005 Chevrolet Impala


PostPosted: Mon Jan 18, 2010 2:36 pm    Post subject:   Reply with quote

I think i can just drill a small hole near the crack and ziptie it tight...

_________________
Back to top
View user's profile Send private message
WagonMafia02
Member Level
Member Level


Joined: Oct 30, 2007
Posts: 1147
Posts per day: 0.32
Location: White America

2002 Subaru Impreza


PostPosted: Mon Jan 18, 2010 3:17 pm    Post subject:   Reply with quote

wanderson75 wrote:
I've had mine off since January of last year after I blasted a piece of guard rail laying on 75. My temps through the summer never went over the halfway mark.


Strange, when mine was off for just a couple of days my temps were up drastically, almost to the redline after just a 20 minute drive. As soon as I put the air dam back on it fixed the problem.

_________________
20SS07 wrote:
You have to understand, wagonmafia is a dick. Laughing
Back to top
View user's profile Send private message
wanderson75
Guru
Guru
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Oct 12, 2008
Posts: 4362
Posts per day: 1.32
Location: Southgate, Michigan

2005 Chevrolet Impala


PostPosted: Mon Jan 18, 2010 3:53 pm    Post subject:   Reply with quote

WagonMafia02 wrote:
wanderson75 wrote:
I've had mine off since January of last year after I blasted a piece of guard rail laying on 75. My temps through the summer never went over the halfway mark.


Strange, when mine was off for just a couple of days my temps were up drastically, almost to the redline after just a 20 minute drive. As soon as I put the air dam back on it fixed the problem.


Were you running a 3.4 or a 3.8?

_________________
Shameless Plug: http://gamerliving.net
Back to top
View user's profile Send private message Visit poster's website
Wingman520
Guru
Guru
Silver Contributor (Amount: 1) Silver Contributor


Joined: Apr 15, 2008
Posts: 4127
Posts per day: 1.19
Location: Canton, Ohio

2001 Chevrolet Impala
2006 Chevrolet Impala


PostPosted: Mon Jan 18, 2010 4:13 pm    Post subject:   Reply with quote

soxfan2546 wrote:
I think i can just drill a small hole near the crack and ziptie it tight...


that's what i did... my bolt hole on the driver side rusted out and i zip tied it with the existing hole

_________________
2006 Impala LTZ 105k- Dynomax Catback Exhaust, Overkilled by Will Wink

2001 Chevy Impala- 186K Retired: 180 T stat, HV3, Wizaired Intake, GMPP Exhaust, Speed Daddy Headers, 1.9 Yella Terra Rockers, Custom LED interior, BBEngineering.com 6 Pod Cluster, Poly Mounts and Bushings, Dyno Tuned by Dyno Brian @ Dyno Tune Motorsports 181 WHP 230 WTQ
Back to top
View user's profile Send private message Send e-mail AIM Address Yahoo Messenger MSN Messenger
crazydayz
Uberd0rk!
Uberd0rk!


Joined: Mar 11, 2007
Posts: 6996
Posts per day: 1.81
Location: Somewhere in Florida

2000 Chevrolet Impala
2000 Oldsmobile Intrigue
2004 Chevrolet Impala
1997 Chevrolet S10
2006 Chevrolet TrailBlazer


PostPosted: Mon Jan 18, 2010 6:41 pm    Post subject:   Reply with quote

Wingman520 wrote:
soxfan2546 wrote:
I think i can just drill a small hole near the crack and ziptie it tight...


that's what i did... my bolt hole on the driver side rusted out and i zip tied it with the existing hole

Northern rust FTL.......... Twisted Evil

_________________
2004 Indy Impala SS Bagged
check out - http://www.noaffiliation.net
http://www.youtube.com/thecrazydayz
http://www.cardomain.com/ride/3352096
http://www.cardomain.com/ride/2588642
Back to top
View user's profile Send private message Send e-mail AIM Address
WagonMafia02
Member Level
Member Level


Joined: Oct 30, 2007
Posts: 1147
Posts per day: 0.32
Location: White America

2002 Subaru Impreza


PostPosted: Mon Jan 18, 2010 7:51 pm    Post subject:   Reply with quote

wanderson75 wrote:
WagonMafia02 wrote:
wanderson75 wrote:
I've had mine off since January of last year after I blasted a piece of guard rail laying on 75. My temps through the summer never went over the halfway mark.


Strange, when mine was off for just a couple of days my temps were up drastically, almost to the redline after just a 20 minute drive. As soon as I put the air dam back on it fixed the problem.


Were you running a 3.4 or a 3.8?


3.4 with FWI.

_________________
20SS07 wrote:
You have to understand, wagonmafia is a dick. Laughing
Back to top
View user's profile Send private message
autogeek23
Member Level
Member Level
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Nov 05, 2008
Posts: 1549
Posts per day: 0.47
Location: Cleveland OH

2003 Chevrolet Impala


PostPosted: Mon Jan 18, 2010 9:16 pm    Post subject:   Reply with quote

mine was cracked. and it kept growing. i called a dealer and they said it was $60. F that. i took it off. i noticed it ran a lil warmer than normal. but i swapped the dexcool for the green stuff and my engine runs nice and cool. unless im not moving of coarse. it goes to normal running temps when sittin still

_________________

RacePala
Back to top
View user's profile Send private message Visit poster's website AIM Address
Fallguy
Forum Regular
Forum Regular


Joined: Jan 13, 2010
Posts: 147
Posts per day: 0.05


2010 Chevrolet Impala


PostPosted: Tue Jan 19, 2010 12:57 am    Post subject:   Reply with quote

Fix by all means. This actually pushes a bubble (so to speak) of air up from the bottom which keeps the air coming in form the grill going through your radiator instead of taking the path of least resistance by going down somewhat without it and bypassing the radiator.

Good Luck
Back to top
View user's profile Send private message
Wingman520
Guru
Guru
Silver Contributor (Amount: 1) Silver Contributor


Joined: Apr 15, 2008
Posts: 4127
Posts per day: 1.19
Location: Canton, Ohio

2001 Chevrolet Impala
2006 Chevrolet Impala


PostPosted: Tue Jan 19, 2010 1:52 am    Post subject:   Reply with quote

Fallguy wrote:
Fix by all means. This actually pushes a bubble (so to speak) of air up from the bottom which keeps the air coming in form the grill going through your radiator instead of taking the path of least resistance by going down somewhat without it and bypassing the radiator.

Good Luck


agreed and just to add onto ur info there fallguy the air dam creates a low pressure current to draw the high pressure air to the radiator... the grill helps the top half and that dam helps the lower half keep it within spec at least how i see it...

_________________
2006 Impala LTZ 105k- Dynomax Catback Exhaust, Overkilled by Will Wink

2001 Chevy Impala- 186K Retired: 180 T stat, HV3, Wizaired Intake, GMPP Exhaust, Speed Daddy Headers, 1.9 Yella Terra Rockers, Custom LED interior, BBEngineering.com 6 Pod Cluster, Poly Mounts and Bushings, Dyno Tuned by Dyno Brian @ Dyno Tune Motorsports 181 WHP 230 WTQ
Back to top
View user's profile Send private message Send e-mail AIM Address Yahoo Messenger MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 General Impala Discussion All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: October 17, 2017, 10:59:42 pm
Page Generation: 0.15 Seconds ( SQL 41:140 in 0.02 Seconds )