NAIOA.comNAIOA.comNAIOA.com
 Create an Account
 

  
NAIOA Impala Forums :: View topic - p0141 code - engine light
GarageGarage    1/4 Mile Table1/4 Mile Table    Forum FAQForum FAQ    SearchSearch    UsergroupsUsergroups   MedalsMedals
MemberlistMemberlist   ProfileProfile    Watched TopicsWatched Topics    Log in to check your private messagesLog in to check your private messages    Log inLog in 

p0141 code - engine light
Goto page 1, 2  Next
 
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 Engine, Exhaust and Transmission
View previous topic :: View next topic  
Author Message
beamer5084
Newbie
Newbie


Joined: May 03, 2009
Posts: 38
Posts per day: 0.01
Location: Minneapolis, MN

2001 Chevrolet Impala


PostPosted: Wed May 06, 2009 9:32 pm    Post subject:  p0141 code - engine light Reply with quote

Engine light popped on today so I took it to autozone and it was a p0141 code. I checked the forums and did what everyone said, checked the fuse, checked the wires, then replaced the sensor. Light is still on. Mad Is there somethign else that could be wrong. I disconnected the battery but do I have to bring it in and have the code cleared? Thanks!
Back to top
View user's profile Send private message Visit poster's website
petermeridingo76
Resident
Resident
Bronze Contributor (Amount: 1) Bronze Contributor


Joined: Mar 21, 2009
Posts: 505
Posts per day: 0.17
Location: FELTS MILLS, NY

2005 Chevrolet Impala
2008 Chevrolet Impala


PostPosted: Wed May 06, 2009 10:28 pm    Post subject:   Reply with quote

well if the check engine light comes up again after driving for a few miles then yes , someone told me when you disconnest the battery to get rid of the check engine light your just reseting the pcm , i tried doing that when mine came up for my cat converter but when i went to get in inspected the mechanic tells me that it reads system not ready , he tells me to drive a few days then pow the engine light came on again.

_________________
Back to top
View user's profile Send private message Send e-mail
bbengineer
NAIOA Owner / Webmaster
NAIOA Administrator
NAIOA Administrator


Joined: Jun 01, 2005
Posts: 9496
Posts per day: 2.15
Location: NJ

2004 Chevrolet Impala
1998 Chevrolet Corvette
2007 Chevrolet Tahoe
2008 Subaru Impreza
1970 Chevrolet Chevelle


PostPosted: Wed May 06, 2009 10:32 pm    Post subject:   Reply with quote

You replaced the O2 sensor? What brand sensor did you buy?

BBEngineer

_________________

Decisions...Decisions...
Back to top
View user's profile Send private message Visit poster's website
beamer5084
Newbie
Newbie


Joined: May 03, 2009
Posts: 38
Posts per day: 0.01
Location: Minneapolis, MN

2001 Chevrolet Impala


PostPosted: Wed May 06, 2009 11:01 pm    Post subject:   Reply with quote

ACDelco
Back to top
View user's profile Send private message Visit poster's website
Sabrewings
Uberd0rk!
Uberd0rk!


Joined: Feb 15, 2006
Posts: 16858
Posts per day: 4.06
Location: Bossier City, LA

2004 Chevrolet Impala
2009 Subaru Impreza


PostPosted: Thu May 07, 2009 1:00 am    Post subject:   Reply with quote

Which sensor did you replace?

_________________

Still Imp'n, just with a different Imp.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
beamer5084
Newbie
Newbie


Joined: May 03, 2009
Posts: 38
Posts per day: 0.01
Location: Minneapolis, MN

2001 Chevrolet Impala


PostPosted: Thu May 07, 2009 11:31 am    Post subject:   Reply with quote

The one on the back of the engine, right by the firewall.
Back to top
View user's profile Send private message Visit poster's website
Sabrewings
Uberd0rk!
Uberd0rk!


Joined: Feb 15, 2006
Posts: 16858
Posts per day: 4.06
Location: Bossier City, LA

2004 Chevrolet Impala
2009 Subaru Impreza


PostPosted: Thu May 07, 2009 12:49 pm    Post subject:   Reply with quote

beamer5084 wrote:
The one on the back of the engine, right by the firewall.


Wrong sensor. P0141 is for the sensor under the car... the downstream sensor.

_________________

Still Imp'n, just with a different Imp.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
beamer5084
Newbie
Newbie


Joined: May 03, 2009
Posts: 38
Posts per day: 0.01
Location: Minneapolis, MN

2001 Chevrolet Impala


PostPosted: Thu May 07, 2009 12:52 pm    Post subject:   Reply with quote

Really? Mad The autozone guy told me it was the one on the engine. So it's the one behind the cat?
Back to top
View user's profile Send private message Visit poster's website
Sabrewings
Uberd0rk!
Uberd0rk!


Joined: Feb 15, 2006
Posts: 16858
Posts per day: 4.06
Location: Bossier City, LA

2004 Chevrolet Impala
2009 Subaru Impreza


PostPosted: Thu May 07, 2009 12:54 pm    Post subject:   Reply with quote

beamer5084 wrote:
Really? Mad The autozone guy told me it was the one on the engine. So it's the one behind the cat?


Yep. That's the downstream sensor.

_________________

Still Imp'n, just with a different Imp.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
milwaukee_01impala
Senior Level
Senior Level


Joined: Apr 04, 2007
Posts: 2579
Posts per day: 0.69
Location: hmmmm, i wonder??

2001 Chevrolet Impala
2001 Chevrolet Express


PostPosted: Fri May 08, 2009 5:59 am    Post subject:   Reply with quote

wouldnt us guys that dont have a rear o2 sensor set the p0141 code then?

would the cel automatically turn off by it self if a new sensor is installed, or does it have to be cleared?

_________________
engine(LA1)/exhaust: FWI,1.0 DHP pcm,2 1/2" ZZP dp w/highflow cat,res delete,fm 40
interior/exterior:BBEngineering led LS cluster,BBEngineering led HVAC control,BBEngineering DRL/ALC bypass,quad headlights,impala embroidered floormats,20%tint,auto ventshade vent visors,LED tail lamps/front turn signals,LED interior/reverse/license plate lights,silverstar hi/lo beams,turn signal mirrors,aftermarket moonroof,17" Helo slick rims
Back to top
View user's profile Send private message
Sabrewings
Uberd0rk!
Uberd0rk!


Joined: Feb 15, 2006
Posts: 16858
Posts per day: 4.06
Location: Bossier City, LA

2004 Chevrolet Impala
2009 Subaru Impreza


PostPosted: Fri May 08, 2009 6:18 pm    Post subject:   Reply with quote

milwaukee_01impala wrote:
wouldnt us guys that dont have a rear o2 sensor set the p0141 code then?


I think you have to actually have the sensor and it has to malfunction for it to set that code. No sensor is a different code.

milwaukee_01impala wrote:
would the cel automatically turn off by it self if a new sensor is installed, or does it have to be cleared?


All CELs will eventually go away if the problem is fixed.

_________________

Still Imp'n, just with a different Imp.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Wingman520
Guru
Guru
Silver Contributor (Amount: 1) Silver Contributor


Joined: Apr 15, 2008
Posts: 4127
Posts per day: 1.23
Location: Canton, Ohio

2001 Chevrolet Impala
2006 Chevrolet Impala


PostPosted: Fri May 08, 2009 6:20 pm    Post subject:   Reply with quote

Sabrewings wrote:
milwaukee_01impala wrote:
wouldnt us guys that dont have a rear o2 sensor set the p0141 code then?


I think you have to actually have the sensor and it has to malfunction for it to set that code. No sensor is a different code.

milwaukee_01impala wrote:
would the cel automatically turn off by it self if a new sensor is installed, or does it have to be cleared?


All CELs will eventually go away if the problem is fixed.


yeah some of them take FOREVER lol

_________________
2006 Impala LTZ 105k- Dynomax Catback Exhaust, Overkilled by Will Wink

2001 Chevy Impala- 186K Retired: 180 T stat, HV3, Wizaired Intake, GMPP Exhaust, Speed Daddy Headers, 1.9 Yella Terra Rockers, Custom LED interior, BBEngineering.com 6 Pod Cluster, Poly Mounts and Bushings, Dyno Tuned by Dyno Brian @ Dyno Tune Motorsports 181 WHP 230 WTQ
Back to top
View user's profile Send private message Send e-mail AIM Address Yahoo Messenger MSN Messenger
Conner
Forum Regular
Forum Regular


Joined: Jul 17, 2010
Posts: 294
Posts per day: 0.12
Location: Baton Rouge/Hammond, Louisiana

2002 Chevrolet Impala
2004 Chevrolet Impala


PostPosted: Mon Jan 27, 2014 4:05 pm    Post subject:   Reply with quote

anyone have a part number on that downstream o2 sensor? I have run into the check engine light code on my ss as well.
Back to top
View user's profile Send private message
Frank
Master Level
Master Level
Platinum Contributor (Amount: 1) Platinum Contributor


Joined: Aug 16, 2005
Posts: 3462
Posts per day: 0.8
Location: Colorado

2001 Chevrolet Impala


PostPosted: Mon Jan 27, 2014 5:46 pm    Post subject:   Reply with quote

Conner wrote:
anyone have a part number on that downstream o2 sensor? I have run into the check engine light code on my ss as well.

http://parts-catalog.acdelco.c.....search.php

_________________
2001 Galaxy Silver 9C1 w/ L67 and 4T65E-HD...and a few other mods. Wink
Back to top
View user's profile Send private message
Impala_03
Resident
Resident


Joined: Feb 07, 2013
Posts: 595
Posts per day: 0.37


2003 Chevrolet Impala


PostPosted: Mon Jan 27, 2014 10:37 pm    Post subject:  Re: p0141 code - engine light Reply with quote

beamer5084 wrote:
Engine light popped on today so I took it to autozone and it was a p0141 code. I checked the forums and did what everyone said, checked the fuse, checked the wires, then replaced the sensor. Light is still on. Mad Is there somethign else that could be wrong. I disconnected the battery but do I have to bring it in and have the code cleared? Thanks!


ACDelco AFS141 Oxygen Sensor downstream after cat...

ACDelco AFS109 Oxygen Sensor upstream near engine..


It's HIGHLY recommend to replace both other wise you will need to replace the other one later on like I have to do ...

I should know since I replace one all ready and now the other is acting up... (replaced in OCT 2012)
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NAIOA Impala Forums Forum Index -> 2000-2005 Engine, Exhaust and Transmission All times are GMT - 4 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©
All logos and trademarks in this site are property of their respective owner. Comments and posts are property of the poster. All other content is © 2008 by the NAIOA.


Use of this site constitutes agreement with the NAIOA Terms of Service (TOS)


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Server Local Time: June 25, 2017, 5:22:09 am
Page Generation: 0.13 Seconds ( SQL 45:140 in 0.01 Seconds )